View Issue Details

This bug affects 1 person(s).
 8
IDProjectCategoryView StatusLast Update
17039Bug reportsSurvey editingpublic2022-07-20 11:23
Reporterjcarberry Assigned ToDenisChenu  
PrioritylowSeveritypartial_block 
Status closedResolutionfixed 
Product Version3.25.10 
Fixed in Version5.3.x 
Summary17039: Missing .map files under tmp/etc.
Description

404 error about map file

Steps To Reproduce
  1. Create a question of List(radio) type.
  2. Save the question
  3. Open the Answer editor
  4. Enter a value for the answer (maybe you have to save first, maybe not)
  5. Click on the pencil to open the html editor for the answer.
Additional Information

The browser console shows the following errors when the Edit answer page is opened:

DevTools failed to load SourceMap: Could not load content for mysite.com/tmp/assets/25344783/css/lime-admin-colors.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
DevTools failed to load SourceMap: Could not load content for mysite.com/tmp/assets/939bb6f0/bootstrap.min.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
DevTools failed to load SourceMap: Could not load content for mysite.com/tmp/assets/bfe5b166/build/adminbasics.min.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
DevTools failed to load SourceMap: Could not load content for mysite.com/tmp/assets/cbc4a337/build.min...dminsidepanel.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
2DevTools failed to load SourceMap: Could not load content for mysite.com/tmp/assets/232678a5/build/lstutorial.min.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

None of these .map files are on disk.

Permissions for the tmp directory and below: the owner and group have rw permissions everywhere.

TagsNo tags attached.
Bug heat8
Complete LimeSurvey version number (& build)Version 3.25.10+210128
I will donate to the project if issue is resolvedNo
BrowserFirefox
Database type & versionMySQL 5.7
Server OS (if known)Linux something
Webserver software & version (if known)Apache
PHP Version7.4

Users monitoring this issue

User List DenisChenu

Activities

jcarberry

jcarberry

2021-01-30 11:49

reporter   ~61817

This can be closed. It is not a bug in limesurvey. It was due to a directive in an .htaccess file above the limesurvey directory.

DenisChenu

DenisChenu

2021-01-30 14:56

developer   ~61820

DevTools failed to load SourceMap: Could not load content for mysite.com/tmp/assets/25344783/css/lime-admin-colors.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

Still an issue,

I update the title

gabrieljenik

gabrieljenik

2022-07-19 20:22

manager   ~71025

@DenisChenu Still an issue?

DenisChenu

DenisChenu

2022-07-20 11:22

developer   ~71047

No map in /lime-admin-colors.css : fixed.

Issue History

Date Modified Username Field Change
2021-01-29 20:50 jcarberry New Issue
2021-01-30 09:25 DenisChenu Issue Monitored: DenisChenu
2021-01-30 11:49 jcarberry Note Added: 61817
2021-01-30 14:56 DenisChenu Note Added: 61820
2021-01-30 14:57 DenisChenu Description Updated
2021-01-30 18:08 cdorin Priority none => low
2021-01-30 18:08 cdorin Status new => confirmed
2022-07-19 20:22 gabrieljenik Note Added: 71025
2022-07-19 20:22 gabrieljenik Bug heat 6 => 8
2022-07-19 20:22 gabrieljenik Status confirmed => feedback
2022-07-20 11:22 DenisChenu Note Added: 71047
2022-07-20 11:23 DenisChenu Assigned To => DenisChenu
2022-07-20 11:23 DenisChenu Status feedback => closed
2022-07-20 11:23 DenisChenu Resolution open => fixed
2022-07-20 11:23 DenisChenu Fixed in Version => 5.3.x