View Issue Details

IDProjectCategoryView StatusLast Update
17023Bug reportsSurvey editingpublic2021-02-18 13:15
Reportertpartner Assigned Toollehar  
PrioritynormalSeverityblock 
Status closedResolutionfixed 
Product Version4.4.0-RC3 
Target Version4.4.0-RC3 
Summary17023: Question editor broken
Description

The question and text-elements WYSIWYG editor does not work.

See attached screen-cast #44 - https://screencast-o-matic.com/watch/crVuFqRQft

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.4.0-RC4
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
Browsern/a
Database & DB-Version10.3.16-MariaDB
Server OS (if known)XAMPP on Windows 10
Webserver software & version (if known)Apache/2.4.39 (Win64)
PHP Version7.3.7

Activities

cdorin

cdorin

2021-01-28 19:32

manager   ~61762

PR to be tested: https://github.com/LimeSurvey/LimeSurvey/pull/1731 .

tpartner

tpartner

2021-01-28 20:19

developer   ~61781

Last edited: 2021-01-28 20:20

View 2 revisions

My testing of the PR:

  • Default: loads the source-code editor. (not sure that should be the case)
  • Inline HTML editor: editor does not load.
  • Popup HTML editor: initially looks okay bot no editor actually loads in the pop-up.
  • Source code editor: works.
cdorin

cdorin

2021-01-28 20:20

manager   ~61782

Thanks for your time, @tpartner!
@gabrieljenik, could you please take a look at it?

gabrieljenik

gabrieljenik

2021-02-01 14:42

developer   ~61843

Last edited: 2021-02-12 16:47

View 2 revisions

These are the steps we followed.
I couldn't reproduce it.


Checked out PR 1731
Tested with clean DB.
Default editor on Personal Settings: Default
Default editor on Global Settings: Inline

Question Editor tests:
Personal Setting Default - Global Setting Inline: works OK
PS Default - GS Popup: works OK
PS Default - GS Source Code: works OK
PS Inline: works OK
PS Popup: works OK
PS Source Code: works OK

tpartner

tpartner

2021-02-01 15:08

developer   ~61844

No need to yell. :)

I incorporated the PR changes manually.

I will test again when the pull PR is approved and I can test with a simple pull from /master and an existing database (as a normal user upgrading).

gabrieljenik

gabrieljenik

2021-02-01 21:15

developer   ~61852

No need to yell. :)

Haha! How did those big letter got there!

tpartner

tpartner

2021-02-16 14:48

developer   ~62287

Update...

In 4.4.8, the "HTML editor mode" setting seems to work for everything except "Default". That still gives me the source code editor - should that be the default?

There is no editor in the email templates - is that expected?

gabrieljenik

gabrieljenik

2021-02-17 19:04

developer   ~62329

HI Tony !

I couldn't reproduce the issues you mentioned.

In 4.4.8, the "HTML editor mode" setting seems to work for everything except "Default". That still gives me the source code editor - should that be the default?

"Default" means "look into the global settings".

There was an issue about upgrade and html editor personal settings.
Maybe after upgarde you will find things fixed?

There is no editor in the email templates - is that expected?

Couldn't reproduce this.

Thanks!

tpartner

tpartner

2021-02-17 20:15

developer   ~62330

The default setting now seems to work as expected.

Regarding the emails - there is an editor for the User administration email, but not for the survey emails. Please see attached screenshots.

capture_5.png (28,724 bytes)   
capture_5.png (28,724 bytes)   
capture_6.png (44,898 bytes)   
capture_6.png (44,898 bytes)   
DenisChenu

DenisChenu

2021-02-18 08:10

developer   ~62332

Regarding the emails - there is an editor for the User administration email, but not for the survey emails. Please see attached screenshots.

Email is set as HTML in Survey setting ?

tpartner

tpartner

2021-02-18 12:31

developer   ~62349

No, I didn't know that was required. Where is it documented?

DenisChenu

DenisChenu

2021-02-18 12:37

developer   ~62350

If email is set as text : it's better if email editor show as text. If you show HTML editor and send text … email are broken :)

https://manual.limesurvey.org/Participant_settings#Use_HTML_format_for_token_emails

ollehar

ollehar

2021-02-18 12:40

administrator   ~62351

Can I close this? Email templates is a separate issue.

tpartner

tpartner

2021-02-18 13:13

developer   ~62352

@DenisChenu, nothing was said about the editor at your linked documentation. I have updated it - https://manual.limesurvey.org/Participant_settings#Use_HTML_format_for_token_emails.

@ollehar, sure.

Issue History

Date Modified Username Field Change
2021-01-28 19:25 tpartner New Issue
2021-01-28 19:32 cdorin Note Added: 61762
2021-01-28 19:32 cdorin Priority none => normal
2021-01-28 19:32 cdorin Status new => confirmed
2021-01-28 20:19 tpartner Note Added: 61781
2021-01-28 20:20 tpartner Note Edited: 61781 View Revisions
2021-01-28 20:20 cdorin Note Added: 61782
2021-02-01 14:42 gabrieljenik Note Added: 61843
2021-02-01 15:08 tpartner Note Added: 61844
2021-02-01 21:15 gabrieljenik Note Added: 61852
2021-02-12 16:47 gabrieljenik Note Edited: 61843 View Revisions
2021-02-16 14:48 tpartner Note Added: 62287
2021-02-17 19:04 gabrieljenik Note Added: 62329
2021-02-17 20:15 tpartner Note Added: 62330
2021-02-17 20:15 tpartner File Added: capture_5.png
2021-02-17 20:15 tpartner File Added: capture_6.png
2021-02-18 08:10 DenisChenu Note Added: 62332
2021-02-18 12:31 tpartner Note Added: 62349
2021-02-18 12:37 DenisChenu Note Added: 62350
2021-02-18 12:40 ollehar Note Added: 62351
2021-02-18 13:13 tpartner Note Added: 62352
2021-02-18 13:15 ollehar Assigned To => ollehar
2021-02-18 13:15 ollehar Status confirmed => closed
2021-02-18 13:15 ollehar Resolution open => fixed