View Issue Details

This bug affects 1 person(s).
 10
IDProjectCategoryView StatusLast Update
17010Bug reportsSurvey editingpublic2021-02-08 13:30
Reportertpartner Assigned Togabrieljenik  
PriorityhighSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.4.0-RC3 
Target Version4.4.0-RC3 
Summary17010: Admin personal setting not implemented
DescriptionThe admin personal settings are saved but not implemented.

See screen-cast #40 - https://screencast-o-matic.com/watch/crVOFQ99nn
TagsNo tags attached.
Bug heat10
Complete LimeSurvey version number (& build)4.4.0-RC4
I will donate to the project if issue is resolvedNo
Browsern/a
Database type & version10.3.16-MariaDB
Server OS (if known)Windows 10
Webserver software & version (if known)Apache/2.4.39 (Win64)
PHP Version7.3.7

Relationships

related to 16935 closedgabrieljenik Directly show Editor mode from my profile not working 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

DenisChenu

DenisChenu

2021-01-27 13:00

developer   ~61699

See 16935: Directly show Editor mode from my profile not working
https://bugs.limesurvey.org/view.php?id=16935
cdorin

cdorin

2021-01-28 19:35

manager   ~61764

Last edited: 2021-01-28 20:10

Try 4.4.0, @tpartner. Should be fixed in there (was fixed earlier today)
tpartner

tpartner

2021-01-28 20:04

developer   ~61775

Last edited: 2021-01-28 20:10

Tested with a pull from master minutes ago.

- "Preselected question type" still defaults to Array, regardless of setting.
- "Date format" defaults to mm-dd-yyy, regardless of setting.
- "Lock question organizer in sidebar by default" seems to be the opposite of the setting.
cdorin

cdorin

2021-01-28 20:09

manager   ~61778

Last edited: 2021-01-28 20:10

Great, thanks!
gabrieljenik

gabrieljenik

2021-02-02 17:11

manager   ~61860

> "Date format" defaults to mm-dd-yyy, regardless of setting.

Have you spotted any specific place where this is not working.
I am asking as there could be lot of places where this is used.
Tracking them will be hard, but at least we could start with 1 and then see how it goes.
gabrieljenik

gabrieljenik

2021-02-02 17:14

manager   ~61861

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1740

Default question type & Lock question organizer are fixed.
gabrieljenik

gabrieljenik

2021-02-08 13:09

manager   ~62000

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30999
lime_release_bot

lime_release_bot

2021-02-08 13:30

administrator   ~62005

Fixed in Release 4.4.2+210208

Related Changesets

LimeSurvey: master 621664f0

2021-02-08 13:00:00

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 17010: Admin personal setting not implemented (#1740)

Default question type & Lock question organizer are fixed.
Affected Issues
17010
mod - application/controllers/QuestionAdministrationController.php Diff File
mod - application/models/QuestionCreate.php Diff File
mod - application/views/layouts/sidemenu.php Diff File

Issue History

Date Modified Username Field Change
2021-01-26 19:14 tpartner New Issue
2021-01-27 13:00 DenisChenu Note Added: 61699
2021-01-27 13:00 DenisChenu Relationship added related to 16935
2021-01-28 19:35 cdorin Note Added: 61764
2021-01-28 19:35 cdorin Status new => feedback
2021-01-28 20:04 tpartner Note Added: 61775
2021-01-28 20:04 tpartner Status feedback => new
2021-01-28 20:09 cdorin Note Added: 61778
2021-01-28 20:09 cdorin Priority none => high
2021-01-28 20:09 cdorin Status new => confirmed
2021-01-28 20:09 cdorin Sync to Zoho Project => |Yes|
2021-02-02 17:11 gabrieljenik Note Added: 61860
2021-02-02 17:14 gabrieljenik Note Added: 61861
2021-02-08 13:09 gabrieljenik Changeset attached => LimeSurvey master 621664f0
2021-02-08 13:09 gabrieljenik Note Added: 62000
2021-02-08 13:09 gabrieljenik Assigned To => gabrieljenik
2021-02-08 13:09 gabrieljenik Resolution open => fixed
2021-02-08 13:30 lime_release_bot Sync to Zoho Project Yes => |Yes|
2021-02-08 13:30 lime_release_bot Note Added: 62005
2021-02-08 13:30 lime_release_bot Status confirmed => closed