View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
16876Bug reportsSurvey editingpublic2021-03-25 16:39
Reportertpartner Assigned Togabrieljenik  
PriorityhighSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.3.29 
Target Version4.0.x 
Summary16876: Localization (i18n) does not work in custom question themes
DescriptionWhen using the <i18n>1</i18n> tag in a custom question attribute, the value saved for that attribute is not displayed - the default value is always shown.

When the <i18n>1</i18n> tag is removed, the values are displayed as expected.
Steps To ReproduceImport the attached question theme.
Import the attached survey.
Ensure that Q1 is set to the Social-Value-Orientation theme.
Save a value in the Custom options --> Primary top label text setting.
Save the question.
Preview the question or group - the top (and bottom) labels are "..." which is the default setting, not the saved setting.
TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)4.3.29
I will donate to the project if issue is resolvedNo
Browsern/a
Database & DB-Version10.3.16-MariaDB - mariadb.org binary distribution
Server OS (if known)Windows 10
Webserver software & version (if known)Apache/2.4.39 (Win64)
PHP Version7.3.7

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

tpartner

tpartner

2020-12-04 18:40

developer  

capture_2.png (30,721 bytes)   
capture_2.png (30,721 bytes)   
capture_5.png (10,798 bytes)   
capture_5.png (10,798 bytes)   
capture_4.png (24,686 bytes)   
capture_4.png (24,686 bytes)   
capture_3.png (9,610 bytes)   
capture_3.png (9,610 bytes)   
DenisChenu

DenisChenu

2020-12-05 12:47

developer   ~60844

Last edited: 2020-12-05 12:47

View 2 revisions

Thanks to report this one ;)

https://bugs.limesurvey.org/view.php?id=16730#c60663
gabrieljenik

gabrieljenik

2021-03-25 14:02

manager   ~63600

Couldn't reproduce on master
tpartner

tpartner

2021-03-25 14:30

developer   ~63604

Yes, it appears to have been fixed. It tests okay for me now.

Issue History

Date Modified Username Field Change
2020-12-04 18:40 tpartner New Issue
2020-12-04 18:40 tpartner Status new => assigned
2020-12-04 18:40 tpartner Assigned To => cdorin
2020-12-04 18:40 tpartner File Added: capture_2.png
2020-12-04 18:40 tpartner File Added: limesurvey_survey_545624.lss
2020-12-04 18:40 tpartner File Added: capture_5.png
2020-12-04 18:40 tpartner File Added: capture_4.png
2020-12-04 18:40 tpartner File Added: capture_3.png
2020-12-04 18:40 tpartner File Added: Social-Value-Orientation.zip
2020-12-05 12:47 DenisChenu Note Added: 60844
2020-12-05 12:47 DenisChenu Note Edited: 60844 View Revisions
2020-12-28 18:33 cdorin Assigned To cdorin =>
2020-12-28 18:33 cdorin Priority none => high
2020-12-28 18:33 cdorin Status assigned => confirmed
2021-02-08 17:34 ollehar Severity crash => partial_block
2021-03-25 14:02 gabrieljenik Note Added: 63600
2021-03-25 14:30 tpartner Note Added: 63604
2021-03-25 16:39 gabrieljenik Assigned To => gabrieljenik
2021-03-25 16:39 gabrieljenik Status confirmed => closed
2021-03-25 16:39 gabrieljenik Resolution open => fixed