View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
16851Bug reportsSurvey editingpublic2021-03-03 16:12
Reportermedhat Assigned Toollehar  
PrioritynoneSeverityblock 
Status closedResolutionfixed 
Product Version4.3.22 
Summary16851: HTML email template is not previewed properly for admin or users
Description

There are many bugs in email template:

1- multilingual characters are not interpreted properly in sending page
2- html is not interpreted properly in email template once sent (screenshot img1)
3- html code format gets when toggling between to source mode and

Steps To Reproduce

1- enable html emails in global settings
2- create an html email in "email templates" using table, tr & td tags and probably some images

Now to check the bugs:
1- toggle to source mode more than once: spaces will be removed from html code and will it be hard to edit (check screenshot 1)
2- add some text in non-ascii characters (Arabic, Chinese, Indian...etc) and try to send invitation to a participant: the non-ascii code will shown encoded in sending page and you will be clueless about what is being sent to the participant (screenshot 2)
3- html will be corrupted in the email received by the participant (screenshot 3)

Additional Information

This bug is also related to bug # 16601

TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)4.3.22+201019
I will donate to the project if issue is resolvedNo
BrowserChrome
Database type & versionMS Sql Server 2016
Server OS (if known)Windows
Webserver software & version (if known)IIS
PHP Version7.2.29

Relationships

related to 16601 closedcdorin HTML email template is not previewed properly 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

medhat

medhat

2020-11-22 06:45

reporter  

medhat

medhat

2020-11-22 06:51

reporter   ~60730

html email - screenshot3.png (32,010 bytes)   
html email - screenshot3.png (32,010 bytes)   
cdorin

cdorin

2020-12-23 17:57

manager   ~61135

Hello @medhat ,
Could you please check if everything works fine in 4.4.0 RC1?

ollehar

ollehar

2021-03-03 16:12

administrator   ~62687

Hello medhat,

we have asked for feedback on this issue. Because we did not get an answer we assume that the issue is resolved.
However, should you be able to reproduce the issue using the latest version, please feel free to re-open the issue and give us exact details on how to reproduce it.

Thank you and best regards,

ollehar

Issue History

Date Modified Username Field Change
2020-11-22 06:45 medhat New Issue
2020-11-22 06:45 medhat File Added: html email - screenshot3.png
2020-11-22 06:45 medhat File Added: html email - screenshot2.png
2020-11-22 06:45 medhat File Added: html email - screenshot1.png
2020-11-22 06:50 medhat File Deleted: html email - screenshot3.png
2020-11-22 06:51 medhat Note Added: 60730
2020-11-22 06:51 medhat File Added: html email - screenshot3.png
2020-11-22 11:13 DenisChenu Relationship added related to 16601
2020-12-23 17:57 cdorin Status new => feedback
2020-12-23 17:57 cdorin Description Updated
2020-12-23 17:57 cdorin Steps to Reproduce Updated
2020-12-23 17:57 cdorin Note Added: 61135
2021-03-03 16:12 ollehar Assigned To => ollehar
2021-03-03 16:12 ollehar Status feedback => closed
2021-03-03 16:12 ollehar Resolution open => fixed
2021-03-03 16:12 ollehar Note Added: 62687