View Issue Details

IDProjectCategoryView StatusLast Update
16831Bug reportsSurvey editingpublic2021-01-05 15:25
Reportershipizhan Assigned Tovharris  
PrioritylowSeverityfeature 
Status resolvedResolutionopen 
Product Version4.3.26 
Summary16831: Drag the question
Description

In the questionnaire question list, when I drag the same group of questions, everything is normal. When I drag cross group questions, the order of other questions in the drag in group changes

Steps To Reproduce

Create a questionnaire and create multiple groups, each group create more than three questions, drag the question

Additional Information

This is an interactive experience that affects the usage

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.3.26
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
Browser
Database & DB-Version5.6
Server OS (if known)
Webserver software & version (if known)
PHP Version7.4

Activities

cdorin

cdorin

2020-11-13 13:56

manager   ~60633

hey there and thx for report! Which db are you using? And OS?

shipizhan

shipizhan

2020-11-16 03:09

reporter   ~60641

mysql5.6 edition,php7.4 edition.Linux 4.19.76-linuxkit #1 SMP Tue May 26 11:42:35 UTC 2020 x86_64 GNU/Linux

shipizhan

shipizhan

2020-11-16 07:44

reporter   ~60642

4.3.26

shipizhan

shipizhan

2020-11-17 03:20

reporter   ~60676

For example, the first question in the second group should be placed after the last question in the first group. After moving, it is found that the last question in the first group is in front of the first group。

cdorin

cdorin

2020-12-23 19:00

manager   ~61146

to be tested if 4.4.0 RC1 is affected

vharris

vharris

2021-01-05 15:25

manager   ~61438

Unable to reproduce. Dragging questions now works as expected (LS 4.3.33).

Issue History

Date Modified Username Field Change
2020-11-13 09:09 shipizhan New Issue
2020-11-13 13:56 cdorin Note Added: 60633
2020-11-13 13:56 cdorin Status new => feedback
2020-11-16 03:09 shipizhan Note Added: 60641
2020-11-16 03:09 shipizhan Status feedback => new
2020-11-16 07:44 shipizhan Note Added: 60642
2020-11-17 03:20 shipizhan Note Added: 60676
2020-11-17 03:20 shipizhan File Added: 企业微信截图_16055795472449.png
2020-12-23 19:00 cdorin Assigned To => vharris
2020-12-23 19:00 cdorin Status new => feedback
2020-12-23 19:00 cdorin Note Added: 61146
2020-12-23 19:01 cdorin Priority none => low
2021-01-05 15:25 vharris Note Added: 61438
2021-01-05 15:25 vharris Status feedback => resolved