View Issue Details

IDProjectCategoryView StatusLast Update
16729Bug reportsOtherpublic2020-11-30 11:40
Reporterritapas Assigned Togabrieljenik  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.23.5 
Summary16729: Message has no translation
Description

When you take a preview of a survey in a language different from English, the last page looks like:

Salvataggio non riuscito Your survey responses have not been recorded. This survey is not yet active.

That is: First part is the "Did not save" in the other language while "Your survey responses ... active." is still in English.
Apparently this "Your survey responses have not been recorded. This survey is not yet active." string goes untranslated.

indeed, the "Your survey responses have not been recorded. This survey is not yet active." cannot be found among the translatable ones.

Steps To Reproduce

create survey in language different from english.
Preview, submit and see (pic in italian).

This happens in the 4.3.18 demo as well (see pic in french)

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.23.5 (build 200923)
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
Browser
Database & DB-Versionn/a
Server OS (if known)
Webserver software & version (if known)
PHP Versionn/a

Activities

ritapas

ritapas

2020-10-09 14:54

reporter  

immagine.png (17,193 bytes)   
immagine.png (17,193 bytes)   
immagine-2.png (16,539 bytes)   
immagine-2.png (16,539 bytes)   
gabrieljenik

gabrieljenik

2020-11-05 20:38

developer   ~60572

The problem here seems to be that the translation bot is not scanning twig files.
@olle Should we add this manually to the POT file? Should we add the literal to a PHP file (just in a dummy way, will not be used) as to have the bot to pick it up?

Look forward yto your comments

DenisChenu

DenisChenu

2020-11-06 08:28

developer   ~60574

@olle Should we add this manually to the POT file? Should we add the literal to a PHP file (just in a dummy way, will not be used) as to have the bot to pick it up?

It's a general question … in general i try to put the string in a PHP file even if not used. But it can broke easily ;)

gabrieljenik

gabrieljenik

2020-11-06 13:36

developer   ~60581

Maybe we can create a reserved dummy PHP file with all Twig literals, as to have the bot scan it.
@olle, what are your thoughts?

gabrieljenik

gabrieljenik

2020-11-11 22:26

developer   ~60617

@ollehar ping

DenisChenu

DenisChenu

2020-11-12 07:50

developer   ~60618

Else , sometimes : it come from tmp directory (currently)

gabrieljenik

gabrieljenik

2020-11-16 16:51

developer   ~60668

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1656
Add dummy file for storing translatable literals only present in twig files

gabrieljenik

gabrieljenik

2020-11-27 13:53

developer   ~60784

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30752

lime_release_bot

lime_release_bot

2020-11-30 11:40

administrator   ~60802

Fixed in Release 3.25.2+201131

Related Changesets

LimeSurvey: 3.x-LTS 3b1850f8

2020-11-27 13:53:18

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 16729: Message has no translation (#1656)

Add dummy file for storing translatable literals only present in twig files
Affected Issues
16729
add - application/helpers/twig_translation_helper.php Diff File

Issue History

Date Modified Username Field Change
2020-10-09 14:54 ritapas New Issue
2020-10-09 14:54 ritapas File Added: immagine.png
2020-10-09 14:54 ritapas File Added: immagine-2.png
2020-10-13 17:19 cdorin Assigned To => gabrieljenik
2020-10-13 17:19 cdorin Status new => assigned
2020-11-05 20:38 gabrieljenik Note Added: 60572
2020-11-06 08:28 DenisChenu Note Added: 60574
2020-11-06 13:36 gabrieljenik Note Added: 60581
2020-11-11 22:26 gabrieljenik Note Added: 60617
2020-11-12 07:50 DenisChenu Note Added: 60618
2020-11-16 16:51 gabrieljenik Note Added: 60668
2020-11-27 13:53 gabrieljenik Changeset attached => LimeSurvey 3.x-LTS 3b1850f8
2020-11-27 13:53 gabrieljenik Note Added: 60784
2020-11-27 13:53 gabrieljenik Resolution open => fixed
2020-11-30 11:40 lime_release_bot Note Added: 60802
2020-11-30 11:40 lime_release_bot Status assigned => closed