View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
16557Bug reportsTheme editorpublic2020-11-02 18:48
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionunable to reproduce 
Product Version4.3.7 
Fixed in Version4.3.23 
Summary16557: Vanilla : upload theme logo in survey broken
DescriptionWith Vanilla upload image at theme or children is OK.
But receive an error in survey if 1st time
Steps To ReproduceCreate a new survey
Set Vanilla for theme when create
Go to survey option
Upload a image via the button
undefined error
Additional InformationReload ,
Upload an image : OK, no error
TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)4.3.7 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database type & versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 16555 closedDenisChenu bootswatch Image uploaded via Survey theme option are uploaded in Global directory 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

DenisChenu

DenisChenu

2020-07-31 19:58

developer  

DenisChenu

DenisChenu

2020-07-31 20:01

developer   ~59242

The url at 1st time seems broken
DenisChenu

DenisChenu

2020-07-31 20:01

developer   ~59243

user225042

2020-08-04 10:18

  ~59283

Tested the issue in the latest version. Was able to replicate the issue successfully.
Please refer the attachment for more details.
16558_Error.png (216,944 bytes)
Mazi

Mazi

2020-11-02 18:34

partner   ~60500

I can reproduce the problem at LS 3.x. Trying to upload a custom PNG file at the survey's theme options fails with a 500 server error, see screenshot.
image.png (49,282 bytes)   
image.png (49,282 bytes)   
DenisChenu

DenisChenu

2020-11-02 18:42

developer   ~60501

In 3.X : it work with my test server and my online server.

Maybe directory permission issue.
DenisChenu

DenisChenu

2020-11-02 18:48

developer   ~60502

Seem fixed in 4.3.23

And proof for 3. X : https://gfycat.com/fr/validvictorioushuemul

I close

Issue History

Date Modified Username Field Change
2020-07-31 19:58 DenisChenu New Issue
2020-07-31 19:58 DenisChenu File Added: Capture d’écran du 2020-07-31 19-56-44.png
2020-07-31 20:01 DenisChenu Note Added: 59242
2020-07-31 20:01 DenisChenu File Added: Capture d’écran du 2020-07-31 19-59-58.png
2020-07-31 20:01 DenisChenu Note Added: 59243
2020-07-31 20:01 DenisChenu File Added: Capture d’écran du 2020-07-31 20-00-44.png
2020-08-04 10:18 user225042 Note Added: 59283
2020-08-04 10:18 user225042 File Added: 16558_Error.png
2020-08-04 10:18 user225042 Status new => confirmed
2020-08-04 11:44 DenisChenu Summary Vanilla : upload theme logoi in survey broken => Vanilla : upload theme logo in survey broken
2020-08-04 11:45 DenisChenu Relationship added related to 16555
2020-11-02 18:34 Mazi Note Added: 60500
2020-11-02 18:34 Mazi File Added: image.png
2020-11-02 18:42 DenisChenu Note Added: 60501
2020-11-02 18:48 DenisChenu Note Added: 60502
2020-11-02 18:48 DenisChenu Assigned To => DenisChenu
2020-11-02 18:48 DenisChenu Status confirmed => closed
2020-11-02 18:48 DenisChenu Resolution open => unable to reproduce
2020-11-02 18:48 DenisChenu Fixed in Version => 4.3.23