View Issue Details

IDProjectCategoryView StatusLast Update
16537Bug reportsTheme editorpublic2020-12-23 18:02
ReporterMazi Assigned Tocdorin  
PrioritynoneSeverityblock 
Status closedResolutionduplicate 
Product Version3.22.28 
Summary16537: Regression: Missing option to edit "printable survey" files at theme editor
DescriptionAt LS 2.73.x one was able to edit the core theme files for the "printable survey" feature, see attached screenshot. At LS 3 the same files exit as twig files but the user is not able to edit them using the theme editor,
This is a regression that should be fixed at LS3 and probably also LS 4.
Steps To ReproduceSearch for the "printalbe survey" screen at the LS3 theme editor -> it is missing.
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.22.28+200728
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)Ubuntu 18
Webserver software & version (if known)Apache
PHP Version7.2.26

Relationships

duplicate of 15588 confirmed Can't edit files for printable survey 
related to 16742 assignedgabrieljenik Export with printable HTML export default template in zip file 

Activities

Mazi

Mazi

2020-07-29 10:51

partner  

print_survey.png (105,043 bytes)
Mazi

Mazi

2020-07-29 12:19

partner   ~59149

Update: Partially the screen seems to be there at LS 3 but it is named "PDF" -> Why?

Furthermore, there is only the file "layout_print.twig" available. The files for groups and questions are missing.
Mazi

Mazi

2020-07-31 15:32

partner   ~59233

Funny thing, looks like I had already reported this last year: https://bugs.limesurvey.org/view.php?id=15588
Mazi

Mazi

2020-10-20 11:19

partner   ~60296

@cdorin, can you have a look at this one?
DenisChenu

DenisChenu

2020-10-21 08:55

developer   ~60324

> At LS 3 the same files exit as twig files but the user is not able to edit them using the theme editor,

Are the used when use Printable survey ? It's an issue in editor or in printable function ?
Mazi

Mazi

2020-10-21 09:03

partner   ~60325

@DenisChenu, I think it is an issue with the editor. These files are no available for editing: https://github.com/LimeSurvey/LimeSurvey/tree/master/themes/survey/vanilla/views/subviews/print

But adjusting the printable survey requires being able to edit those files.
DenisChenu

DenisChenu

2020-10-21 09:21

developer   ~60326

> But adjusting the printable survey requires being able to edit those files.

Yes, i know, but if you have a FTP access : you can quickly check :).

PS : you can also add it in your config.xml file i think : https://github.com/LimeSurvey/LimeSurvey/blob/73312b03077e934385d0a7dfc6b845175db6c775/themes/survey/vanilla/config.xml#L101
or https://gitlab.com/SondagesPro/SurveyThemes/skelvanilla/-/blob/master/config.xml#L280
Mazi

Mazi

2020-10-21 09:26

partner   ~60327

Yes, of course YOU can do that. But the common user is not able to do that.

In LS 2.73 it was possible so I marked it as a regression.
Mazi

Mazi

2020-12-07 10:28

partner   ~60849

@cdorin, this is a regression which should be fixed.
cdorin

cdorin

2020-12-23 18:02

manager   ~61138

duplicate

Issue History

Date Modified Username Field Change
2020-07-29 10:51 Mazi New Issue
2020-07-29 10:51 Mazi File Added: print_survey.png
2020-07-29 12:19 Mazi Note Added: 59149
2020-07-31 15:31 Mazi Relationship added duplicate of 15588
2020-07-31 15:32 Mazi Note Added: 59233
2020-10-20 11:19 Mazi Note Added: 60296
2020-10-21 08:54 DenisChenu Relationship added related to 16742
2020-10-21 08:55 DenisChenu Note Added: 60324
2020-10-21 09:03 Mazi Note Added: 60325
2020-10-21 09:21 DenisChenu Note Added: 60326
2020-10-21 09:26 Mazi Note Added: 60327
2020-12-07 10:28 Mazi Note Added: 60849
2020-12-23 18:02 cdorin Assigned To => cdorin
2020-12-23 18:02 cdorin Status new => closed
2020-12-23 18:02 cdorin Resolution open => duplicate
2020-12-23 18:02 cdorin Note Added: 61138