View Issue Details

IDProjectCategoryView StatusLast Update
16455Bug reportsStatisticspublic2021-02-23 14:05
ReporterJmantysalo Assigned Togabrieljenik  
PriorityhighSeveritypartial_block 
Status resolvedResolutionfixed 
Product Version4.3.2 
Summary16455: Public statistics for Ranking question not shown
Description

In LS3 I had an example survey asking favorite colors in a ranking question with public statistics. It does not work anymore in LS4, statistics after taking the survey are not shown.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Versio 4.3.2+200629
I will donate to the project if issue is resolvedNo
Sync to Zoho ProjectYes
Browser
Database & DB-VersionN/A
Server OS (if known)
Webserver software & version (if known)
PHP VersionN/A

Activities

user225042

2020-07-07 17:20

  ~58758

Please provide us with a screenshot of the error. Thank you.

Jmantysalo

Jmantysalo

2020-07-09 09:27

reporter   ~58821

Last edited: 2021-02-03 19:28

Please provide us with a screenshot of the error.

Nothing to show, as there are nothing shown.

gabrieljenik

gabrieljenik

2021-02-17 16:20

developer   ~62316

Fixed stats for ranking questions.
Also reviewed as requested and fixed the following:

  • Array (Numbers): Error 500: query parameter ":scale:id" instead of ":scale_id" on 'createSGQA'
  • Array (Numbers): Error 500: wrong fieldname created on 'createSGQA' (X-Scale subquestion not taken into account)
  • List with Comments + Pie Chart: Error 500, "Call to a member function gT() on string": $sLanguageCode->gT("Comments")
  • Ranking: 'createSGQA' returns null because it looks for subquestions instead of answer options
  • Ranking: 'buildOutputList' doesn't implement l10n
  • Multiple choice (M and P): 'buildOutputList' doesn't implement l10n

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1767

gabrieljenik

gabrieljenik

2021-02-23 14:04

developer   ~62462

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=31168

Related Changesets

LimeSurvey: master c8c6ba6b

2021-02-23 14:04:55

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 16455: Public statistics for Ranking question not shown (#1767)

Fixed stats for ranking questions.
Also reviewed as requested and fixed the following:
- Array (Numbers): Error 500: query parameter ":scale:id" instead of ":scale_id" on 'createSGQA'
- Array (Numbers): Error 500: wrong fieldname created on 'createSGQA' (X-Scale subquestion not taken into account)
- List with Comments + Pie Chart: Error 500, "Call to a member function gT() on string": $sLanguageCode->gT("Comments")
- Ranking: 'createSGQA' returns null because it looks for subquestions instead of answer options
- Ranking: 'buildOutputList' doesn't implement l10n
- Multiple choice (M and P): 'buildOutputList' doesn't implement l10n
Affected Issues
16455
mod - application/controllers/Statistics_userController.php Diff File
mod - application/helpers/userstatistics_helper.php Diff File

Issue History

Date Modified Username Field Change
2020-07-02 18:21 Jmantysalo New Issue
2020-07-07 17:20 user225042 Note Added: 58758
2020-07-09 09:27 Jmantysalo Note Added: 58821
2021-02-03 19:28 cdorin Priority none => normal
2021-02-03 19:28 cdorin Status new => confirmed
2021-02-03 19:28 cdorin Sync to Zoho Project => Yes
2021-02-09 13:59 cdorin Priority normal => high
2021-02-09 13:59 cdorin Severity tweak => partial_block
2021-02-09 13:59 cdorin Sync to Zoho Project Yes => Yes
2021-02-17 16:20 gabrieljenik Note Added: 62316
2021-02-23 14:04 gabrieljenik Changeset attached => LimeSurvey master c8c6ba6b
2021-02-23 14:04 gabrieljenik Note Added: 62462
2021-02-23 14:04 gabrieljenik Assigned To => gabrieljenik
2021-02-23 14:04 gabrieljenik Resolution open => fixed
2021-02-23 14:05 ollehar Status confirmed => resolved