View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
16437Bug reportsOtherpublic2020-07-06 13:21
ReporterDenisChenu Assigned ToJHoeck  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.22.24 
Summary16437: Unable to construct adminsidepanel
DescriptionWhen try to construct adminsidepanel it broke with rtlcss
Steps To ReproduceGet the fork https://github.com/LimeSurvey/LimeSurvey/pull/1456
Try to build yarn

````
[shnoulle@poledra adminsidepanel]$ yarn
yarn install v1.21.1
[1/4] Resolving packages...
[2/4] Fetching packages...
info fsevents@1.2.11: The platform "linux" is incompatible with this module.
info "fsevents@1.2.11" is an optional dependency and failed compatibility check. Excluding it from installation.
[3/4] Linking dependencies...
warning " > sass-loader@7.3.1" has unmet peer dependency "webpack@^3.0.0 || ^4.0.0".
[4/4] Building fresh packages...
success Saved lockfile.
Done in 4.30s.
[shnoulle@poledra adminsidepanel]$ yarn build
yarn run v1.21.1
$ yarn run dev && yarn run prod
$ vue-cli-service build --mode developement
 ERROR Error loading vue.config.js:
 ERROR Error: Cannot find module 'rtlcss'
 Require stack:
- /mnt/data/shnoulle/nginx/www/3LTS/assets/packages/meta/LSRTLPlugin/LSRTLPlugin.js
- /mnt/data/shnoulle/nginx/www/3LTS/assets/packages/adminsidepanel/vue.config.js
- /mnt/data/shnoulle/nginx/www/3LTS/assets/packages/adminsidepanel/node_modules/@vue/cli-service/lib/Service.js
- /mnt/data/shnoulle/nginx/www/3LTS/assets/packages/adminsidepanel/node_modules/@vue/cli-service/bin/vue-cli-service.js
Error: Cannot find module 'rtlcss'
Require stack:
- /mnt/data/shnoulle/nginx/www/3LTS/assets/packages/meta/LSRTLPlugin/LSRTLPlugin.js
- /mnt/data/shnoulle/nginx/www/3LTS/assets/packages/adminsidepanel/vue.config.js
- /mnt/data/shnoulle/nginx/www/3LTS/assets/packages/adminsidepanel/node_modules/@vue/cli-service/lib/Service.js
- /mnt/data/shnoulle/nginx/www/3LTS/assets/packages/adminsidepanel/node_modules/@vue/cli-service/bin/vue-cli-service.js
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:957:15)
    at Function.Module._load (internal/modules/cjs/loader.js:840:27)
    at Module.require (internal/modules/cjs/loader.js:1019:19)
    at require (internal/modules/cjs/helpers.js:77:18)
    at Object.<anonymous> (/mnt/data/shnoulle/nginx/www/3LTS/assets/packages/meta/LSRTLPlugin/LSRTLPlugin.js:3:16)
    at Module._compile (internal/modules/cjs/loader.js:1133:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10)
    at Module.load (internal/modules/cjs/loader.js:977:32)
    at Function.Module._load (internal/modules/cjs/loader.js:877:14)
    at Module.require (internal/modules/cjs/loader.js:1019:19)
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
````
Additional InformationTrying to add rtlcss

````
[shnoulle@poledra adminsidepanel]$ yarn add rtlcss
yarn add v1.21.1
[1/4] Resolving packages...
[2/4] Fetching packages...
warning Pattern ["rtlcss@^2.5.0"] is trying to unpack in the same destination "/home/shnoulle/.cache/yarn/v6/npm-rtlcss-2.5.0-455549e49113f9e1cf83169a44de526c816de8a4-integrity/node_modules/rtlcss" as pattern ["rtlcss@^2.2.1"]. This could result in non-deterministic behavior, skipping.
info fsevents@1.2.11: The platform "linux" is incompatible with this module.
info "fsevents@1.2.11" is an optional dependency and failed compatibility check. Excluding it from installation.
[3/4] Linking dependencies...
warning " > sass-loader@7.3.1" has unmet peer dependency "webpack@^3.0.0 || ^4.0.0".
[4/4] Building fresh packages...
success Saved lockfile.
success Saved 1 new dependency.
info Direct dependencies
└─ rtlcss@2.5.0
info All dependencies
└─ rtlcss@2.5.0
Done in 2.98s.
````

And same issue
TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)3.22.24 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)fedora/linux
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Activities

DenisChenu

DenisChenu

2020-06-30 10:28

developer   ~58573

With 4.X

````
$ yarn build
yarn run v1.22.4
$ yarn run dev && yarn run prod
$ vue-cli-service build --mode developement
 ERROR Error loading vue.config.js:
 ERROR Error: Cannot find module 'rtlcss'
 Require stack:
- /mnt/data/shnoulle/nginx/www/master/assets/packages/meta/LSRTLPlugin/LSRTLPlugin.js
- /mnt/data/shnoulle/nginx/www/master/assets/packages/adminsidepanel/vue.config.js
- /mnt/data/shnoulle/nginx/www/master/assets/packages/adminsidepanel/node_modules/@vue/cli-service/lib/Service.js
- /mnt/data/shnoulle/nginx/www/master/assets/packages/adminsidepanel/node_modules/@vue/cli-service/bin/vue-cli-service.js
Error: Cannot find module 'rtlcss'
Require stack:
- /mnt/data/shnoulle/nginx/www/master/assets/packages/meta/LSRTLPlugin/LSRTLPlugin.js
- /mnt/data/shnoulle/nginx/www/master/assets/packages/adminsidepanel/vue.config.js
- /mnt/data/shnoulle/nginx/www/master/assets/packages/adminsidepanel/node_modules/@vue/cli-service/lib/Service.js
- /mnt/data/shnoulle/nginx/www/master/assets/packages/adminsidepanel/node_modules/@vue/cli-service/bin/vue-cli-service.js
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:957:15)
    at Function.Module._load (internal/modules/cjs/loader.js:840:27)
    at Module.require (internal/modules/cjs/loader.js:1019:19)
    at require (internal/modules/cjs/helpers.js:77:18)
    at Object.<anonymous> (/mnt/data/shnoulle/nginx/www/master/assets/packages/meta/LSRTLPlugin/LSRTLPlugin.js:3:16)
    at Module._compile (internal/modules/cjs/loader.js:1133:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10)
    at Module.load (internal/modules/cjs/loader.js:977:32)
    at Function.Module._load (internal/modules/cjs/loader.js:877:14)
    at Module.require (internal/modules/cjs/loader.js:1019:19)
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
````
JHoeck

JHoeck

2020-06-30 14:15

developer   ~58577

Its possible to build the package adminsidepanel in the latest lts. There is no error message in the terminal. So I can not reproduce this issue.
DenisChenu

DenisChenu

2020-06-30 14:17

developer   ~58578

> Its possible to build the package adminsidepanel in the latest lts. There is no error message in the terminal. So I can not reproduce this issue.

Not for me …
DenisChenu

DenisChenu

2020-06-30 14:18

developer   ~58579

````
$ yarn -vv
1.22.4
````
JHoeck

JHoeck

2020-07-01 11:25

developer   ~58605

I fixed this issue in latest master. There was a wrong entry point for the RTLPlugin in /meta/
DenisChenu

DenisChenu

2020-07-01 11:32

developer   ~58606

Thanks but …still not … :(

https://bin.shnoulle.net/?f492d94e4f76fdd8#8o4qLQztU7nXs5a29dkTQg5NaXxv5HRuZLZ6yY7mLkpE


````
[shnoulle@poledra adminsidepanel]$ rm -Rf node_modules/
[shnoulle@poledra adminsidepanel]$ yarn
yarn install v1.22.4
warning package-lock.json found. Your project contains lock files generated by tools other than Yarn. It is advised not to mix package managers in order to avoid resolution inconsistencies caused by unsynchronized lock files. To clear this warning, remove package-lock.json.
[1/4] Resolving packages...
[2/4] Fetching packages...
info fsevents@1.2.9: The platform "linux" is incompatible with this module.
info "fsevents@1.2.9" is an optional dependency and failed compatibility check. Excluding it from installation.
[3/4] Linking dependencies...
warning " > sass-loader@7.3.1" has unmet peer dependency "webpack@^3.0.0 || ^4.0.0".
[4/4] Building fresh packages...
Done in 8.22s.
[shnoulle@poledra adminsidepanel]$ yarn build
yarn run v1.22.4
$ yarn run dev && yarn run prod
$ vue-cli-service build --mode developement
 ERROR Error loading vue.config.js:
 ERROR Error: Cannot find module 'rtlcss'
 Require stack:
- /mnt/data/shnoulle/nginx/www/master/assets/packages/meta/LSRTLPlugin/LSRTLPlugin.js
- /mnt/data/shnoulle/nginx/www/master/assets/packages/adminsidepanel/vue.config.js
- /mnt/data/shnoulle/nginx/www/master/assets/packages/adminsidepanel/node_modules/@vue/cli-service/lib/Service.js
- /mnt/data/shnoulle/nginx/www/master/assets/packages/adminsidepanel/node_modules/@vue/cli-service/bin/vue-cli-service.js
Error: Cannot find module 'rtlcss'
Require stack:
- /mnt/data/shnoulle/nginx/www/master/assets/packages/meta/LSRTLPlugin/LSRTLPlugin.js
- /mnt/data/shnoulle/nginx/www/master/assets/packages/adminsidepanel/vue.config.js
- /mnt/data/shnoulle/nginx/www/master/assets/packages/adminsidepanel/node_modules/@vue/cli-service/lib/Service.js
- /mnt/data/shnoulle/nginx/www/master/assets/packages/adminsidepanel/node_modules/@vue/cli-service/bin/vue-cli-service.js
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:957:15)
    at Function.Module._load (internal/modules/cjs/loader.js:840:27)
    at Module.require (internal/modules/cjs/loader.js:1019:19)
    at require (internal/modules/cjs/helpers.js:77:18)
    at Object.<anonymous> (/mnt/data/shnoulle/nginx/www/master/assets/packages/meta/LSRTLPlugin/LSRTLPlugin.js:3:16)
    at Module._compile (internal/modules/cjs/loader.js:1133:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10)
    at Module.load (internal/modules/cjs/loader.js:977:32)
    at Function.Module._load (internal/modules/cjs/loader.js:877:14)
    at Module.require (internal/modules/cjs/loader.js:1019:19)
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
````
JHoeck

JHoeck

2020-07-01 11:46

developer   ~58607

You have to try the yarn command in meta/LSRTLPlugin too.
DenisChenu

DenisChenu

2020-07-01 11:52

developer   ~58608

> You have to try the yarn command in meta/LSRTLPlugin too.

\o/ Thank you !

A lot of warning but builded :)
JHoeck

JHoeck

2020-07-01 12:26

developer   ~58609

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30235
lime_release_bot

lime_release_bot

2020-07-06 13:21

administrator   ~58707

Fixed in Release 4.3.3+200707

Related Changesets

LimeSurvey: master 8b042139

2020-07-01 11:23:50

JHoeck

Details Diff
Fixed issue 16437: Unable to construct adminsidepanel Affected Issues
16437
mod - assets/packages/meta/LSRTLPlugin/package.json Diff File

Issue History

Date Modified Username Field Change
2020-06-30 10:22 DenisChenu New Issue
2020-06-30 10:28 DenisChenu Note Added: 58573
2020-06-30 14:15 JHoeck Note Added: 58577
2020-06-30 14:17 DenisChenu Note Added: 58578
2020-06-30 14:18 DenisChenu Note Added: 58579
2020-07-01 11:25 JHoeck Note Added: 58605
2020-07-01 11:25 JHoeck Assigned To => JHoeck
2020-07-01 11:25 JHoeck Status new => assigned
2020-07-01 11:32 DenisChenu Note Added: 58606
2020-07-01 11:46 JHoeck Note Added: 58607
2020-07-01 11:52 DenisChenu Note Added: 58608
2020-07-01 12:26 JHoeck Changeset attached => LimeSurvey master 8b042139
2020-07-01 12:26 JHoeck Note Added: 58609
2020-07-01 12:26 JHoeck Resolution open => fixed
2020-07-06 13:21 lime_release_bot Note Added: 58707
2020-07-06 13:21 lime_release_bot Status assigned => closed