View Issue Details

IDProjectCategoryView StatusLast Update
16420Bug reportsStatisticspublic2020-08-13 10:46
Reporterasshank Assigned To 
PrioritynoneSeverityminor 
Status resolvedResolutionopen 
Product Version4.3.1 
Summary16420: responsefiltering in statistics is not working
Description

The responsefiltering in statistics is not working properly.
Serious issue.

Steps To Reproduce

I created a simple survey with a gender question and an other question.
In [Statistics], when I apply a responsefilter 'male' in the gender-question, the question statistics still include surveys filled-in by 'females'.
See attached lss and screenshot.
See also 16326.

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.3.1+200623
I will donate to the project if issue is resolvedNo
BrowserEdge
Database & DB-VersionMariadb
Server OS (if known)Linux
Webserver software & version (if known)apache
PHP Version7.3

Activities

asshank

asshank

2020-06-23 15:38

reporter  

2020-06-23_15h28_21.png (157,734 bytes)
asshank

asshank

2020-07-06 13:42

reporter   ~58720

Any clue on this issue?
We think it's a serious issue, as it is not possible now to analyse (filter) data in surveys anymore, nor filter the data before downloading to excel etc.).

2020-07-06_13h39_15.png (84,722 bytes)   
2020-07-06_13h39_15.png (84,722 bytes)   

user225042

2020-07-07 15:29

  ~58748

Last edited: 2020-08-13 10:46

Can you please upgrade to new version and check. If still the issue exist please share the lss file
Thank You

asshank

asshank

2020-07-08 15:35

reporter   ~58791

Last edited: 2020-08-13 10:46

yes, just test with version 4.3.3+200707.
issue still exists.
the lss already attached

user225042

2020-07-08 16:26

  ~58795

Last edited: 2020-08-13 10:46

Able to replicate the issue in the latest versions(4.3.3), moving issue to confirm.

albeda1

albeda1

2020-07-21 00:30

reporter   ~59007

Last edited: 2020-08-13 10:46

Same issue here. Any clue where to start to debug the code? I have a survey ready to process, and need to find a workaround.

albeda1

albeda1

2020-07-22 00:15

reporter   ~59031

Last edited: 2020-08-13 10:46

Sorry, Version 4.3.5 here.. .its the same in 4.0.0

mikecouchman

mikecouchman

2020-07-22 01:39

reporter   ~59034

Last edited: 2020-08-13 10:46

Issue has been in since version 4.1.14+20033. Really hoping this gets more attention than just a 'minor' bug as I have a lot of users complaining at the moment and I have no workaround for them!

albeda1

albeda1

2020-07-22 02:51

reporter   ~59035

Last edited: 2020-08-13 10:46

It's working in 4.1.14 ? the problem seems to bi a varialbe $query not including the first part of the query, so $sql comes with the filter part, but the query is empty.
If it works in 4.1.14 , a diff can solve the problem... Lets see...

mikecouchman

mikecouchman

2020-07-22 03:59

reporter   ~59036

Last edited: 2020-08-13 10:46

Sorry albeda1 - I mean that was the version I upgrade to from 3.something, and the error was picked up in that version, and has continued since.

gabrieljenik

gabrieljenik

2020-08-04 18:43

developer   ~59304

Last edited: 2020-08-13 10:46

View 2 revisions

Please review after applying fix for 16326

albeda1

albeda1

2020-08-04 19:13

reporter   ~59306

Last edited: 2020-08-13 10:46

Patch applied, It's working for me in 4.3.0. Great news

user225042

2020-08-11 17:06

  ~59410

Last edited: 2020-08-13 10:46

Tested the issue before pulling the PR, Issue exist. Tested the issue after pulling the PR, below are my findings:
Filters are working as expected
Please refer the attachment for more details

16420_FilterStatistics.png (82,555 bytes)   
16420_FilterStatistics.png (82,555 bytes)   

Issue History

Date Modified Username Field Change
2020-06-23 15:38 asshank New Issue
2020-06-23 15:38 asshank File Added: 2020-06-23_15h28_21.png
2020-06-23 15:38 asshank File Added: limesurvey_survey_678613.lss
2020-07-06 13:42 asshank Note Added: 58720
2020-07-06 13:42 asshank File Added: 2020-07-06_13h39_15.png
2020-07-07 15:29 user225042 Note Added: 58748
2020-07-08 15:35 asshank Note Added: 58791
2020-07-08 16:26 user225042 Note Added: 58795
2020-07-08 16:26 user225042 Status new => confirmed
2020-07-08 16:26 user225042 Description Updated View Revisions
2020-07-08 16:26 user225042 Steps to Reproduce Updated View Revisions
2020-07-21 00:30 albeda1 Note Added: 59007
2020-07-22 00:15 albeda1 Note Added: 59031
2020-07-22 01:39 mikecouchman Note Added: 59034
2020-07-22 02:51 albeda1 Note Added: 59035
2020-07-22 03:59 mikecouchman Note Added: 59036
2020-08-04 18:43 gabrieljenik Note Added: 59304
2020-08-04 18:44 gabrieljenik Note Edited: 59304 View Revisions
2020-08-04 19:13 albeda1 Note Added: 59306
2020-08-11 17:06 user225042 Note Added: 59410
2020-08-11 17:06 user225042 File Added: 16420_FilterStatistics.png
2020-08-13 10:46 swendrich Status confirmed => resolved