View Issue Details

IDProjectCategoryView StatusLast Update
16341Bug reportsFile managerpublic2020-06-17 13:16
ReporterJmantysalo Assigned To 
PrioritynoneSeverityblock 
Status confirmedResolutionfixed 
Product Version4.2.5 
Summary16341: Admin file upload does not work
Description

Uploading files to a survey do not work.

Files are left to upload/surveys/ with filenames like 123456foobar.jpg where 123456 is the number of the survey and foobar.jpg is the name of the file. I suppose that somehow a directory separator is dropped.

Additional Information

A user noticed this in RHEL8-based version 4.2.4 and I suppose it is was working in previous version we used.

To test I installed clean 4.2.5 to an Ubuntu machine without SELinux and just said chmod a+rwx limesurvey, and tested as superadmin. Same result.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.2.5+200526
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionN/A
Server OS (if known)
Webserver software & version (if known)
PHP VersionNewest available on Ubuntu 18.04 / on RHEL 8

Activities

ollehar

ollehar

2020-05-28 17:13

administrator   ~58078

The filename is your only problem? Does it work to download the files through the admin interface?

Jmantysalo

Jmantysalo

2020-05-28 18:20

reporter   ~58083

Sorry for being unclear (again). The problem is exactly when uploading files as admin of survey. From a survey admin viewpoint a file just vanishes without any warning or error message.

ollehar

ollehar

2020-05-29 10:29

administrator   ~58088

Which type of file?

Jmantysalo

Jmantysalo

2020-05-29 11:05

reporter   ~58089

I tested this with jpg, png and pdf, and so suppose that the file type is not an issue here.

ollehar

ollehar

2020-05-29 11:33

administrator   ~58091

Good info, thank you.

Jmantysalo

Jmantysalo

2020-05-29 11:35

reporter   ~58092

As this is quite important to our users, I would like to see any kind of workaround, temporary solution etc.

ollehar

ollehar

2020-05-29 11:39

administrator   ~58093

I can only recommend to use LimeSurvey 3.

Jmantysalo

Jmantysalo

2020-05-29 11:45

reporter   ~58094

Nearly impossible to use LS 3 for surveys that are already almost done. :( Too much manual work to remove LS4-only -features from .lsq or .lss.

ollehar

ollehar

2020-05-29 11:50

administrator   ~58095

I think you can export surveys as tab-separated files and import them in LS3. But yes, for running surveys it will be hard.

Jmantysalo

Jmantysalo

2020-06-04 00:33

reporter   ~58164

16352 is a duplicate of this with a patch. (And, maybe, another error seen after adding the patch.)

ollehar

ollehar

2020-06-09 10:41

administrator   ~58223

Fixed now?

Jmantysalo

Jmantysalo

2020-06-15 07:27

reporter   ~58276

Not fixed. I just downloaded 4.2.8+200608 and did a clean install. I tested on Ubuntu with permissions a+rwx, and just creating one survey and clicking resources gives "An error has happened and no files could be located".

If I manuall create a directory upload/surveys/NNNNNN, then the file manager flashes for a half of second and then disappears.

ollehar

ollehar

2020-06-15 10:26

administrator   ~58282

Ah, well, we'll release 4.4 today (or this week), and we've reverted the file manager to LS3 in this version, which should resolve your issue.

ollehar

ollehar

2020-06-15 10:27

administrator   ~58283

Fixed in 4.4

cdorin

cdorin

2020-06-15 12:21

manager   ~58284

I have opened the ticket once more - we decided not to revert now in 4.3, but we will do it in 4.4 (that will be released in ~8 weeks). There are some issues that need to be ironed out.

Jmantysalo

Jmantysalo

2020-06-17 13:16

reporter   ~58324

In my test this now works in private browsing -- i.e. the user must clear cookies or browser cache or something. Also this works in a LS 4.3.0 updated with ComfortUpdate from older version.

Issue History

Date Modified Username Field Change
2020-05-28 17:07 Jmantysalo New Issue
2020-05-28 17:13 ollehar Note Added: 58078
2020-05-28 17:13 ollehar Assigned To => adamzammit
2020-05-28 17:13 ollehar Status new => feedback
2020-05-28 17:13 ollehar Assigned To adamzammit =>
2020-05-28 18:20 Jmantysalo Note Added: 58083
2020-05-28 18:20 Jmantysalo Status feedback => new
2020-05-29 10:29 ollehar Note Added: 58088
2020-05-29 11:05 Jmantysalo Note Added: 58089
2020-05-29 11:33 ollehar Note Added: 58091
2020-05-29 11:35 Jmantysalo Note Added: 58092
2020-05-29 11:39 ollehar Note Added: 58093
2020-05-29 11:45 Jmantysalo Note Added: 58094
2020-05-29 11:50 ollehar Note Added: 58095
2020-06-04 00:33 Jmantysalo Note Added: 58164
2020-06-09 10:41 ollehar Note Added: 58223
2020-06-09 10:41 ollehar Status new => feedback
2020-06-15 07:27 Jmantysalo Note Added: 58276
2020-06-15 07:27 Jmantysalo Status feedback => new
2020-06-15 10:26 ollehar Note Added: 58282
2020-06-15 10:27 ollehar Status new => resolved
2020-06-15 10:27 ollehar Resolution open => fixed
2020-06-15 10:27 ollehar Note Added: 58283
2020-06-15 12:21 cdorin Status resolved => confirmed
2020-06-15 12:21 cdorin Note Added: 58284
2020-06-15 14:02 ollehar Summary File upload not work => Admin file upload does not work
2020-06-15 14:02 ollehar Steps to Reproduce Updated View Revisions
2020-06-17 13:16 Jmantysalo Note Added: 58324