View Issue Details

IDProjectCategoryView StatusLast Update
16274Bug reportsTheme editorpublic2020-10-19 10:13
ReporterJmantysalo Assigned Togabrieljenik  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version4.2.1 
Summary16274: Fruity Theme : Setting font didn't work
Description

Setting font in theme options changes nothing. I used fruity theme and after setting font the body tag has font-comic_sans, but it does nothing. Maybe some .css is not loaded at all or something.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.2.1+200428
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionN/A
Server OS (if known)
Webserver software & version (if known)
PHP VersionN/A

Activities

cdorin

cdorin

2020-08-26 15:32

manager   ~59634

I moved it to acknowledge since we plan to revert CKEditor

DenisChenu

DenisChenu

2020-08-27 18:12

developer   ~59649

@cdorin : theme option , not editor.

@Jmantysalo : can you send a sample survey, ath theme did you try/use ?

Jmantysalo

Jmantysalo

2020-08-28 07:24

reporter   ~59650

This can be seen in any survey, but whatever. I did a clean install on the newest version, made a sample survey (that uses fruity as default) and set Comic Sans as font. Setting does nothing. .lss is attached.

I use Firefox on Ubuntu 20.04, haven't tested on other browsers.

DenisChenu

DenisChenu

2020-08-28 09:33

developer   ~59651

Confirmed

  • Vanilla : OK (in 4.X)
  • Fruity : not OK
  • Bootsrap : no font update
DenisChenu

DenisChenu

2020-08-28 09:35

developer   ~59652

OK in 3.X (for Fruity)

DenisChenu

DenisChenu

2020-08-28 09:36

developer   ~59653

Vanilla screenshot, nothing updated for Fruity :)

To be more clear of the issue :)

gabrieljenik

gabrieljenik

2020-10-13 17:45

developer   ~60182

The issue was because when inheriting, there is no object where to add a package, but an "inherit" string, creating a JS error.
Solved by initializing an empty package object.

https://github.com/LimeSurvey/LimeSurvey/pull/1621

gabrieljenik

gabrieljenik

2020-10-16 07:13

developer   ~60223

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30605

lime_release_bot

lime_release_bot

2020-10-19 10:13

administrator   ~60258

Fixed in Release 4.3.22+201019

Related Changesets

LimeSurvey: master 41be4489

2020-10-16 07:13:52

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 16274: Fruity Theme : Setting font didn't work (#1621)

If no current "package to load" object, creating an empty one
Affected Issues
16274
mod - assets/packages/themeoptions-core/themeoptions-core.js Diff File

Issue History

Date Modified Username Field Change
2020-05-14 13:36 Jmantysalo New Issue
2020-05-14 14:25 cdorin Assigned To => cdorin
2020-05-14 14:25 cdorin Priority none => normal
2020-05-14 14:25 cdorin Status new => confirmed
2020-08-26 15:32 cdorin Assigned To cdorin =>
2020-08-26 15:32 cdorin Status confirmed => acknowledged
2020-08-26 15:32 cdorin Note Added: 59634
2020-08-27 18:12 DenisChenu Note Added: 59649
2020-08-28 07:24 Jmantysalo Note Added: 59650
2020-08-28 07:24 Jmantysalo File Added: limesurvey_survey_119822.lss
2020-08-28 09:33 DenisChenu Status acknowledged => confirmed
2020-08-28 09:33 DenisChenu Note Added: 59651
2020-08-28 09:34 DenisChenu Summary Setting font makes nothing => Fruity Theme : Setting font didn't work
2020-08-28 09:35 DenisChenu Note Added: 59652
2020-08-28 09:35 DenisChenu Assigned To => cdorin
2020-08-28 09:35 DenisChenu Status confirmed => assigned
2020-08-28 09:36 DenisChenu Note Added: 59653
2020-08-28 09:36 DenisChenu File Added: Capture d’écran du 2020-08-28 09-32-29.png
2020-08-28 09:36 DenisChenu File Added: Capture d’écran du 2020-08-28 09-32-42.png
2020-10-02 12:53 cdorin Assigned To cdorin => gabrieljenik
2020-10-13 17:45 gabrieljenik Note Added: 60182
2020-10-16 07:13 gabrieljenik Changeset attached => LimeSurvey master 41be4489
2020-10-16 07:13 gabrieljenik Note Added: 60223
2020-10-16 07:13 gabrieljenik Resolution open => fixed
2020-10-19 10:13 lime_release_bot Note Added: 60258
2020-10-19 10:13 lime_release_bot Status assigned => closed