View Issue Details

IDProjectCategoryView StatusLast Update
16200Bug reports_ Unknownpublic2020-12-28 13:33
Reportermbarbalas20 Assigned Tocdorin  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version4.1.18 
Fixed in Version4.4.0-RC1 
Summary16200: List question - deleted "Other" category but prompt for other input visible
DescriptionUsing a simple List type question, the help prompt "If you choose 'Other:' please also specify your choice in the accompanying text field." is still visible. I have tried toggling between Other on and off but the accompanying text does not disappear.

Screen shot of question attached.

Version 4.1.16+200407
Running on Windows 10/Firefox browser version 75.0 (64 bit)
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.2.2
I will donate to the project if issue is resolvedNo
BrowserWindows 10/Firefox browser version 75.0 (64 bit)
Database & DB-VersionMySQL MariaDB version 5.5.64
Server OS (if known)CentOS 7 (Kernel Linux 3.10.0-1062.12.1.e17)
Webserver software & version (if known)
PHP Version7.2

Activities

mbarbalas20

mbarbalas20

2020-04-28 19:15

reporter  

ollehar

ollehar

2020-04-29 10:48

administrator   ~57452

For us to be able to investigate this issue please attach a 2 question sample survey demonstrating the issue, either as .lss file (survey structure) or (even better) as .lsa file (survey archive).

Just attach it to this issue and we will have a look.
Thank you!
mbarbalas20

mbarbalas20

2020-04-30 20:39

reporter   ~57514

Sample LSS file attached
mbarbalas20

mbarbalas20

2020-04-30 20:44

reporter   ~57515

Also noticed in the Question Group display, the ordering if not correct (see attached JPG screenshot)
image.png (59,708 bytes)   
image.png (59,708 bytes)   
DenisChenu

DenisChenu

2020-05-01 12:06

developer   ~57517

> Also noticed in the Question Group display, the ordering if not correct (see attached JPG screenshot)

It's another issue : please report it :)
DenisChenu

DenisChenu

2020-05-07 12:14

developer   ~57605

Same issue in 3.X
And same issue with other as number.

BUT : you can easily fix it : set "No" to other comment mandatory
DenisChenu

DenisChenu

2020-05-07 12:17

developer   ~57606

There are worst issue in 4.X : only one tip are shown at a time
DenisChenu

DenisChenu

2020-05-07 12:25

developer   ~57608

Since there are easy solution :) i didn't fix
cdorin

cdorin

2020-12-28 13:33

manager   ~61216

Fixed in 4.4.0 RC1

Issue History

Date Modified Username Field Change
2020-04-28 19:15 mbarbalas20 New Issue
2020-04-28 19:15 mbarbalas20 File Added: LS issue - Other text showing inappropriately.jpg
2020-04-29 10:48 ollehar Note Added: 57452
2020-04-29 10:48 ollehar Status new => feedback
2020-04-30 20:39 mbarbalas20 Note Added: 57514
2020-04-30 20:39 mbarbalas20 File Added: limesurvey_survey_246448.lss
2020-04-30 20:39 mbarbalas20 Status feedback => new
2020-04-30 20:44 mbarbalas20 Note Added: 57515
2020-04-30 20:44 mbarbalas20 File Added: image.png
2020-05-01 12:06 DenisChenu Note Added: 57517
2020-05-04 11:50 ollehar Priority none => normal
2020-05-04 11:50 ollehar Description Updated View Revisions
2020-05-07 11:52 DenisChenu Assigned To => DenisChenu
2020-05-07 11:52 DenisChenu Status new => assigned
2020-05-07 12:14 DenisChenu Note Added: 57605
2020-05-07 12:14 DenisChenu File Added: limesurvey_survey_otherCommentWithoutOther.lss
2020-05-07 12:17 DenisChenu Note Added: 57606
2020-05-07 12:25 DenisChenu Assigned To DenisChenu =>
2020-05-07 12:25 DenisChenu Status assigned => confirmed
2020-05-07 12:25 DenisChenu Complete LimeSurvey version number (& build) Version 4.1.16+200407 => Version 4.2.2
2020-05-07 12:25 DenisChenu Note Added: 57608
2020-12-28 13:33 cdorin Assigned To => cdorin
2020-12-28 13:33 cdorin Status confirmed => closed
2020-12-28 13:33 cdorin Resolution open => fixed
2020-12-28 13:33 cdorin Fixed in Version => 4.4.0-RC1
2020-12-28 13:33 cdorin Note Added: 61216