View Issue Details

IDProjectCategoryView StatusLast Update
16095Bug reportsOtherpublic2020-04-28 10:12
Reporterymca Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version4.1.15 
Fixed in Version4.1.18 
Summary16095: Exclamation sign doesn't have text or is duplicate.
Description

As you can see in the picture there are 2 exclamation signs.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.1.15+200402
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionsame
Server OS (if known)
Webserver software & version (if known)
PHP Versionsame

Activities

ymca

ymca

2020-04-05 12:34

reporter  

Untitled-2.jpg (23,306 bytes)   
Untitled-2.jpg (23,306 bytes)   
ymca

ymca

2020-04-05 14:55

reporter   ~56949

When changing to Hindi and Hebrew, saw not all warning are translated but in Portuguese it's OK.

Untitled-3.jpg (20,561 bytes)   
Untitled-3.jpg (20,561 bytes)   
cdorin

cdorin

2020-04-05 15:11

manager   ~56951

Translations are provided by community members. In case it is missing, please check https://translate.limesurvey.org (use your limesurvey.org credentials to log in).

ymca

ymca

2020-04-05 15:15

reporter   ~56953

OK thanks.

ymca

ymca

2020-04-05 15:41

reporter   ~56954

I see both languages are already translated, but with an orange color (Fuzzy?)

cdorin

cdorin

2020-04-07 00:23

manager   ~56987

Please submit the translations again - that s why they have not been recognised by the system :)

ymca

ymca

2020-04-07 11:44

reporter   ~56998

OK, so after I update the translation in your site, it will be automatically updated in mine or I'll need to download a new version when it comes out?
Also what about the English default language here?
https://bugs.limesurvey.org/file_download.php?file_id=12962&type=bug

DenisChenu

DenisChenu

2020-04-07 17:36

developer   ~57011

Can you upload the question in a lss file ?

ymca

ymca

2020-04-07 18:11

reporter   ~57013

Didn't find export 1 question to lss so exported a group.

limesurvey_group_28.lsg (21,082 bytes)
DenisChenu

DenisChenu

2020-04-07 18:39

developer   ~57015

No ...

A lss with only this question type ...

My opinon : if current translation are empty : must show english string . Seems to be Please complete all parts . I want to understand why you don't have it :)

ymca

ymca

2020-04-07 18:44

reporter   ~57016

"A lss with only this question type ..." tried to find it in a active survey, and didn't find it.
Tried to create a duplicate one and also didn't find lss export, just group export.
"My opinon : if current translation are empty : must show English string " I also think that.
"Seems to be Please complete all parts ." My question is multi choice and not all boxes are mandatory so, maybe that is why it needs to be different English sentence?

DenisChenu

DenisChenu

2020-04-07 19:11

developer   ~57017

Last edited: 2020-04-07 19:12

View 2 revisions

Tried to create a duplicate one and also didn't find lss export, just group export.

https://manual.limesurvey.org/Display/Export_survey :)

My question is multi choice

I think there are only one sentence for multiple choice ...

Except with min/max (see french screenshot of 3.X versin)

DenisChenu

DenisChenu

2020-04-07 19:12

developer  

ymca

ymca

2020-04-15 12:30

reporter   ~57132

"Translations are provided by community members. In case it is missing, please check https://translate.limesurvey.org (use your limesurvey.org credentials to log in)."

cdorin, I've suggested a new translation.
Now what?

DenisChenu

DenisChenu

2020-04-15 12:34

developer   ~57133

My opinion: it's NOT a translation issue ...

Except if translation exist and set to " " (just a space)

Please : send the lss file ...

ymca

ymca

2020-04-16 16:12

reporter   ~57167

Here is the lss file.
If you change language and dont fill question group number 2, it will show:
"https://bugs.limesurvey.org/file_download.php?file_id=12963&type=bug"
You can also see that in the question G2Q00005
"Which country do you think performs best during the crisis?" the list is not full (couldn't save the whole list).
Also have tried to change the question text and it didn't save it.

DenisChenu

DenisChenu

2020-04-16 16:25

developer   ~57172

I confirm : it's not related to language ....

In multiple choice : mandatiory part appear 2 times : one time with string, one time without

ymca

ymca

2020-04-16 16:37

reporter   ~57178

Cool.
And what about the other thing, should I send you the the countries list here or somewhere else?
How can I help?

DenisChenu

DenisChenu

2020-04-16 16:42

developer   ~57184

@ollehar : the issue is with broken DB ....

maybe you can hack your DB : just delete some questioni10n

ymca

ymca

2020-04-16 16:49

reporter   ~57189

8o
You mean about the translation problem or the saving all countries list?
I have phpMyAdmin but don't know where to go and what to delete.

DenisChenu

DenisChenu

2020-04-16 16:52

developer   ~57190

This issue is «16095: Exclamation sign doesn't have text or is duplicate.»

@cdorin write it can be a translation issue : https://bugs.limesurvey.org/view.php?id=16095#c56951

It's not

DenisChenu

DenisChenu

2020-04-17 18:35

developer   ~57221

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=29841

cdorin

cdorin

2020-04-17 18:39

manager   ~57223

thanks denis!

lime_release_bot

lime_release_bot

2020-04-28 10:12

administrator   ~57424

Fixed in Release 4.2.0+200422

Related Changesets

LimeSurvey: master f8f28717

2020-04-17 18:35:42

DenisChenu

Details Diff
Fixed issue 16095: Multiple choice exclamation sign without text
Dev: get the text from 3.X, same behaviour
Affected Issues
16095
mod - application/helpers/expressions/em_manager_helper.php Diff File
mod - application/views/survey/questions/question_help/mandatory_tip.twig Diff File

Issue History

Date Modified Username Field Change
2020-04-05 12:34 ymca New Issue
2020-04-05 12:34 ymca File Added: Untitled-2.jpg
2020-04-05 14:55 ymca File Added: Untitled-3.jpg
2020-04-05 14:55 ymca Note Added: 56949
2020-04-05 15:11 cdorin Note Added: 56951
2020-04-05 15:15 ymca Note Added: 56953
2020-04-05 15:41 ymca Note Added: 56954
2020-04-07 00:23 cdorin Note Added: 56987
2020-04-07 11:44 ymca Note Added: 56998
2020-04-07 17:36 DenisChenu Note Added: 57011
2020-04-07 18:11 ymca File Added: limesurvey_group_28.lsg
2020-04-07 18:11 ymca Note Added: 57013
2020-04-07 18:39 DenisChenu Note Added: 57015
2020-04-07 18:44 ymca Note Added: 57016
2020-04-07 19:11 DenisChenu Note Added: 57017
2020-04-07 19:12 DenisChenu Note Edited: 57017 View Revisions
2020-04-07 19:12 DenisChenu File Added: Capture d’écran du 2020-04-07 19-12-08.png
2020-04-15 12:30 ymca Note Added: 57132
2020-04-15 12:34 DenisChenu Note Added: 57133
2020-04-16 16:12 ymca File Added: bug.limesurvey_survey_239164.lss
2020-04-16 16:12 ymca Note Added: 57167
2020-04-16 16:25 DenisChenu File Added: Capture d’écran du 2020-04-16 16-23-58.png
2020-04-16 16:25 DenisChenu File Added: Capture d’écran du 2020-04-16 16-24-14.png
2020-04-16 16:25 DenisChenu Note Added: 57172
2020-04-16 16:37 ymca Note Added: 57178
2020-04-16 16:42 DenisChenu Note Added: 57184
2020-04-16 16:49 ymca Note Added: 57189
2020-04-16 16:52 DenisChenu Note Added: 57190
2020-04-17 17:35 ollehar Product Version => 4.1.15
2020-04-17 18:29 DenisChenu Assigned To => DenisChenu
2020-04-17 18:29 DenisChenu Status new => assigned
2020-04-17 18:35 DenisChenu Changeset attached => LimeSurvey master f8f28717
2020-04-17 18:35 DenisChenu Note Added: 57221
2020-04-17 18:35 DenisChenu Resolution open => fixed
2020-04-17 18:37 DenisChenu Status assigned => resolved
2020-04-17 18:37 DenisChenu Fixed in Version => 4.1.18
2020-04-17 18:39 cdorin Note Added: 57223
2020-04-28 10:12 lime_release_bot Note Added: 57424
2020-04-28 10:12 lime_release_bot Status resolved => closed