View Issue Details

IDProjectCategoryView StatusLast Update
16084Bug reportsConditionspublic2021-01-28 19:48
Reporterbyan Assigned To 
PrioritynormalSeverityminor 
Status closedResolutionreopened 
Product Version4.1.13 
Fixed in Version4.4.0 
Summary16084: Error when using Expression Manager to hide subquestions for multiple choice
DescriptionThis issue can be found at https://www.limesurvey.org/community/forums/can-i-do-this-with-limesurvey/120703-error-when-using-expression-manager-to-hide-subquestions-for-multiple-choice

I I have two questions. The first is single choice (G01Q01) and second is multiple choice (G01Q02). The goal is to hide subquestion in the second question based on the answer to the first question. In the attached example, subquestion 1 (SQ01) should be hidden if the answer to question 1 is not the first choice (AO01).

My solution was to add (G01Q01.NAOK == "AO01") in the condition box of SQ01. It did hide the first subquestion of G01Q02 unless the first choice is selected in G01Q01. However, the survey cannot be submitted unless the first choice is selected in G01Q01.

In other words, when option 2 was selected (in fact, any choice other than option 1), the error message "One or more questions have not been answered in a valid manner. You cannot proceed until these answers are valid." popped up, preventing the survey from moving to the next page or, in this case, being submitted.
Additional InformationDenis, do you still have the problem in the RC release? I am never getting the pop up
TagsNo tags attached.
Complete LimeSurvey version number (& build)4.1.13+200325
I will donate to the project if issue is resolvedYes
Browser
Database & DB-Version10.2.30-MariaDB - MariaDB Server
Server OS (if known)
Webserver software & version (if known)
PHP Version7.3.6

Activities

byan

byan

2020-04-02 21:42

reporter  

error.png (11,675 bytes)   
error.png (11,675 bytes)   
survey.png (6,045 bytes)   
survey.png (6,045 bytes)   
SQ in G01Q02.png (9,387 bytes)   
SQ in G01Q02.png (9,387 bytes)   
AO in G01Q01.png (4,254 bytes)   
AO in G01Q01.png (4,254 bytes)   
DenisChenu

DenisChenu

2020-04-03 09:33

developer   ~56918

lss from 3.X : seems OK,

Seems bug appear in 4.X ....
DenisChenu

DenisChenu

2020-04-03 09:52

developer   ~56919

Last edited: 2020-04-03 09:55

View 3 revisions

Checking with tracevar : ` 'valid' => false` even if both question are answered ...

`'mandNonSoft' => true` on multiple question ...

DenisChenu

DenisChenu

2020-04-03 09:57

developer   ~56920

What is this awfull checking ???

` 'mandNonSoft' => ($qInfo['mandatory'] == 'Y' || $qInfo['mandatory'] == 'N') && ($qmandViolation === true || $qvalid === false) ? true : false,`

mandNonSoft can be true with mandatory set to N !!
DenisChenu

DenisChenu

2020-04-03 10:01

developer   ~56921

Broken in https://github.com/LimeSurvey/LimeSurvey/commit/f6a9b3082bd0cf8306129d73382ee23e0740dc64#diff-796aba4d06254b9caea9d461e4ea80c9

My opinion : must be
`$qInfo['mandatory'] == 'Y' && $qmandViolation === true`

But since i think this mandatory soft are an error ....
cdorin

cdorin

2020-12-30 17:17

manager   ~61328

Fixed in 4.4.0RC1
cdorin

cdorin

2021-01-28 19:48

manager   ~61770

seems fixed. to be tested with 4.4.0+

Issue History

Date Modified Username Field Change
2020-04-02 21:42 byan New Issue
2020-04-02 21:42 byan File Added: error.png
2020-04-02 21:42 byan File Added: survey.png
2020-04-02 21:42 byan File Added: SQ in G01Q02.png
2020-04-02 21:42 byan File Added: AO in G01Q01.png
2020-04-02 21:42 byan File Added: limesurvey_survey_517537.lss
2020-04-02 23:53 cdorin Description Updated View Revisions
2020-04-02 23:53 cdorin Zoho Sprints => |Yes|
2020-04-02 23:53 swendrich Zoho Sprints ID => 14469000000025025
2020-04-03 09:33 DenisChenu File Added: limesurvey_survey_bug16084_for3LTS.lss
2020-04-03 09:33 DenisChenu Note Added: 56918
2020-04-03 09:52 DenisChenu Note Added: 56919
2020-04-03 09:54 DenisChenu Note Edited: 56919 View Revisions
2020-04-03 09:55 DenisChenu Note Edited: 56919 View Revisions
2020-04-03 09:57 DenisChenu Note Added: 56920
2020-04-03 10:01 DenisChenu Note Added: 56921
2020-07-29 20:14 cdorin Status new => confirmed
2020-07-29 20:14 cdorin Zoho Sprints Yes => |Yes|
2020-12-30 17:17 cdorin Assigned To => cdorin
2020-12-30 17:17 cdorin Status confirmed => closed
2020-12-30 17:17 cdorin Resolution open => fixed
2020-12-30 17:17 cdorin Note Added: 61328
2020-12-30 17:21 cdorin Assigned To cdorin =>
2020-12-30 17:21 cdorin Priority none => normal
2020-12-30 17:21 cdorin Status closed => feedback
2020-12-30 17:21 cdorin Resolution fixed => reopened
2020-12-30 17:21 cdorin Additional Information Updated View Revisions
2021-01-28 19:48 cdorin Status feedback => closed
2021-01-28 19:48 cdorin Fixed in Version => 4.4.0
2021-01-28 19:48 cdorin Note Added: 61770