View Issue Details

IDProjectCategoryView StatusLast Update
16070Bug reportsOtherpublic2021-03-23 09:04
ReporterJmantysalo Assigned Tocdorin  
PrioritynormalSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.1.10 
Fixed in Version4.4.0-RC1 
Summary16070: Quick-translation ends with internal Server Error
DescriptionQuick-translation of a survey ends with "500: Internal Server Error Call to a member function getAttributes() on null".
Steps To ReproduceMake a new survey, go to Group list and import the attached group. Try Tools / Quick-translation.
Additional InformationNormal translation works, hence this is only a minor issue.
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.1.10+200311
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMariaDB, newest available on Ubuntu 18.04 LTS
Server OS (if known)Ubuntu 18.04 LTS
Webserver software & version (if known)Apache
PHP VersionNewest available on Ubuntu 18.04

Activities

Jmantysalo

Jmantysalo

2020-04-01 09:41

reporter  

limesurvey_group_2.lsg (98,139 bytes)
wisniman

wisniman

2020-04-17 20:52

reporter   ~57230

Can confirm same experience in version 4.1.18+200416 on Apache/2.4.41 (Win64).
ollehar

ollehar

2020-04-27 17:52

administrator   ~57398

Please always include the lss file necessary to reproduce the issue. The lsg file cannot be imported without a proper language setup in the survey.
Jmantysalo

Jmantysalo

2020-04-28 06:04

reporter   ~57405

Duh! Now I can not reproduce this myself, but wisniman already confirmed the bug.
ollehar

ollehar

2020-04-28 10:03

administrator   ~57414

OK, then maybe I can ask @wisniman to attach an lss file that reproduces the issue?
cdorin

cdorin

2020-07-09 15:10

manager   ~58858

I cannot reproduce it - can someone double check it on latest release? Also, can someone provide an .lss file ? (used English and Romanian, and everything was fine)
Jmantysalo

Jmantysalo

2020-07-13 12:27

reporter   ~58911

I tested on a fresh install of Version 4.3.3+200707 (download link for 4.3.4 is broken) and still have the same problem.

But... Yesterday a user here said that quick translation did not work, and when I tested it seemed to be fine in the same survey. Some kind of heisenbug maybe?
cdorin

cdorin

2020-07-29 21:58

manager   ~59172

@jmantysalo, can you please send us an .lss file to double check? So far, I can't reproduce it. Regarding the user -> could you please tell us which permissions (s)he has?
Jmantysalo

Jmantysalo

2020-07-30 11:12

reporter   ~59201

@cdorin, she has permissions "Permission to create surveys" -> Create and Permission to create, view, update, delete, export and import templates -> view/read.

As said, this seem to be a heisenbug. :( I'll try to get more information about failing cases.
cdorin

cdorin

2020-07-30 16:38

manager   ~59220

thanks for update - moved to acknowledged . Need a way to reproduce it before having it assigned.

cdorin

cdorin

2020-12-29 19:06

manager   ~61306

Reverted the view in LS4.4.0 RC1
Jmantysalo

Jmantysalo

2021-01-04 13:02

reporter   ~61411

> thanks for update - moved to acknowledged . Need a way to reproduce it before having it assigned.

In 4.4.0 RC1: Make a new survey having Finnish as the base language. Import attached lsg-file. Add Arabic as additional language. Press Tools / Quick translate. Gives internal server error.
cdorin

cdorin

2021-01-04 13:07

manager   ~61413

HEy @jmantysalo - can you please create a new bug report with the attached .lsg ? Could be an RTL issue as well (something we haven;t tackled yet)
Jmantysalo

Jmantysalo

2021-01-05 09:53

reporter   ~61426

Currently there are other problems, but yes, you can close this ticket. I will see if I can reproduce the problem after few more beta versions.
Jmantysalo

Jmantysalo

2021-03-23 09:04

reporter   ~63573

Just to notify that this still fails in version 4.4.13+210315.

Issue History

Date Modified Username Field Change
2020-04-01 09:41 Jmantysalo New Issue
2020-04-01 09:41 Jmantysalo File Added: limesurvey_group_2.lsg
2020-04-17 20:52 wisniman Note Added: 57230
2020-04-27 17:52 ollehar Note Added: 57398
2020-04-27 17:52 ollehar Status new => feedback
2020-04-28 06:04 Jmantysalo Note Added: 57405
2020-04-28 06:04 Jmantysalo Status feedback => new
2020-04-28 10:03 ollehar Note Added: 57414
2020-04-28 10:03 ollehar Priority none => high
2020-04-28 10:03 ollehar Severity minor => block
2020-07-09 15:10 cdorin Severity block => partial_block
2020-07-09 15:10 cdorin Status new => feedback
2020-07-09 15:10 cdorin Note Added: 58858
2020-07-13 12:27 Jmantysalo Note Added: 58911
2020-07-13 12:27 Jmantysalo Status feedback => new
2020-07-29 21:58 cdorin Status new => feedback
2020-07-29 21:58 cdorin Note Added: 59172
2020-07-30 11:12 Jmantysalo Note Added: 59201
2020-07-30 11:12 Jmantysalo Status feedback => new
2020-07-30 16:38 cdorin Priority high => normal
2020-07-30 16:38 cdorin Status new => acknowledged
2020-07-30 16:38 cdorin Note Added: 59220
2020-12-29 19:06 cdorin Assigned To => cdorin
2020-12-29 19:06 cdorin Status acknowledged => closed
2020-12-29 19:06 cdorin Resolution open => fixed
2020-12-29 19:06 cdorin Fixed in Version => 4.4.0-RC1
2020-12-29 19:06 cdorin Note Added: 61306
2021-01-04 13:02 Jmantysalo Note Added: 61411
2021-01-04 13:07 cdorin Note Added: 61413
2021-01-05 09:53 Jmantysalo Note Added: 61426
2021-03-23 09:04 Jmantysalo Note Added: 63573