View Issue Details

IDProjectCategoryView StatusLast Update
16061Bug reportsOtherpublic2020-04-20 10:29
Reporterf_funke Assigned ToJHoeck  
PriorityhighSeverityminor 
Status resolvedResolutionfixed 
Product Version4.1.13 
Summary16061: wast of time caused by info pop-up/modal
Description

The info pop-up/modal takes to much space. It overlays the preview buttons. So after saving a question you always have to wait until the information disappears. As a typical workflow is to edit and save a question followed by a preview of the question (group) this really is a wast of users time.

My suggestion is the move the info area either a bit up or to decrease its height so that the preview buttons are fully visible.

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.1.13
I will donate to the project if issue is resolvedNo
BrowserFirefox @Windows
Database & DB-Versionn/a
Server OS (if known)
Webserver software & version (if known)
PHP Versionn/a

Activities

f_funke

f_funke

2020-03-29 11:45

developer  

grafik.png (18,827 bytes)   
grafik.png (18,827 bytes)   
ong

ong

2020-03-30 11:15

reporter   ~56834

I can confirm that this is a nuisance and it would be nice to have this smaller as suggested.

tammo

tammo

2020-04-18 11:04

developer   ~57234

Last edited: 2020-04-18 11:04

View 2 revisions

I totally agree. I think a confirmation could (should) appear in a designated area and not be modal.

I hope that there can be a special place for that, which expands when needed and disappears after some seconds.

DenisChenu

DenisChenu

2020-04-18 11:36

developer   ~57236

@JHoeck i still have this issue .

Maybe move the alert inside flow ?

ong

ong

2020-04-18 12:01

reporter   ~57241

Hi DenisChenu,
maybe move it up to the top of the page is enough. I would assume it's unlikely, that people will click on anything in the top navigation after saving the question.
(Also, I do not understand what you might mean by "alert inside flow").

DenisChenu

DenisChenu

2020-04-20 08:53

developer   ~57254

inside : floaw , see screenshot.

Inside the content, take place

DenisChenu

DenisChenu

2020-04-20 08:54

developer   ~57255

I hope that there can be a special place for that, which expands when needed and disappears after some seconds.

I prefer to have a "close" link, not disapeear, but it's a personal opinion, and if it can be impoved to have a user option.

ong

ong

2020-04-20 09:25

reporter   ~57256

Hi
thanks for the image.
I am not sure about a close link (X on the right) or an automatic close. As one might continue working on the question, this question has been changed and is not saved in that current state. A close link might make users forget that the question has not been saved.
Also: What if a user saves again - how does he know, that his last changes have been saved (and it's not only an old message still showing).
This makes it appealing to me to have it disappear automatically. Of course there can be an additional X in the corner to quickly get rid of the message.

DenisChenu

DenisChenu

2020-04-20 09:28

developer   ~57257

I didn't like the autohide when in flow : because if you have already your mouse on a button : the button move :)

Currently : when there are error : it's hard to copy paste the text :)

A close link might make users forget that the question has not been saved.

But if auto hide : you are not sure user see it :)

ong

ong

2020-04-20 10:29

reporter   ~57258

Autohide is the current way I believe. I agree, that the user might not notice. But as the user has just clicked on SAVE he will probably assume that something happens.
Right now the user waits (dots on screen while saving) for the message. I would think this is not different when autohide would be use in future (well, it could flash 3 times or so).

Issue History

Date Modified Username Field Change
2020-03-29 11:45 f_funke New Issue
2020-03-29 11:45 f_funke File Added: grafik.png
2020-03-30 11:15 ong Note Added: 56834
2020-03-30 20:52 cdorin Priority none => high
2020-03-30 20:52 cdorin Status new => confirmed
2020-04-15 10:04 JHoeck Assigned To => JHoeck
2020-04-15 10:04 JHoeck Status confirmed => assigned
2020-04-15 10:04 JHoeck Status assigned => confirmed
2020-04-15 17:17 JHoeck Status confirmed => resolved
2020-04-15 17:17 JHoeck Resolution open => fixed
2020-04-18 11:04 tammo Note Added: 57234
2020-04-18 11:04 tammo Note Edited: 57234 View Revisions
2020-04-18 11:36 DenisChenu Note Added: 57236
2020-04-18 12:01 ong Note Added: 57241
2020-04-20 08:53 DenisChenu File Added: Capture d’écran du 2020-04-20 08-52-43.png
2020-04-20 08:53 DenisChenu Note Added: 57254
2020-04-20 08:54 DenisChenu Note Added: 57255
2020-04-20 09:25 ong Note Added: 57256
2020-04-20 09:28 DenisChenu Note Added: 57257
2020-04-20 10:29 ong Note Added: 57258