View Issue Details

IDProjectCategoryView StatusLast Update
16043Bug reportsSurvey takingpublic2020-07-29 22:08
Reporterong Assigned Tocdorin  
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.1.11 
Summary16043: 2 sided array with 9 steps not correct displayed
Description

Hi
this is also a problem un version 4.1.12 (which does not yet exist in the dropdown).

I have an array with 2 sides. Even on a full HD screen the layout is not correct: There is not enough space for the radio buttons (see attached image).

Steps To Reproduce

Create an array (type F)
Create two sided subquestions (like this: leftside|rightside)
Add 9 answers (1..9)
Preview/view the result

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.1.12+200324
I will donate to the project if issue is resolvedNo
Browservivaldi/chromium
Database & DB-Versionmysqlnd 5.0.12-dev - 20150407 / v 8.0.18
Server OS (if known)Debian 4.9.189-3+deb9u2 (2019-11-11) x86_64
Webserver software & version (if known)apache2
PHP Version7.something

Activities

ong

ong

2020-03-25 17:00

reporter  

Untitled.png (17,349 bytes)   
Untitled.png (17,349 bytes)   
cdorin

cdorin

2020-04-07 00:19

manager   ~56985

Hello, could you please attach an .lss file ? UnfortunatelyI was not able to reproduce it (latest master)

ong

ong

2020-04-07 12:10

reporter   ~57000

Hi cdorin,

I added a private note with a download link. If you can not see that, please let me know.
thanks.

ong

ong

2020-04-07 18:30

reporter   ~57014

Hi,

just updated to 4.1.16+200407 - all problems are still existing.
Do you think it's worth trying to export the survey. Create a completely new installation and database and import it back ... could the problems be gone?
ong

ong

ong

2020-04-08 09:23

reporter   ~57019

Hi,
just installed version 4.1.16+200407 in a new web root, with new mysql database and imported the lss - the problem still occurs, see new attached image

likert1-9_broken.png (89,539 bytes)   
likert1-9_broken.png (89,539 bytes)   
cdorin

cdorin

2020-07-07 19:03

manager   ~58762

Last edited: 2020-07-07 19:03

View 2 revisions

Hey @ong, the issue is very strange and I just can't reproduce it.

cdorin

cdorin

2020-07-07 19:03

manager   ~58763

See screenshot and how it looks on my machine - can you send us the .lss file? maybe there is a setting enabled that I am not aware of.

test_array_9 answer options.png (29,174 bytes)   
test_array_9 answer options.png (29,174 bytes)   
ong

ong

2020-07-13 10:21

reporter   ~58910

Really strange. I have closed my survey by now (which eventually did not use the 9 point scale). I guess it has been fixed.
Thanks for testing.
The lss file was the one I have sent before (and I can not find an old version which was using that scale right now).

cdorin

cdorin

2020-07-29 22:08

manager   ~59173

Most probably it was an issue with an older version since I remember having some array theme-related issues. Glad to hear now everything is fine :)

Issue History

Date Modified Username Field Change
2020-03-25 17:00 ong New Issue
2020-03-25 17:00 ong File Added: Untitled.png
2020-03-30 21:53 cdorin Priority none => high
2020-03-30 21:53 cdorin Status new => confirmed
2020-03-30 21:53 cdorin Description Updated View Revisions
2020-03-30 21:53 cdorin Steps to Reproduce Updated View Revisions
2020-04-07 00:19 cdorin Note Added: 56985
2020-04-07 00:19 cdorin Assigned To => cdorin
2020-04-07 00:19 cdorin Status confirmed => feedback
2020-04-07 12:09 ong Status feedback => assigned
2020-04-07 12:10 ong Note Added: 57000
2020-04-07 18:30 ong Note Added: 57014
2020-04-08 09:23 ong File Added: likert1-9_broken.png
2020-04-08 09:23 ong Note Added: 57019
2020-07-07 19:03 cdorin Note Added: 58762
2020-07-07 19:03 cdorin Note Edited: 58762 View Revisions
2020-07-07 19:03 cdorin Note Added: 58763
2020-07-07 19:03 cdorin File Added: test_array_9 answer options.png
2020-07-07 19:04 cdorin Assigned To cdorin =>
2020-07-07 19:04 cdorin Priority high => none
2020-07-07 19:04 cdorin Severity minor => partial_block
2020-07-07 19:04 cdorin Status assigned => feedback
2020-07-13 10:21 ong Note Added: 58910
2020-07-13 10:21 ong Status feedback => new
2020-07-29 22:08 cdorin Assigned To => cdorin
2020-07-29 22:08 cdorin Status new => closed
2020-07-29 22:08 cdorin Resolution open => fixed
2020-07-29 22:08 cdorin Note Added: 59173