View Issue Details

IDProjectCategoryView StatusLast Update
16034Bug reportsSurvey editingpublic2020-03-31 15:07
Reporterong Assigned Tocdorin  
PriorityurgentSeveritycrash 
Status closedResolutionno change required 
Product Version4.1.11 
Summary16034: Labelsets gone
Description

Hi

this also occurs in version 4.1.12.
When I save labels as a new labelset - it's not available afterwards.
Also old labelsets are not shown.

Steps To Reproduce

Create matrix question (type F) with subquestions
create answers
save those as labelset
click on "predefined label sets" -> you will see nothing (see animated attached image)

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.1.12+200324
I will donate to the project if issue is resolvedNo
Browservivaldi
Database & DB-Versionmysqlnd 5.0.12-dev - 20150407 / v 8.0.18
Server OS (if known)Debian 4.9.189-3+deb9u2 (2019-11-11) x86_64
Webserver software & version (if known)apache2
PHP Version7.something

Activities

ong

ong

2020-03-24 18:51

reporter  

labelset_gone.gif (206,872 bytes)
ong

ong

2020-03-25 11:23

reporter   ~56766

Afterwords:
Even when I use the admin menu to create new label sets, they do not show up when i want to choose a predefined label set.

cdorin

cdorin

2020-03-30 21:52

manager   ~56842

I think the label sets get saved as far as I remember but it is a problem of UX -> unless you type in something in the search box of predefined label sets, nothing will be displayed. COuld you please confirm that?

ong

ong

2020-03-31 07:46

reporter   ~56848

Hi cdorin,

yes, you are correct - I did not notice before.
When designing a question one can
save as predefined labelset
and
use predefined labelset.

Both options work.
Predefined sets are shown, once I click into the search box. Clicking is enough, when I type the search is being executed and the list limited to possible results.

ong

cdorin

cdorin

2020-03-31 15:07

manager   ~56858

Ok, I will then close this ticket. The UX problem is known internally - we will tackle it soon as well. Thanks for reporting it!

Issue History

Date Modified Username Field Change
2020-03-24 18:51 ong New Issue
2020-03-24 18:51 ong File Added: labelset_gone.gif
2020-03-25 11:23 ong Note Added: 56766
2020-03-30 21:52 cdorin Status new => feedback
2020-03-30 21:52 cdorin Description Updated View Revisions
2020-03-30 21:52 cdorin Steps to Reproduce Updated View Revisions
2020-03-30 21:52 cdorin Note Added: 56842
2020-03-31 07:46 ong Note Added: 56848
2020-03-31 07:46 ong Status feedback => new
2020-03-31 12:33 ollehar Priority none => urgent
2020-03-31 12:42 ollehar Severity minor => crash
2020-03-31 15:07 cdorin Assigned To => cdorin
2020-03-31 15:07 cdorin Status new => closed
2020-03-31 15:07 cdorin Resolution open => no change required
2020-03-31 15:07 cdorin Note Added: 56858