View Issue Details

IDProjectCategoryView StatusLast Update
16033Bug reportsSurvey editingpublic2021-02-24 14:39
Reporterong Assigned Toollehar  
PrioritynormalSeverityminor 
Status closedResolutionno change required 
Product Version4.1.11 
Summary16033: Sorting of questions broken
Description

Hi,

this error occurs also in 4.1.12 (which is not available yet from the dropdown on the bug reporting tool):
The sorting of questions is not working correctly and only with a workaround.

Steps To Reproduce

When I open structure and access a question group. There I click add a question to the group. Sometimes the order (first column in question group-view) is not correct, but shows
a) to high numbers (12345, 12347)
b) numbers not unique (1 -> 2 -> 2)
c) numbers with steps in between (1 -> 3 -> 5 instead of 1 -> 2 -> 3).

Additional Information

a) I was not able to solve the problem by unlocking structure view and dragging the questions
b) I was not able to solve the problem switching to settings -> question list, marking (all) questions and selecting "Set question group and position" below the question list in the lookup.

Doing those things I am somehow able to get the order of the questions I want (again).

Tagssorting
Complete LimeSurvey version number (& build)4.1.12+200324
I will donate to the project if issue is resolvedNo
Sync to Zoho ProjectYes
BrowserVivaldi
Database & DB-Versionmysqlnd 5.0.12-dev - 20150407 / version 8.0.18
Server OS (if known)Debian 4.9.189-3+deb9u2 (2019-11-11) x86_64
Webserver software & version (if known)apache2
PHP Version7.something

Activities

ong

ong

2020-03-24 18:36

reporter  

Untitled.png (7,349 bytes)   
Untitled.png (7,349 bytes)   
ong

ong

2020-03-24 19:05

reporter   ~56757

See weird sorting number in image

Untitled-2.png (2,922 bytes)   
Untitled-2.png (2,922 bytes)   
gabrieljenik

gabrieljenik

2021-02-18 21:35

developer   ~62367

Can you please update your version and retest?
This seems old and we have been working on this.

ong

ong

2021-02-19 08:32

reporter   ~62383

Hi,
well, I can not find my described way anymore. It seems to be not settings -> question list ... but there it seems no possible anymore to reorder.
LS 4.4.4+210212

Olaf

gabrieljenik

gabrieljenik

2021-02-22 16:10

developer   ~62453

Please, use the "reoganize" menu item on the left side bar

ong

ong

2021-02-22 18:23

reporter   ~62455

Hi,
well, I do not know what you mean. I know, I can drag & drop questions and groups and both seem to work in 4.4.7
Olaf

Jackwilliams

Jackwilliams

2021-02-22 19:04

reporter   ~62456

Last edited: 2021-02-23 09:16

View 2 revisions

Write down all the important points or information that you find useful. Also, even after taking notes, if you find any topic or concept difficult to understand, then you can go for assignment help online as well for clarifying your concepts.

Warning : SPAMMER, need to delete account.

ollehar

ollehar

2021-02-23 11:20

administrator   ~62459

Please check if this bug still exists in the latest patch release. Thank you.

ong

ong

2021-02-23 17:08

reporter   ~62471

Hi,
in the 4.4.7 version I can reliably drag and drop items and groups to new positions.
(but there are sooo many other bugs in 4.4.7 :-( ... I will see, that I report some)

gabrieljenik

gabrieljenik

2021-02-24 14:15

developer   ~62490

OK, so I guess this can be closed now?

ollehar

ollehar

2021-02-24 14:39

administrator   ~62492

Thank you, @ong. Yes, please report everything you can find. :) We're working hard to make it stable.

Issue History

Date Modified Username Field Change
2020-03-24 18:36 ong New Issue
2020-03-24 18:36 ong File Added: Untitled.png
2020-03-24 18:37 ong Tag Attached: sorting
2020-03-24 19:05 ong File Added: Untitled-2.png
2020-03-24 19:05 ong Note Added: 56757
2020-03-30 21:51 cdorin Priority none => normal
2020-03-30 21:51 cdorin Status new => confirmed
2020-03-30 21:51 cdorin Description Updated View Revisions
2020-03-30 21:51 cdorin Steps to Reproduce Updated View Revisions
2020-03-30 21:51 cdorin Additional Information Updated View Revisions
2021-02-09 13:43 cdorin Sync to Zoho Project => Yes
2021-02-18 21:35 gabrieljenik Note Added: 62367
2021-02-19 08:32 ong Note Added: 62383
2021-02-22 16:10 gabrieljenik Note Added: 62453
2021-02-22 18:23 ong Note Added: 62455
2021-02-22 19:04 Jackwilliams Note Added: 62456
2021-02-23 09:16 DenisChenu Note Edited: 62456 View Revisions
2021-02-23 11:20 ollehar Assigned To => ollehar
2021-02-23 11:20 ollehar Status confirmed => feedback
2021-02-23 11:20 ollehar Note Added: 62459
2021-02-23 17:08 ong Note Added: 62471
2021-02-23 17:08 ong Status feedback => assigned
2021-02-24 14:15 gabrieljenik Note Added: 62490
2021-02-24 14:39 ollehar Note Added: 62492
2021-02-24 14:39 ollehar Status assigned => closed
2021-02-24 14:39 ollehar Resolution open => no change required