View Issue Details

IDProjectCategoryView StatusLast Update
15981Bug reportsSurvey editingpublic2021-01-27 13:15
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version4.1.10 
Fixed in Version4.4.0-RC3 
Summary15981: question_template are not exported/imported
Description

When export and import a survey with Question theme (here boostrap button) : it was not exported, then not imported

Steps To Reproduce
  1. Activate the 2 button Question theme in global setting (core one)
  2. Import included LSS
  3. Check Theme of Q00010 : core
  4. Set Button theme
  5. Export
  6. Import : check Theme : core again
  7. Check XML : it's seems OK
Additional Information

Same with copy survey : Theme are not copied.

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.1.10 github
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)fedora/linux
Webserver software & version (if known)nginx
PHP Versionphp7.3

Relationships

related to 15963 assignedp_teichmann Display Theme Options are not saved for survey that has been copied 

Activities

DenisChenu

DenisChenu

2020-03-13 08:54

developer  

DenisChenu

DenisChenu

2020-03-13 08:58

developer   ~56439

3.X didn't have this issue :

  • import lss in 3.X : OK
  • import lss in master : KO
cdorin

cdorin

2021-01-22 11:01

manager   ~61635

Hey @DenisChenu , I cannot reproduce it in latest master (we merged develop into it). Can you please try again?

DenisChenu

DenisChenu

2021-01-22 11:16

developer   ~61637

Yes :)

Issue History

Date Modified Username Field Change
2020-03-13 08:54 DenisChenu New Issue
2020-03-13 08:54 DenisChenu File Added: limesurvey_survey_QTheme2.lss
2020-03-13 08:54 DenisChenu Relationship added related to 15963
2020-03-13 08:58 DenisChenu File Added: limesurvey_survey_ThemeFrom3X.lss
2020-03-13 08:58 DenisChenu Note Added: 56439
2020-03-13 11:01 ollehar Assigned To => p_teichmann
2020-03-13 11:01 ollehar Status new => assigned
2021-01-22 11:01 cdorin Assigned To p_teichmann =>
2021-01-22 11:01 cdorin Status assigned => feedback
2021-01-22 11:01 cdorin Note Added: 61635
2021-01-22 11:16 DenisChenu Assigned To => DenisChenu
2021-01-22 11:16 DenisChenu Status feedback => resolved
2021-01-22 11:16 DenisChenu Resolution open => fixed
2021-01-22 11:16 DenisChenu Fixed in Version => 4.4.0-RC3
2021-01-22 11:16 DenisChenu Note Added: 61637
2021-01-27 13:15 cdorin Status resolved => closed