View Issue Details

IDProjectCategoryView StatusLast Update
15926Bug reports[All Projects] Survey editingpublic2020-03-23 18:56
Reportervgavgavga Assigned To 
PrioritynoneSeveritymajor 
Status closedResolutionunable to reproduce 
Product Version4.1.6 
Target VersionFixed in Version 
Summary15926: Question Type Popup is blank
Description

When adding or editing Questions, when clicking on the Question type the popup is blank

Firefox error says bootstrap min 404 but file is there, when I click the link in FF debug console the bootstrap file opens

Steps To Reproduce

Add question
Click on question type
Get blank window

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.1.6+200220
I will donate to the project if issue is resolvedNo
BrowserFF 73.0 & Chrome 80.0.3987.122
Database & DB-Versionmariadb 10.4.12
Server OS (if known)
Webserver software & version (if known)
PHP Version7.3.15

Relationships

has duplicate 16007 closedcdorin Question type popup empty 

Activities

vgavgavga

vgavgavga

2020-02-27 15:50

reporter   ~56237

Update to Version 4.1.7+200224 same error

ollehar

ollehar

2020-02-27 16:55

administrator   ~56241

Any 500 in network tab? Can you enable debug = 2 in application/config/config.php and try again, please. Paste the complete error message here.

vgavgavga

vgavgavga

2020-02-27 19:14

reporter   ~56244

I will do tomorrow. It's some weird behaviour happening, when saving the survey a new question appears, when I try to delete it I get a 500

vgavgavga

vgavgavga

2020-02-27 19:22

reporter   ~56245

I get some 404s on spectrum.js, in contrast to the bootstrap min it really is not found

Mindflow

Mindflow

2020-02-28 13:32

reporter   ~56253

Hi,
I have the same problem here with the following Vue errors logged to the console:
[Vue warn]: Error in render: "TypeError: this.currentlySelectedType is null"

found in

---> <QuestionTypeSelector> at src/helperComponents/QuestionTypeSelector.vue
<VueJsModal> at src/Modal.vue
<ModalsContainer> at src/ModalsContainer.vue
<Lsnextquestioneditor> at src/App.vue
<Root> vue.esm.js:628

TypeError: "this.currentlySelectedType is null"
isSelected QuestionTypeSelector.vue:132
render QuestionTypeSelector.vue:126
renderList VueJS
render QuestionTypeSelector.vue:115
renderList VueJS
render QuestionTypeSelector.vue:43
VueJS 20

I can also confirm the problems with spectrum.js/css being loaded from the wrong folder in /tmp/assets

ollehar

ollehar

2020-02-28 14:15

administrator   ~56254

[Vue warn]: Error in render: "TypeError: this.currentlySelectedType is null"

Easily fixed. The other errors are non-related.

vgavgavga

vgavgavga

2020-02-28 14:30

reporter   ~56255

how can I fix this manually for the time being? I'm in need of creating a new survey :(

Mindflow

Mindflow

2020-02-28 14:32

reporter   ~56256

My workaround for this is to save the question, open another one, go back to the original question and then I get the overview in the question editor. Does that work for you?

ollehar

ollehar

2020-02-28 16:32

administrator   ~56260

Does it help to clear the cache?

vgavgavga

vgavgavga

2020-02-28 22:27

reporter   ~56261

Mindflows workaround helps

cdalexndr

cdalexndr

2020-03-20 16:48

reporter   ~56716

Another workaround is: "Global Settings" -> "General" tab -> Question type selector -> change to "Simple"

ollehar

ollehar

2020-03-20 17:20

administrator   ~56722

It would be nice with an exact step-by-step instruction on how to reproduce this issue. No one in our office has this problem.

cdalexndr

cdalexndr

2020-03-20 18:51

reporter   ~56723

Strangely, on my end it suddenly stopped reproducing. Before that it was easily reproductible.
Recreated database, even tried different browser (Edge), but now it doesn't reproduce anymore.
Using docker image: martialblog/limesurvey:4.1.10_200311-fpm-alpine

ollehar

ollehar

2020-03-23 18:56

administrator   ~56741

Please reopen this issue if the problem reappears.

Issue History

Date Modified Username Field Change
2020-02-27 15:03 vgavgavga New Issue
2020-02-27 15:03 vgavgavga File Added: 2020-02-27 15_00_30-Window.png
2020-02-27 15:03 vgavgavga File Added: 2020-02-27 15_00_54-Window.png
2020-02-27 15:50 vgavgavga Note Added: 56237
2020-02-27 16:55 ollehar Note Added: 56241
2020-02-27 19:14 vgavgavga File Added: 2020-02-27 19_11_27-LimeSurvey.png
2020-02-27 19:14 vgavgavga File Added: 2020-02-27 19_09_54-500_ Interner Serverfehler.png
2020-02-27 19:14 vgavgavga Note Added: 56244
2020-02-27 19:22 vgavgavga File Added: 2020-02-27 19_22_00-CN=Microsoft Windows, O=Microsoft Corporation, L=Redmond, S=Washington, C=US.png
2020-02-27 19:22 vgavgavga File Added: 2020-02-27 19_22_11-404 Nicht gefunden.png
2020-02-27 19:22 vgavgavga Note Added: 56245
2020-02-28 11:14 vgavgavga File Deleted: 2020-02-27 15_00_30-Window.png
2020-02-28 11:14 vgavgavga File Deleted: 2020-02-27 15_00_54-Window.png
2020-02-28 11:14 vgavgavga File Deleted: 2020-02-27 19_11_27-LimeSurvey.png
2020-02-28 11:14 vgavgavga File Deleted: 2020-02-27 19_09_54-500_ Interner Serverfehler.png
2020-02-28 11:14 vgavgavga File Deleted: 2020-02-27 19_22_00-CN=Microsoft Windows, O=Microsoft Corporation, L=Redmond, S=Washington, C=US.png
2020-02-28 11:15 vgavgavga File Deleted: 2020-02-27 19_22_11-404 Nicht gefunden.png
2020-02-28 13:32 Mindflow Note Added: 56253
2020-02-28 14:15 ollehar Note Added: 56254
2020-02-28 14:30 vgavgavga Note Added: 56255
2020-02-28 14:32 Mindflow Note Added: 56256
2020-02-28 16:32 ollehar Note Added: 56260
2020-02-28 22:27 vgavgavga Note Added: 56261
2020-03-20 16:48 cdalexndr Note Added: 56716
2020-03-20 17:20 ollehar Note Added: 56722
2020-03-20 18:51 cdalexndr Note Added: 56723
2020-03-20 23:30 cdorin Relationship added has duplicate 16007
2020-03-23 18:56 ollehar Status new => closed
2020-03-23 18:56 ollehar Resolution open => unable to reproduce
2020-03-23 18:56 ollehar Note Added: 56741