View Issue Details

IDProjectCategoryView StatusLast Update
15872Bug reportsErgonomypublic2020-12-28 18:42
ReporterDenisChenu Assigned Tocdorin  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Fixed in Version4.4.0-RC1 
Summary15872: No error about duplicate code when copy
DescriptionWhen copying question : use same code than previous question didn't show any error.
Steps To ReproduceCreate a survey, set code to Q01
Click on copy
Set code to Q01 : no error
Additional InformationAfter save : come back to the question editor/copy. Red alert is empty
TagsNo tags attached.
Complete LimeSurvey version number (& build)4.1.4 github
I will donate to the project if issue is resolvedNo
BrowserFirefox ESR
Database & DB-Versionmariadb
Server OS (if known)debian
Webserver software & version (if known)apache
PHP Versionphp7.3

Activities

DenisChenu

DenisChenu

2020-02-13 17:16

developer  

DenisChenu

DenisChenu

2020-02-13 17:19

developer   ~55982

And at the 3rd copy : error shown ..
All the _fix_ are broken ...
cdorin

cdorin

2020-02-21 00:28

manager   ~56124

Can you confirm with latest master release? (message displayed here with debug off - didn t test with debug 2)

I would take out the red alert since there is already a warning below the code.
DenisChenu

DenisChenu

2020-02-21 09:14

developer   ~56129

In 3.X : you CAN NOT submit a bad code. We use customValidity to diable submit. It's not done in 4.X

> I would take out the red alert since there is already a warning below the code.

No wer MUST disable submit ...


Else : again this morning (after pull and reset)

1. Create a question with a sample question
2. Update question code from Q00 to Q01 : **FALSE ERROR ARE SHOWN**
3. Save : OK
4. Copy : set Q01Copy to Q01 : **NO ERROR**
5. Save : red alert + all reset ...
DenisChenu

DenisChenu

2020-02-21 09:20

developer   ~56130

Video step for reproduce

[![Peek-21-02-2020-09-17.gif](https://s5.gifyu.com/images/Peek-21-02-2020-09-17.gif)](https://gifyu.com/image/7RFS)

https://s5.gifyu.com/images/Peek-21-02-2020-09-17.gif
DenisChenu

DenisChenu

2020-02-21 09:21

developer   ~56131

> I would take out the red alert since there is already a warning below the code.

The warning is **invalid** see screencast ...

Issue History

Date Modified Username Field Change
2020-02-13 17:16 DenisChenu New Issue
2020-02-13 17:16 DenisChenu File Added: Capture d’écran du 2020-02-13 17-12-00.png
2020-02-13 17:16 DenisChenu File Added: Capture d’écran du 2020-02-13 17-14-59.png
2020-02-13 17:19 DenisChenu File Added: Capture d’écran du 2020-02-13 17-17-32.png
2020-02-13 17:19 DenisChenu Note Added: 55982
2020-02-21 00:28 cdorin Note Added: 56124
2020-02-21 09:14 DenisChenu Note Added: 56129
2020-02-21 09:20 DenisChenu Note Added: 56130
2020-02-21 09:21 DenisChenu Note Added: 56131
2020-02-21 14:52 cdorin Assigned To => cdorin
2020-02-21 14:52 cdorin Status new => assigned
2020-12-28 18:42 cdorin Status assigned => closed
2020-12-28 18:42 cdorin Resolution open => fixed
2020-12-28 18:42 cdorin Fixed in Version => 4.4.0-RC1