View Issue Details

IDProjectCategoryView StatusLast Update
15837Bug reportsPluginspublic2020-10-19 10:13
Reporterrovinj Assigned Togabrieljenik  
PrioritynoneSeverityfeature 
Status closedResolutionfixed 
Product Version4.3.3 
Summary15837: After upgrade plugins are duplicated
Description

After upgrade plugins are duplicated, old plugin giv error 500.

TagsNo tags attached.
Complete LimeSurvey version number (& build)LimeSurvey 4
I will donate to the project if issue is resolved
Browser
Database & DB-Version
Server OS (if known)
Webserver software & version (if known)
PHP Version

Relationships

duplicate of 15805 assignedollehar Plugins duplicated 

Activities

rovinj

rovinj

2020-02-08 17:36

reporter  

2020-02-08 17_35_48-Window.png (17,005 bytes)   
2020-02-08 17_35_48-Window.png (17,005 bytes)   
cdorin

cdorin

2020-03-19 16:51

manager   ~56678

Hey, and thanks for your feedback!

How did you upgrade if I may ask? Via Comfort Update or git?

Also, which version are you using right now?

yniquet

yniquet

2020-07-08 19:47

reporter   ~58812

When we update LS CE from 3.14 to 4.1 or 4.3 the plugin are duplicates in the tablle plugin.
I create a empty folder for LS4, unzip the new version 4.3 and process the update database with no errors after my first connexion.
I you clic on the active plugin that give me error 500

cdorin

cdorin

2020-07-29 20:11

manager   ~59161

@eddylackmann, maybe that is something that also needs to be checked in plugin manager

gabrieljenik

gabrieljenik

2020-08-24 21:37

developer   ~59598

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1562

gabrieljenik

gabrieljenik

2020-10-15 09:33

developer   ~60211

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30599

lime_release_bot

lime_release_bot

2020-10-19 10:13

administrator   ~60259

Fixed in Release 4.3.22+201019

Related Changesets

LimeSurvey: master ea060499

2020-08-24 21:35:55

gabrieljenik

Details Diff
Fixed issue 15837: After upgrade plugins are duplicated

InstalledPlugins variable had the wrong form.
Affected Issues
15837
mod - application/helpers/update/updatedb_helper.php Diff File

LimeSurvey: master e2505b1f

2020-10-15 09:33:12

ollehar


Committer: GitHub Details Diff
Fixed issue 15837: After upgrade plugins are duplicated

Merge pull request #1562 from gabrieljenik/bug/15837--After-upgrade-plugins-are-duplicated
Affected Issues
15837
mod - application/helpers/update/updatedb_helper.php Diff File

Issue History

Date Modified Username Field Change
2020-02-08 17:36 rovinj New Issue
2020-02-08 17:36 rovinj File Added: 2020-02-08 17_35_48-Window.png
2020-02-09 10:48 DenisChenu Relationship added duplicate of 15805
2020-03-19 15:49 ollehar Project Feature requests => Bug reports
2020-03-19 16:51 cdorin Assigned To => cdorin
2020-03-19 16:51 cdorin Status new => feedback
2020-03-19 16:51 cdorin Complete LimeSurvey version number (& build) => LimeSurvey 4
2020-03-19 16:51 cdorin Note Added: 56678
2020-07-08 19:47 yniquet Note Added: 58812
2020-07-08 19:47 yniquet File Added: 2020-07-08 13_35_54-Mysql-lab_limesurvey_lab_plugins_ - HeidiSQL 9.5.0.5278.jpg
2020-07-08 19:47 yniquet File Added: 2020-07-08 13_45_48-500 _ Erreur interne au serveur.jpg
2020-07-09 12:44 ollehar Product Version => 4.3.3
2020-07-29 20:11 cdorin Note Added: 59161
2020-08-20 15:24 cdorin Assigned To cdorin => gabrieljenik
2020-08-24 21:37 gabrieljenik Note Added: 59598
2020-10-15 09:33 ollehar Changeset attached => LimeSurvey master e2505b1f
2020-10-15 09:33 gabrieljenik Changeset attached => LimeSurvey master ea060499
2020-10-15 09:33 gabrieljenik Note Added: 60211
2020-10-15 09:33 gabrieljenik Resolution open => fixed
2020-10-15 09:55 ollehar Status feedback => resolved
2020-10-19 10:13 lime_release_bot Note Added: 60259
2020-10-19 10:13 lime_release_bot Status resolved => closed