View Issue Details

IDProjectCategoryView StatusLast Update
15827Bug reports[All Projects] User / Groups / Rolespublic2020-02-12 18:50
ReporterDenisChenu Assigned To 
PrioritynoneSeverityminor 
Status closedResolutionunable to reproduce 
Product Version4.1.1 
Target VersionFixed in Version 
Summary15827: Unable to delete user : CRSF issue
Description

When try to delete any user : receive a 500 error

Steps To Reproduce
  1. Log in as admin
  2. Create a sample user
  3. See list of user
  4. Click on delete button
  5. Confirm
  6. CRSF issue
Additional Information

We must use POST (and control CRSF) since it was a delete action.

In 3.X : we goes to a "confirm" page to set survey to another user.

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.1.1 github
I will donate to the project if issue is resolvedNo
Browsernot relevant (FF)
Database & DB-Versionnot relevant?
Server OS (if known)not relevant ?
Webserver software & version (if known)not relevant ?
PHP Versionnot relevant ?

Activities

DenisChenu

DenisChenu

2020-02-06 08:20

developer   ~55774

My opinion :

  1. Move for bootstrap.widgets.TbGridView to ext.LimeGridView.LimeGridView
  2. Use LimeGridView buttons system https://github.com/LimeSurvey/LimeSurvey/blob/2141c44d33ae145d7ab602f1818a15c40fc483b1/application/models/SurveyDynamic.php#L275
cdorin

cdorin

2020-02-12 18:20

manager   ~55929

@eddylackmann, any thoughts on this one?
Cannot personally reproduce it.

eddylackmann

eddylackmann

2020-02-12 18:25

developer   ~55930

I can't reproduce it !

DenisChenu

DenisChenu

2020-02-12 18:50

developer   ~55931

Yep, can not reproduce currently

Issue History

Date Modified Username Field Change
2020-02-06 08:18 DenisChenu New Issue
2020-02-06 08:20 DenisChenu Note Added: 55774
2020-02-12 18:20 cdorin Note Added: 55929
2020-02-12 18:25 eddylackmann Note Added: 55930
2020-02-12 18:50 DenisChenu Status new => closed
2020-02-12 18:50 DenisChenu Resolution open => unable to reproduce
2020-02-12 18:50 DenisChenu Note Added: 55931