View Issue Details

This bug affects 1 person(s).
 8
IDProjectCategoryView StatusLast Update
15812Bug reportsImport/Exportpublic2021-08-04 15:28
Reporterpaulierco Assigned Toollehar  
PrioritynoneSeverityblock 
Status closedResolutionfixed 
Product Version4.1.0 
Summary15812: export pdf/csv/doc not working anymore
DescriptionSince i did the upgrade to 4.1.0 from 3.2.1, export of surveys is not working anymore.

PDF export error -> [image.png] attached.
If i'm trying to
Steps To ReproducePDF export error -> [image.png] attached.
If i'm trying to export Word, i have this error:

"File not found

Firefox can’t find the file at http://survey.domain.com/index.php/admin/export/sa/exportresults/surveyid/135786.

    Check the file name for capitalization or other typing errors.
    Check to see if the file was moved, renamed or deleted."
Additional Information php -v
PHP 7.2.27-5+ubuntu16.04.1+deb.sury.org+2 (cli) (built: Feb 1 2020 18:00:16) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.27-5+ubuntu16.04.1+deb.sury.org+2, Copyright (c) 1999-2018, by Zend Technologies

mysql -V
mysql Ver 14.14 Distrib 5.7.29, for Linux (x86_64) using EditLine wrapper
TagsNo tags attached.
Bug heat8
Complete LimeSurvey version number (& build)Version 4.1.0+200128
I will donate to the project if issue is resolvedYes
BrowserFirefox 71
Database & DB-Versionmysql Ver 14.14 Distrib 5.7.29
Server OS (if known)Ubuntu 16.04
Webserver software & version (if known)
PHP VersionPHP 7.2.27-5+ubuntu16.04.1

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

paulierco

paulierco

2020-02-02 11:38

reporter  

image.png (71,922 bytes)   
image.png (71,922 bytes)   
ollehar

ollehar

2020-02-03 10:00

administrator   ~55630

Whoever fixes this, please make a regression test.
ollehar

ollehar

2020-02-03 11:39

administrator   ~55639

Please put debug = 0 and try again.
ollehar

ollehar

2020-02-03 11:44

administrator   ~55640

This only happens to certain surveys. I've managed to reproduce it on a big survey, but not a small one yet.
ollehar

ollehar

2020-02-03 11:46

administrator  

paulierco

paulierco

2020-02-03 14:54

reporter   ~55654

As a workaround you have to disable the timing when you enable the survey.
Also, if the survey is already active, when you tried to export the PDF, you have to uncheck the the interviewtime and everything is related to timing. Export to PDF will work then.
c_schmitz

c_schmitz

2021-03-22 10:25

administrator   ~63515

Hello paulierco,
This should already be fixed in recent versions.
Can you please check if this issue still exists in the latest version of LimeSurvey and let us know?
Thank you!
galads

galads

2021-08-04 15:28

administrator   ~65833

Hello paulierco,

we have asked for feedback on this issue. Because we did not get an answer we assume that the issue is resolved.
However, should you be able to reproduce the issue using the latest version, please feel free to re-open the issue and give us exact details on how to reproduce it.

Thank you and best regards,

galads

Issue History

Date Modified Username Field Change
2020-02-02 11:38 paulierco New Issue
2020-02-02 11:38 paulierco File Added: image.png
2020-02-03 10:00 ollehar Note Added: 55630
2020-02-03 11:20 ollehar Assigned To => ollehar
2020-02-03 11:20 ollehar Status new => confirmed
2020-02-03 11:39 ollehar Note Added: 55639
2020-02-03 11:44 ollehar Note Added: 55640
2020-02-03 11:46 ollehar File Added: survey_archive_614243.lsa
2020-02-03 14:54 paulierco Note Added: 55654
2021-03-02 18:22 ollehar Status confirmed => feedback
2021-03-22 10:25 c_schmitz Note Added: 63515
2021-08-04 15:28 galads Status feedback => closed
2021-08-04 15:28 galads Resolution open => fixed
2021-08-04 15:28 galads Note Added: 65833
2021-08-04 15:28 galads Bug heat 6 => 8