View Issue Details

IDProjectCategoryView StatusLast Update
15783Bug reportsSurvey takingpublic2020-06-29 11:46
ReporterDenisChenu Assigned To 
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version4.0.1 
Summary15783: Print answers : all is empty
Description

All is empty for print answers for this survey

Steps To Reproduce

Import includd survey,
Launch,
See the value (default)
See the printanswers link
Click : no answers part
Click on PDF Dowload : except a line : all is empty
QueXML PDF is OK.

Additional Information

I just create a new survey … nothing other.
Then : think it's for whole survey ?

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.1 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 15529 closedcdorin Print answer wrongly includes hidden questions 
has duplicate 15907 closed Printanswer functionality not working (Print results page and PDF is empty) 

Activities

DenisChenu

DenisChenu

2020-01-27 18:09

developer  

test-print-935774.pdf (84,957 bytes)
DenisChenu

DenisChenu

2020-01-31 17:12

developer   ~55608

Same with : https://bugs.limesurvey.org/view.php?id=15529

BrunoLime

BrunoLime

2020-02-18 12:24

reporter   ~56069

Last edited: 2020-06-25 11:36

I today created a test survey on demo.limesurvey.org (4.1.1). The print PDF at the end of the survey shows no questions but only one page with the survy title (see attached PDF).

test-522962-2.pdf (84,873 bytes)
edv

edv

2020-03-18 10:44

reporter   ~56633

Last edited: 2020-06-25 11:36

Showing the answers of the survey in PDF still not working in 4.1.8
created a testsurvey with option "user can print answers", queXML PDF is fine, but exported PDF has only two lines and the name of the survey, no answers

DenisChenu

DenisChenu

2020-03-18 11:14

developer   ~56635

Last edited: 2020-06-25 11:36

I start working on print answers in 3.X
Seems print answers system are not updated according to i10n new table ....

cdorin

cdorin

2020-04-07 00:39

manager   ~56988

Last edited: 2020-06-25 11:36

Hey DEnis, unfortunately, I cannot reproduce it. Do you still have the issue in latest master/dev?

DenisChenu

DenisChenu

2020-04-07 08:52

developer   ~56989

Last edited: 2020-06-25 11:36

@cdorin : yes and i don't understand why you can't reproduce ...

Peek 07-04-2020 08-52.gif (409,738 bytes)
DenisChenu

DenisChenu

2020-04-07 09:00

developer   ~56990

Last edited: 2020-06-25 11:36

The issue is here : https://github.com/LimeSurvey/LimeSurvey/blob/d0dc99c6ea0c0929b1cc0cb793b1186298a33589/application/models/SurveyDynamic.php#L994

$oGroup->language are not set in 4.X

cdorin

cdorin

2020-04-07 09:59

manager   ~56993

Last edited: 2020-06-25 11:36

Bhaa, did not test it correctly. Thanks for the .gif!

DenisChenu

DenisChenu

2020-04-07 10:00

developer   ~56994

Last edited: 2020-06-25 11:36

Import includd survey,
Launch,
See the value (default)
See the printanswers link
Click : no answers part
Click on PDF Dowload : except a line : all is empty
QueXML PDF is OK.

Are unclear ?

cdorin

cdorin

2020-04-07 10:01

manager   ~56995

Last edited: 2020-06-25 11:36

Nop. Guess the conclusion is never do testing after 10 PM :)

edv

edv

2020-04-07 10:40

reporter   ~56997

Last edited: 2020-06-25 11:36

Testet with 4.1.15
PDF is empty as before
please see post from DenisChenu
(would realy like to see this working again...)

result

result

2020-05-11 17:28

reporter   ~57686

Last edited: 2020-06-25 11:36

Tested with 4.2.3+200511.

Would really hate to downgrade again to 3.x to get printing working. Is there any workaround yet?

gabrieljenik

gabrieljenik

2020-06-19 16:18

partner   ~58361

Last edited: 2020-06-25 11:36

From what we have seen, the new languages i10n models are not taken into account by that method and neither by getQuestionArray.
Also, when conforming $aGroupAttributes will also add the group_name, description and language attribute from the QuestionGroupL10n as to comply with backwards comaptibility.

Will adapt both.

sushmanadendla

sushmanadendla

2020-06-22 16:55

manager   ~58377

Last edited: 2020-06-25 11:36

Tested the issue by checking out to branch in master below attaching the findings. Answers have been printed on the PDF.
Working as Expected

test-print-935774-2.pdf (86,142 bytes)
guest

guest

2020-06-23 16:02

viewer   ~58407

Last edited: 2020-06-25 11:36

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30208

lime_release_bot

lime_release_bot

2020-06-29 11:46

administrator   ~58539

Fixed in Release 4.3.2+200629

Related Changesets

LimeSurvey: master ea846162

2020-06-23 16:02:22

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 15783: Print answers : all is empty (#1442) Affected Issues
15783
mod - application/models/SurveyDynamic.php Diff File

Issue History

Date Modified Username Field Change
2020-01-27 18:09 DenisChenu New Issue
2020-01-27 18:09 DenisChenu File Added: test-print-935774.pdf
2020-01-27 18:09 DenisChenu File Added: survey_archive_935774.lsa
2020-01-31 17:12 DenisChenu Note Added: 55608
2020-01-31 17:12 DenisChenu Relationship added related to 15529
2020-02-05 08:53 cdorin Assigned To => cdorin
2020-02-05 08:53 cdorin Status new => assigned
2020-02-18 12:24 BrunoLime File Added: test-522962-2.pdf
2020-02-18 12:24 BrunoLime Note Added: 56069
2020-02-22 20:32 cdorin Assigned To cdorin =>
2020-02-22 20:32 cdorin Priority none => normal
2020-02-22 20:32 cdorin Status assigned => confirmed
2020-03-18 10:44 edv Note Added: 56633
2020-03-18 11:14 DenisChenu Note Added: 56635
2020-04-07 00:39 cdorin Note Added: 56988
2020-04-07 00:40 cdorin Assigned To => cdorin
2020-04-07 00:40 cdorin Status confirmed => assigned
2020-04-07 00:40 cdorin Assigned To cdorin =>
2020-04-07 00:40 cdorin Status assigned => feedback
2020-04-07 08:52 DenisChenu File Added: Peek 07-04-2020 08-52.gif
2020-04-07 08:52 DenisChenu Note Added: 56989
2020-04-07 08:52 DenisChenu Status feedback => new
2020-04-07 09:00 DenisChenu Note Added: 56990
2020-04-07 09:59 cdorin Note Added: 56993
2020-04-07 09:59 cdorin Status new => confirmed
2020-04-07 10:00 DenisChenu Note Added: 56994
2020-04-07 10:01 cdorin Note Added: 56995
2020-04-07 10:40 edv Note Added: 56997
2020-05-11 17:28 result Note Added: 57686
2020-06-19 16:18 gabrieljenik Note Added: 58361
2020-06-22 09:50 DenisChenu Relationship added has duplicate 15907
2020-06-22 16:55 sushmanadendla Note Added: 58377
2020-06-22 16:55 sushmanadendla File Added: printanswertest-851999.pdf
2020-06-22 16:55 sushmanadendla File Added: test-print-935774-2.pdf
2020-06-23 16:02 gabrieljenik Changeset attached => LimeSurvey master ea846162
2020-06-23 16:02 guest Note Added: 58407
2020-06-25 11:36 swendrich Status confirmed => resolved
2020-06-29 11:46 lime_release_bot Note Added: 58539
2020-06-29 11:46 lime_release_bot Status resolved => closed
2020-06-29 11:46 lime_release_bot Resolution open => fixed