View Issue Details

IDProjectCategoryView StatusLast Update
15732Bug reportsSurvey editingpublic2021-03-03 14:11
ReporterDenisChenu Assigned ToJHoeck  
PriorityhighSeverityminor 
Status closedResolutionwon't fix 
Product Version4.0.0-RC14 
Summary15732: Ressource manager show ressources for ALL surveys …
DescriptionResource manager showing all surveys resource.
Steps To ReproduceClick on resources on right menu : see resources (and manage) for all surveys.
Additional InformationThis hide the real survey tab
Can have a 'global resource' but if i click on survey 123 : i want only 123 resources.

And **what happen if you have more than 200 survey's ?** The list become unusuable … did you check ?
TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.0 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Activities

DenisChenu

DenisChenu

2020-01-17 07:33

developer  

DenisChenu

DenisChenu

2020-01-17 07:36

developer   ~55342

Can you find 992119 survey id on the list ? no : it's 3 screen after …
jelo

jelo

2021-02-26 18:13

partner   ~62539

Is that still relevant or is the part removed`?
When trying to click on Resources of a Survey in LS 4.4.10 the Browser Is trying to get /index.php/admin/filemanager?surveyid=123345, but nothing happens.

The URL is not working.
/index.php/admin/filemanager?surveyid=831885&1614359540353=
Status404
Not Found
VersionHTTP/2
Transferred352 B (80 B size)
Referrer Policyno-referrer-when-downgrade
DenisChenu

DenisChenu

2021-02-27 09:02

developer   ~62543

You're right @jelo : «new super file manager» was removed from 4.4

I close this one
jelo

jelo

2021-02-27 09:20

partner   ~62546

Last edited: 2021-02-27 09:21

View 2 revisions

Is Resources removed from the Survey menu? I have a LS 4.4.10 here and a click on Resources is a broken URL as stated in the comment above?
DenisChenu

DenisChenu

2021-02-27 10:48

developer   ~62547

Your issue is surely related to this issue [17128: Outdated menu follow to 404 : demo.limesurvey.org](https://bugs.limesurvey.org/view.php?id=17128)

I report again this issue with menu, because all previous one was closed as "reset to default" …
DenisChenu

DenisChenu

2021-02-27 10:50

developer   ~62548

@jelo : blood tears ?
jelo

jelo

2021-02-27 11:05

partner   ~62551

@DenisChenu: Thanks, I will comment there.

Yes, my eyesball are tearing blood. I have no tears of water left.
ollehar

ollehar

2021-03-03 13:59

administrator   ~62635

All 404s in the side-menu are related to database update and controller refactoring. Go to menu entries and reset everything.
DenisChenu

DenisChenu

2021-03-03 14:07

developer   ~62637

Yes : but you can ask to user to reset menu : if they have updated (manually) menu : they can not really reset, no ?
jelo

jelo

2021-03-03 14:11

partner   ~62639

@ollehar: Thanks, that was also mentioned in a different ticket. Shouldn't that be triggered when doing updates? At least ComfortUpdate should be able to trigger the reset.

Issue History

Date Modified Username Field Change
2020-01-17 07:33 DenisChenu New Issue
2020-01-17 07:33 DenisChenu File Added: Capture d’écran du 2020-01-17 07-31-37.png
2020-01-17 07:36 DenisChenu Note Added: 55342
2020-01-17 14:15 cdorin Assigned To => cdorin
2020-01-17 14:15 cdorin Status new => assigned
2020-01-17 14:15 cdorin Priority none => high
2020-01-22 14:15 JHoeck Assigned To cdorin => JHoeck
2021-02-26 18:13 jelo Note Added: 62539
2021-02-27 09:02 DenisChenu Status assigned => closed
2021-02-27 09:02 DenisChenu Resolution open => won't fix
2021-02-27 09:02 DenisChenu Note Added: 62543
2021-02-27 09:20 jelo Note Added: 62546
2021-02-27 09:21 jelo Note Edited: 62546 View Revisions
2021-02-27 10:48 DenisChenu Note Added: 62547
2021-02-27 10:48 DenisChenu File Added: Capture d’écran du 2021-02-27 10-47-09.png
2021-02-27 10:50 DenisChenu Note Added: 62548
2021-02-27 11:05 jelo Note Added: 62551
2021-03-03 13:59 ollehar Note Added: 62635
2021-03-03 14:07 DenisChenu Note Added: 62637
2021-03-03 14:11 jelo Note Added: 62639