View Issue Details

IDProjectCategoryView StatusLast Update
15711Bug reports[All Projects] Survey editingpublic2020-01-21 10:57
ReporterDenisChenu Assigned ToJHoeck  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version4.0.0-RC14 
Target VersionFixed in Version 
Summary15711: Question editor break existing HTML
Description

If you have complex HTML : question editor can break it when you update

Steps To Reproduce

See screencast

Copy paste

<dl>
    <dt>Terme</dt>
    <dd>Definition</dd>
</dl>

in source dit
Save
Add anything in HTML edit
Save
Chec source

Additional Information

Since we can not totally disable HTML editor (have it on demand only)
And source edit broke question edit : https://bugs.limesurvey.org/view.php?id=15531

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.0-RC14
I will donate to the project if issue is resolvedNo
Browserfirefox
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Activities

DenisChenu

DenisChenu

2020-01-14 15:33

developer  

Peek 14-01-2020 15-30.gif (1,022,398 bytes)
JHoeck

JHoeck

2020-01-21 10:57

manager   ~55400

This issue is not a bug.

Issue History

Date Modified Username Field Change
2020-01-14 15:33 DenisChenu New Issue
2020-01-14 15:33 DenisChenu File Added: Peek 14-01-2020 15-30.gif
2020-01-14 17:11 cdorin Assigned To => cdorin
2020-01-14 17:11 cdorin Status new => assigned
2020-01-15 11:34 cdorin Assigned To cdorin => JHoeck
2020-01-21 10:57 JHoeck Status assigned => closed
2020-01-21 10:57 JHoeck Resolution open => fixed
2020-01-21 10:57 JHoeck Note Added: 55400