View Issue Details

IDProjectCategoryView StatusLast Update
15677Bug reportsInstallationpublic2020-01-14 17:11
ReporterMazi Assigned Tocdorin  
PrioritynoneSeveritycrash 
Status closedResolutionno change required 
Product Version3.21.2 
Summary15677: New installation fails with message "Alias "application.helpers.expressions.warnings.EMWarningInvalidComparison" is invalid."
Description

I just tried installing the latest 3.21.2 but after entering the DB details I get this error:
Internal Server Error
Alias "application.helpers.expressions.warnings.EMWarningInvalidComparison" is invalid. Make sure it points to an existing PHP file and the file is readable.

I am unable to finish the installation.

Steps To Reproduce

I just donwloaded the latest release and ran the installer, entered DB details and then the error shows up.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.21.2
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)?
Webserver software & version (if known)MySQL
PHP Version7.2.24

Activities

cdorin

cdorin

2019-12-19 10:37

manager   ~55072

Hey @DenisChenu, is this one for you?

DenisChenu

DenisChenu

2019-12-19 10:48

developer   ~55073

@olle add this new helpers , but i can have a look
https://github.com/LimeSurvey/LimeSurvey/commit/09e1a548188003b011d657bd96d43ff3005860c8#diff-982754e35e16018256509084e1c64a14

My opinion is to do it in 4 and not in 3.X ;)

DenisChenu

DenisChenu

2019-12-19 10:49

developer   ~55074

@ollehar ;)

DenisChenu

DenisChenu

2019-12-19 15:07

developer   ~55085

Using old BD : no issue.

I check with an empty DB

DenisChenu

DenisChenu

2019-12-19 15:11

developer   ~55086

Even with a new DB : can not confirm : i can't reproduce on last GIT versin.

@cdorin : can you reproduce ?

Mazi

Mazi

2019-12-19 15:44

partner   ~55092

@DenisChenu, I may have missed a detail. The error actually did NOT show up with a fresh installation (empty DB) but when updating an old 1.92 system with an existing DB.

DenisChenu

DenisChenu

2019-12-19 15:45

developer   ~55093

OK,

Then it's in upgrade process …

ollehar

ollehar

2020-01-06 11:39

administrator   ~55129

I'm guessing the file is missing?

Mazi

Mazi

2020-01-06 11:41

partner   ~55130

I am not sure, @ollehar. The issues shows up when updating an old DB using the latest LS 3 files. So the file should be there?!

ollehar

ollehar

2020-01-06 16:03

administrator   ~55132

Check the folder? application/helpers/expressions/warnings/EMWarningInvalidComparison.php

Mazi

Mazi

2020-01-06 16:32

partner   ~55133

Hmm, at the backup I created the file does not exist, though it should be included at version 3.21.2, see screenshot. No idea why it was not there, maybe just a temporary upload problem. Feel free to close this ticket if you can't reproduce.

image.png (55,903 bytes)   
image.png (55,903 bytes)   
ollehar

ollehar

2020-01-06 16:41

administrator   ~55134

Where/how did you create that file structure?

Mazi

Mazi

2020-01-06 17:07

partner   ~55135

If I remember correctly I downloaded the ZIP from ls.org, unzipped and uploaded to the server as is.

c_schmitz

c_schmitz

2020-01-14 15:14

administrator   ~55232

Well, I guess you did not upload all files then or someone/something removed the file after upload.

Issue History

Date Modified Username Field Change
2019-12-19 10:35 Mazi New Issue
2019-12-19 10:37 cdorin Note Added: 55072
2019-12-19 10:37 cdorin Assigned To => cdorin
2019-12-19 10:37 cdorin Status new => assigned
2019-12-19 10:48 DenisChenu Note Added: 55073
2019-12-19 10:49 DenisChenu Note Added: 55074
2019-12-19 15:07 DenisChenu Note Added: 55085
2019-12-19 15:11 DenisChenu Note Added: 55086
2019-12-19 15:44 Mazi Note Added: 55092
2019-12-19 15:45 DenisChenu Note Added: 55093
2020-01-06 11:39 ollehar Note Added: 55129
2020-01-06 11:39 ollehar Status assigned => feedback
2020-01-06 11:41 Mazi Note Added: 55130
2020-01-06 11:41 Mazi Status feedback => assigned
2020-01-06 16:03 ollehar Note Added: 55132
2020-01-06 16:32 Mazi File Added: image.png
2020-01-06 16:32 Mazi Note Added: 55133
2020-01-06 16:41 ollehar Note Added: 55134
2020-01-06 17:07 Mazi Note Added: 55135
2020-01-14 15:14 c_schmitz Note Added: 55232
2020-01-14 17:11 cdorin Status assigned => closed
2020-01-14 17:11 cdorin Resolution open => no change required