View Issue Details

IDProjectCategoryView StatusLast Update
15611Bug reportsSurvey takingpublic2021-01-19 18:49
Reportertpartner Assigned Togabrieljenik  
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.0.0-RC8 
Summary15611: No HTML wrapper in public stats
DescriptionThere is no theme wrapper or, for that matter, any <html>, <head> or <body> tags applied to the public statistics view.

See attached screenshot.

In my opinion, the survey theme should be applied to this view.

This problem also occurs in version 3.20.2 .
Steps To ReproduceCreate a survey and activate public statistics. With the public stats page loaded, view the page source in a new tab.
TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.0-rc8
I will donate to the project if issue is resolvedNo
BrowserN/A
Database & DB-Versionmysqlnd 5.0.12
Server OS (if known)Windows 10
Webserver software & version (if known)Apache/2.4.39 (Win64)
PHP Version7.3.7

Relationships

related to 15612 closedgabrieljenik Public stats didn't have any theme part, graphic is broken 

Activities

tpartner

tpartner

2019-11-22 14:42

developer  

bug_stats_elements.png (56,898 bytes)   
bug_stats_elements.png (56,898 bytes)   
DenisChenu

DenisChenu

2019-11-22 15:08

developer   ~54763

> This problem also occurs in version 3.20.2 .

I set 3.20.x for issue
DenisChenu

DenisChenu

2019-11-22 15:11

developer   ~54764

Last edited: 2020-12-22 14:51

Confirm in 3.20.2 github
DenisChenu

DenisChenu

2019-11-22 15:12

developer   ~54765

Last edited: 2020-12-22 14:51

Oups : uncofirmed with 3.20.2 github sorry
DenisChenu

DenisChenu

2019-11-22 15:17

developer   ~54766

Last edited: 2020-12-22 14:51

Reconfirm in 3.30.2 … show source show the issue …
tpartner

tpartner

2019-11-22 15:21

developer   ~54767

Last edited: 2020-12-22 14:51

I don't want it to get lost in 4.x.
Mazi

Mazi

2020-09-17 08:07

partner   ~59856

Last edited: 2020-12-22 14:51

@cdorin, this is an issue since the first release of LS 3.00. Can we finally fix this? It is a really embarassing bug since no design details are applied to the public statistics at all, see e,g. the current partner survey at https://survey.limesurvey.org/statistics_user/524176?language=en.

You wouldn't expect such a f..ed up design at a professional tool.
DenisChenu

DenisChenu

2020-09-17 08:34

developer   ~59857

Last edited: 2020-12-22 14:51

Great way to reproduce by @Mazi !
cdorin

cdorin

2020-12-22 14:53

manager   ~61020

@gabrieljenik , could you please check this issue and have a fix applied in LS4 develop ?
tpartner

tpartner

2020-12-22 15:15

developer   ~61023

It should be fixed in 3.x LTS too.
gabrieljenik

gabrieljenik

2020-12-23 17:54

manager   ~61133

Last edited: 2020-12-23 18:31

View 2 revisions

Created new twig views for statistics for using as frame (based on print view)

PR for DEV: https://github.com/LimeSurvey/LimeSurvey/pull/1695

PR for Master: https://github.com/LimeSurvey/LimeSurvey/pull/1696
gabrieljenik

gabrieljenik

2020-12-30 10:55

manager   ~61314

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30829
lime_release_bot

lime_release_bot

2021-01-18 18:11

administrator   ~61591

Fixed in Release 4.3.34+210119
tpartner

tpartner

2021-01-19 13:22

developer   ~61593

Why was this not fixed in 3.x? What happened to the LTS part?
DenisChenu

DenisChenu

2021-01-19 14:48

developer   ~61594

> Why was this not fixed in 3.x? What happened to the LTS part?

:+1:
Mazi

Mazi

2021-01-19 15:38

partner   ~61600

This definitely has to be applied to LS3.x as well. I absolutely second this since the effort should be small.
DenisChenu

DenisChenu

2021-01-19 18:49

developer   ~61601

https://bugs.limesurvey.org/view.php?id=15612#c61552
https://github.com/LimeSurvey/LimeSurvey/pull/1717

:)

Related Changesets

LimeSurvey: master 8045be8b

2020-12-30 10:54:58

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 15611: No HTML wrapper in public stats (#1696)

Created new twig views for statistics for using as frame (based on print view)
Affected Issues
15611
mod - application/controllers/Statistics_userController.php Diff File
mod - themes/survey/bootswatch/config.xml Diff File
mod - themes/survey/vanilla/config.xml Diff File
add - themes/survey/vanilla/views/layout_statistics_user.twig Diff File
add - themes/survey/vanilla/views/subviews/content/statistics_user.twig Diff File
add - themes/survey/vanilla/views/subviews/statistics_user/index.html Diff File
add - themes/survey/vanilla/views/subviews/statistics_user/statistics_user_content.twig Diff File
add - themes/survey/vanilla/views/subviews/statistics_user/statistics_user_foot.twig Diff File
add - themes/survey/vanilla/views/subviews/statistics_user/statistics_user_head.twig Diff File

Issue History

Date Modified Username Field Change
2019-11-22 14:42 tpartner New Issue
2019-11-22 14:42 tpartner File Added: bug_stats_elements.png
2019-11-22 15:08 DenisChenu Note Added: 54763
2019-11-22 15:11 DenisChenu Product Version 4.0.0-RC8 => 3.20.x
2019-11-22 15:11 DenisChenu Target Version 4.0.0-RC9 =>
2019-11-22 15:11 DenisChenu Complete LimeSurvey version number (& build) 4.0.0-RC8 => 3.20.2 github
2019-11-22 15:11 DenisChenu Server OS (if known) Windows 10 => Windows 10 / fedora linux
2019-11-22 15:11 DenisChenu Webserver software & version (if known) Apache/2.4.39 (Win64) => Apache/2.4.39 (Win64) / nginx
2019-11-22 15:11 DenisChenu PHP Version 7.3.7 => 7.3.7 / 7.2
2019-11-22 15:11 DenisChenu Note Added: 54764
2019-11-22 15:12 DenisChenu Note Added: 54765
2019-11-22 15:12 DenisChenu Product Version 3.20.x => 4.0.0-RC8
2019-11-22 15:16 DenisChenu Relationship added related to 15612
2019-11-22 15:16 DenisChenu Complete LimeSurvey version number (& build) 3.20.2 github => 4.0.0-rc8
2019-11-22 15:16 DenisChenu Server OS (if known) Windows 10 / fedora linux => Windows 10
2019-11-22 15:16 DenisChenu Webserver software & version (if known) Apache/2.4.39 (Win64) / nginx => Apache/2.4.39 (Win64)
2019-11-22 15:16 DenisChenu PHP Version 7.3.7 / 7.2 => 7.3.7
2019-11-22 15:17 DenisChenu Note Added: 54766
2019-11-22 15:21 tpartner Note Added: 54767
2019-11-26 15:11 cdorin Assigned To => cdorin
2019-11-26 15:11 cdorin Status new => assigned
2020-09-17 08:07 Mazi Note Added: 59856
2020-09-17 08:34 DenisChenu Note Added: 59857
2020-12-22 14:51 cdorin Assigned To cdorin =>
2020-12-22 14:51 cdorin Status assigned => new
2020-12-22 14:51 cdorin Status new => confirmed
2020-12-22 14:53 cdorin Note Added: 61020
2020-12-22 15:15 tpartner Note Added: 61023
2020-12-23 17:54 gabrieljenik Note Added: 61133
2020-12-23 18:31 gabrieljenik Note Edited: 61133 View Revisions
2020-12-30 10:55 gabrieljenik Changeset attached => LimeSurvey master 8045be8b
2020-12-30 10:55 gabrieljenik Note Added: 61314
2020-12-30 10:55 gabrieljenik Assigned To => gabrieljenik
2020-12-30 10:55 gabrieljenik Resolution open => fixed
2021-01-18 18:11 lime_release_bot Note Added: 61591
2021-01-18 18:11 lime_release_bot Status confirmed => closed
2021-01-19 13:22 tpartner Note Added: 61593
2021-01-19 14:48 DenisChenu Note Added: 61594
2021-01-19 15:38 Mazi Note Added: 61600
2021-01-19 18:49 DenisChenu Note Added: 61601