View Issue Details

IDProjectCategoryView StatusLast Update
15576Bug reportsSurvey editingpublic2020-03-09 15:36
ReporterDenisChenu Assigned Tocdorin  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version4.0.0-RC7 
Fixed in Version4.0.0-RC11 
Summary15576: Invalid url for preview with get url param
Description

The preview show a 404 error with

  1. subdirectory
  2. or get param
Steps To Reproduce

Create an instance in a subdirectory, and get param
Create a question : look at url

Additional Information

Fixed url part : /admin/questioneditorgetRenderedPreview …must use createUrl …

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.0-RC7 git
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)fedora/linux
Webserver software & version (if known)nginx
PHP Version7.3.11

Activities

DenisChenu

DenisChenu

2019-11-15 09:24

developer  

ollehar

ollehar

2019-11-15 13:14

administrator   ~54635

Confirm. This worked some days ago, I believe. >< Needs a regression test after fix, please!

pstelling

pstelling

2019-12-11 10:45

developer   ~55002

i'm sorry. I can't reproduce the bug. Maybe someone could give some more information (installed limesurvey into subdirector and set the urlFormat to "get", created a new question and questionpreview looked normal)

DenisChenu

DenisChenu

2019-12-11 10:57

developer   ~55003

Confirm it seems fixed now

DenisChenu

DenisChenu

2019-12-11 10:58

developer  

Issue History

Date Modified Username Field Change
2019-11-15 09:24 DenisChenu New Issue
2019-11-15 09:24 DenisChenu File Added: Capture d’écran du 2019-11-15 09-18-57.png
2019-11-15 13:14 ollehar Assigned To => ollehar
2019-11-15 13:14 ollehar Status new => confirmed
2019-11-15 13:14 ollehar Note Added: 54635
2019-11-18 18:00 ollehar Assigned To ollehar =>
2019-11-20 17:22 cdorin Assigned To => cdorin
2019-11-20 17:22 cdorin Status confirmed => assigned
2019-12-11 10:45 pstelling Note Added: 55002
2019-12-11 10:46 pstelling Status assigned => feedback
2019-12-11 10:57 DenisChenu Status feedback => resolved
2019-12-11 10:57 DenisChenu Resolution open => fixed
2019-12-11 10:57 DenisChenu Fixed in Version => 4.0.0-RC11
2019-12-11 10:57 DenisChenu Note Added: 55003
2019-12-11 10:58 DenisChenu File Added: Capture d’écran du 2019-12-11 10-58-16.png
2020-03-09 15:36 c_schmitz Status resolved => closed