View Issue Details

IDProjectCategoryView StatusLast Update
15542Bug reports[All Projects] Survey editingpublic2019-11-27 18:38
Reporterwillemvdmaden Assigned Tocdorin  
PrioritynoneSeveritymajor 
Status closedResolutionno change required 
Product Version3.20.x 
Target VersionFixed in Version 
Summary15542: When copying an entire survey, the subquestions aren't copied.
Description

Hey,

So I've created a sort of 'template' with a special theme and special questions/subquestions for a particular use. This means that people who want to create a similar survey have to copy my survey to be sure that everything works. I've been doing this with multiple versions, making a back-up each day and now suddenly the subquestions aren't copied. Even when I copy an older version, which has been demonstrated to be working, the subquestions aren't copied.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.17.0+190402
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-Version180
Server OS (if known)
Webserver software & version (if known)
PHP Versionlatest

Activities

willemvdmaden

willemvdmaden

2019-11-06 16:43

reporter   ~54438

Sorry the php version is 7.3.10

jelo

jelo

2019-11-07 01:45

partner   ~54452

Are the subquestions never copied? Or only when you try to copy your "special" survey?
The version you indicate is "Version 3.17.0+190402".
You will need to check with a newer version of LimeSurvey too.
Perhaps it's caused by change to PHP 7.3.10. If possible check with PHP 7.2.X

willemvdmaden

willemvdmaden

2019-11-15 09:28

reporter   ~54610

Hello Jelo,

I'm sorry for the delay but I've updated everything and the issue persists. It appears that only the "special" questions are not copied. But it's odd because When I did it before there was no problem. Any recommendation to how I can see what's going wrong?

willemvdmaden

willemvdmaden

2019-11-15 09:30

reporter   ~54611

Oh I didn't read properly, I thought the PHP remark was also about updating to a new version. How do I switch back to PHP 7.2.x?

willemvdmaden

willemvdmaden

2019-11-18 13:22

reporter   ~54643

Hello @jelo I changed the version to PHP 7.2 and the issue persists. Any other tips?

DenisChenu

DenisChenu

2019-11-18 14:52

developer   ~54655

Can you upload the lss file please ?
Then we can check on the last version

willemvdmaden

willemvdmaden

2019-11-18 15:02

reporter   ~54659

Here you go @DenisChenu thanks for the response



limesurvey_survey_36973.lss (73,596 bytes)
DenisChenu

DenisChenu

2019-11-19 08:21

developer   ~54665

OK, issue in EA10 question … lss have subquestions
But why it don't import …

I confirm the issue in 3.20 …

DenisChenu

DenisChenu

2019-11-19 08:30

developer   ~54667

@willemvdmaden : can you try to export a TXT/TSV file please ?
And if you can try to redo the EA10 question on a single survey ? Start by create only one subquestion and see if this survey with this single question are OK or not ?

@cdorin : i use super admin account here, see the screenshot of XML. Can you confirm too ?



DenisChenu

DenisChenu

2019-11-19 08:30

developer  

DenisChenu

DenisChenu

2019-11-19 08:33

developer   ~54668

OK :)

Think i got it : <gid><![CDATA[0]]></gid>

@willemvdmaden : can you do a Check data integrity and test again ?

willemvdmaden

willemvdmaden

2019-11-19 09:10

reporter   ~54669

@DenisChenu Awesome! It totally works now. So what was the problem? I can't make up anything of that code aside from CDATA[0]

DenisChenu

DenisChenu

2019-11-19 09:12

developer   ~54670

Last edited: 2019-11-19 09:12

View 2 revisions

The group id (gid) is 0 for subquestions. It can happen on some sutey when copying question from group to another.
In fact : it's not really needed when importing subquestion : subquestion need to know only parent id.

Then still have an issue in import part (import you lss MUST work) but happy Check data integrity fix it :).

Issue History

Date Modified Username Field Change
2019-11-06 16:41 willemvdmaden New Issue
2019-11-06 16:43 willemvdmaden Note Added: 54438
2019-11-07 01:45 jelo Note Added: 54452
2019-11-15 09:28 willemvdmaden Note Added: 54610
2019-11-15 09:30 willemvdmaden Note Added: 54611
2019-11-18 13:22 willemvdmaden Note Added: 54643
2019-11-18 14:52 DenisChenu Note Added: 54655
2019-11-18 15:02 willemvdmaden File Added: limesurvey_survey_36973.lss
2019-11-18 15:02 willemvdmaden Note Added: 54659
2019-11-19 08:21 DenisChenu Note Added: 54665
2019-11-19 08:22 DenisChenu Status new => confirmed
2019-11-19 08:22 DenisChenu Product Version => 3.20.x
2019-11-19 08:30 DenisChenu File Added: Capture d’écran du 2019-11-19 08-27-01.png
2019-11-19 08:30 DenisChenu File Added: Capture d’écran du 2019-11-19 08-27-27.png
2019-11-19 08:30 DenisChenu Note Added: 54667
2019-11-19 08:30 DenisChenu File Added: Capture d’écran du 2019-11-19 08-30-29.png
2019-11-19 08:33 DenisChenu Note Added: 54668
2019-11-19 09:10 willemvdmaden Note Added: 54669
2019-11-19 09:12 DenisChenu Note Added: 54670
2019-11-19 09:12 DenisChenu Note Edited: 54670 View Revisions
2019-11-20 17:25 cdorin Assigned To => cdorin
2019-11-20 17:25 cdorin Status confirmed => assigned
2019-11-27 18:38 cdorin Status assigned => closed
2019-11-27 18:38 cdorin Resolution open => no change required