View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
15502Bug reports_ Unknownpublic2021-03-10 17:46
ReporterWhilelM Assigned Toollehar  
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Summary15502: Data too long for column 'surveyls_welcometext'
DescriptionDuring update from version 3.8.2 to version 3.19.3, got error:

    Erreur non récupérable durant la mise à jour. Détails de cette erreur :

    CDbCommand n'a pas pu exécuter la commande SQL: SQLSTATE[22001]: String data, right truncated: 1406 Data too long for column 'surveyls_welcometext' at row 28

    Fichier updatedb_helper.php, ligne 3962.

Data came from MySQL 5.6 instance. copied database to a new MariaDB 10.3.17 instance
No other problem knowned to this time.
TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)3193_191023
I will donate to the project if issue is resolvedNo
BrowserFirefox 69.0 (64-bit)
Database type & versionMariaDB 10.3.17 358
Server OS (if known)Linux 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2 (2019-08-28) x86_64 GNU/Linux
Webserver software & version (if known)Apache 2.4.38-3
PHP Version7.3

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

WhilelM

WhilelM

2019-10-31 12:45

reporter  

CDbException.zip (4,752 bytes)
DenisChenu

DenisChenu

2019-10-31 14:25

developer   ~54297

Forum post : https://www.limesurvey.org/forum/french-forum/119553-erreur-lors-upgrade-bdd-data-too-long-for-column-surveyls_welcometext
cdorin

cdorin

2021-01-28 19:42

manager   ~61765

Still an issue in latest LTS/master?
ollehar

ollehar

2021-03-10 17:46

administrator   ~63111

Hello WhilelM,

we have asked for feedback on this issue. Because we did not get an answer we assume that the issue is resolved.
However, should you be able to reproduce the issue using the latest version, please feel free to re-open the issue and give us exact details on how to reproduce it.

Thank you and best regards,

ollehar

Issue History

Date Modified Username Field Change
2019-10-31 12:45 WhilelM New Issue
2019-10-31 12:45 WhilelM File Added: CDbException.zip
2019-10-31 14:25 DenisChenu Note Added: 54297
2019-12-03 15:45 cdorin Assigned To => cdorin
2019-12-03 15:45 cdorin Status new => assigned
2020-12-28 18:45 cdorin Assigned To cdorin =>
2020-12-28 18:45 cdorin Status assigned => new
2021-01-28 19:42 cdorin Status new => feedback
2021-01-28 19:42 cdorin Note Added: 61765
2021-03-10 17:46 ollehar Assigned To => ollehar
2021-03-10 17:46 ollehar Status feedback => closed
2021-03-10 17:46 ollehar Resolution open => fixed
2021-03-10 17:46 ollehar Note Added: 63111