View Issue Details

IDProjectCategoryView StatusLast Update
15432Bug reports[All Projects] Menu systempublic2019-11-14 19:30
Reporterf_funke Assigned ToJHoeck  
PrioritynoneSeveritymajor 
Status resolvedResolutionfixed 
Product Version4.0.0-RC5 
Target VersionFixed in Version 
Summary15432: button to access responses not implemented
Description

The button to access survey responses is not implemented in the top menu.

Tagssprint
Complete LimeSurvey version number (& build)4.0.0-RC5
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionn/a
Server OS (if known)
Webserver software & version (if known)
PHP Versionn/a

Relationships

related to 15337 resolvedJHoeck Two top-menus in responses view 
related to 15568 assignedcdorin LS 3 vs. LS 4: different order of menu items 

Activities

f_funke

f_funke

2019-10-21 13:43

developer  

grafik.png (56,179 bytes)
grafik.png (56,179 bytes)
f_funke

f_funke

2019-10-21 13:43

developer   ~54129

Thanks for reporting, @KRav!

JHoeck

JHoeck

2019-10-28 16:14

manager   ~54241

I can not find this issue in RC6.
Inside which tab is it not appearing?

f_funke

f_funke

2019-10-29 12:17

developer   ~54250

Issue is still there in RC6.

To replicate you should ...

  1. create and activate a survey
  2. choose in the left-hand menu structure | overview
    ... to see that there is no button "Responses" in the top menu.

Perhaps the issue is related to the changes in the order of menu item:
"stop | execute | tools |display/export | participants | responses" in 3.19.3
versus
"stop | execute | tools |participants | display/export" in 4.0.0-RC6

I'd suggest to restore the old oder of menu items if this has no side effect.



grafik-2.png (103,634 bytes)
JHoeck

JHoeck

2019-10-30 11:48

manager   ~54273

Fixed in branch issue-15432-responses-button-missing.

ollehar

ollehar

2019-11-01 14:50

administrator   ~54327

Test work, please merge.

JHoeck

JHoeck

2019-11-01 15:06

manager   ~54331

Merged into latest develop.

ollehar

ollehar

2019-11-01 15:06

administrator   ~54332

Hooray!

Issue History

Date Modified Username Field Change
2019-10-21 13:43 f_funke New Issue
2019-10-21 13:43 f_funke File Added: grafik.png
2019-10-21 13:43 f_funke Note Added: 54129
2019-10-28 16:00 JHoeck Assigned To => JHoeck
2019-10-28 16:00 JHoeck Status new => assigned
2019-10-28 16:00 JHoeck Tag Attached: sprin
2019-10-28 16:00 JHoeck Tag Detached: sprin
2019-10-28 16:00 JHoeck Tag Attached: sprint
2019-10-28 16:14 JHoeck Note Added: 54241
2019-10-29 12:17 f_funke File Added: grafik-2.png
2019-10-29 12:17 f_funke Note Added: 54250
2019-10-29 12:24 f_funke Relationship added related to 15337
2019-10-29 13:54 JHoeck Status assigned => feedback
2019-10-29 14:01 JHoeck Status feedback => assigned
2019-10-30 11:48 JHoeck Status assigned => resolved
2019-10-30 11:48 JHoeck Resolution open => fixed
2019-10-30 11:48 JHoeck Note Added: 54273
2019-11-01 14:50 ollehar Note Added: 54327
2019-11-01 15:06 JHoeck Note Added: 54331
2019-11-01 15:06 ollehar Note Added: 54332
2019-11-14 19:30 f_funke Relationship added related to 15568