View Issue Details

IDProjectCategoryView StatusLast Update
15423Bug reportsConditionspublic2019-10-19 10:06
Reporterterryaulenbach Assigned ToDenisChenu  
PrioritynoneSeveritypartial_block 
Status closedResolutionduplicate 
Product Version3.19.1 
Fixed in Version3.19.1 
Summary15423: question conditions are ignored when previewing a group
Description

When previewing a question group with conditional questions, the conditions are ignored. You have to preview the entire survey in order for them to work. This can be quite time consuming when you have a long survey and many required answers. For e.g., a question that should not show unless a particular answer in a previous question has been selected simply show anyway when you preview the group.

Steps To Reproduce
  1. create survey
  2. add group
  3. add question
  4. add another question
  5. make the visibility of the second question dependant on a particular answer in the first question
  6. preview the group
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.17.3+190429
I will donate to the project if issue is resolvedNo
BrowserFirefox 69.03, Chrome 77.0.3865.120
Database & DB-VersionPostgreSQL 9.6.5 (win32)
Server OS (if known)Windows Server 2012 R2 Standard Edition
Webserver software & version (if known)Apache 2.4.33 (Win64)
PHP Version7.2.7 (x64)

Relationships

duplicate of 14988 closedDenisChenu Preview question group not working + relevance equations 

Activities

DenisChenu

DenisChenu

2019-10-19 10:06

developer   ~54104

Already fixed in 3.17.9

Issue History

Date Modified Username Field Change
2019-10-18 19:18 terryaulenbach New Issue
2019-10-19 10:04 DenisChenu Relationship added duplicate of 14988
2019-10-19 10:06 DenisChenu Assigned To => DenisChenu
2019-10-19 10:06 DenisChenu Status new => closed
2019-10-19 10:06 DenisChenu Resolution open => duplicate
2019-10-19 10:06 DenisChenu Fixed in Version => 3.19.1
2019-10-19 10:06 DenisChenu Note Added: 54104