View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
15323Bug reportsInstallationpublic2021-03-19 07:31
Reporterollehar Assigned Toc_schmitz  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version4.0.0-RC3 
Target Version4.0.0-RC4Fixed in Version4.4.13 
Summary15323: Can't install from command-line if debug = 2
DescriptionCan you check this, Denis? Does this bug matter for you? The issue is with a truncated index over a too large VARCHAR(200) (can only take VARCHAR(191) in index).
Steps To Reproduce1. Have config.php
2. Set debug=2
3. Delete database limesurvey
4. Run `$ DBENGINE=MYISAM php application/commands/console.php install admin password TravisLS no@email.com verbose`
TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)latest
I will donate to the project if issue is resolvedNo
Browser-
Database type & version-
Server OS (if known)-
Webserver software & version (if known)-
PHP Version-

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

DenisChenu

DenisChenu

2019-09-24 18:09

developer   ~53702

> Does this bug matter for you?

Not really :) but i can have a look.

No issue with 3.X (and debug>1) ?
DenisChenu

DenisChenu

2020-03-12 08:42

developer   ~56416

I think we need a default DBEngine for commend install

I dislike to have :
````
[shnoulle@poledra master]$ php application/commands/console.php install
You have to set admin/password/full name and email address on the command line like this: php console.php install adminname mypassword fullname emailaddress [verbose]
[shnoulle@poledra master]$ php application/commands/console.php install DenisChenu password DenisChenu denis@sondages.pro
CException: Environment variable DBENGINE is empty, should be either MyISAM or InnoDB in /mnt/data/shnoulle/nginx/www/master/application/commands/InstallCommand.php:122

`````

Then :

1. Allow DBENGINE in params
2. Set a default

PS : we need a set a default for each ... and maybe a console.php install -u=DenisChenu -p=Password .....
DenisChenu

DenisChenu

2020-03-12 08:45

developer   ~56417

Else : no error, no issue when

```
$ DBENGINE=MYISAM php application/commands/console.php install DenisChenu password DenisChenu denis@sondages.pro
[shnoulle@poledra master]$ grep debug application/config/config.php
    // debug: Set this to 1 if you are looking for errors. If you still get no errors after enabling this
        'debug'=>2,
        'debugsql'=>0, // Set this to 1 to enanble sql logging, only active when debug = 2
```
DenisChenu

DenisChenu

2020-03-12 08:46

developer   ~56418

PS : maybe add a return 0 and a echo "Setup was done with success" ?
ollehar

ollehar

2020-03-12 10:24

administrator   ~56423

There's an index that won't work because the varchar is too long.
ollehar

ollehar

2020-03-12 10:24

administrator   ~56424

Wait, I already said that. Hm.
ollehar

ollehar

2020-03-12 10:25

administrator   ~56425

I won't look at this now, since there are lots of other high-priority issues.
DenisChenu

DenisChenu

2020-03-12 14:13

developer   ~56429

> There's an index that won't work because the varchar is too long.

I can't reproduce :)
ollehar

ollehar

2020-03-12 14:14

administrator   ~56430

You must set debug = 2 to get the error.
DenisChenu

DenisChenu

2020-03-12 14:21

developer   ~56431

see `$ grep debug application/config/config.php `
DenisChenu

DenisChenu

2020-03-12 14:21

developer   ~56432

PHP version maybe ?
c_schmitz

c_schmitz

2021-03-19 07:31

administrator   ~63447

I just tested this and it all works, now.

Issue History

Date Modified Username Field Change
2019-09-24 17:12 ollehar New Issue
2019-09-24 17:12 ollehar Status new => assigned
2019-09-24 17:12 ollehar Assigned To => DenisChenu
2019-09-24 17:13 ollehar Status assigned => feedback
2019-09-24 18:09 DenisChenu Note Added: 53702
2020-03-12 08:40 DenisChenu Assigned To DenisChenu => ollehar
2020-03-12 08:42 DenisChenu Note Added: 56416
2020-03-12 08:45 DenisChenu Note Added: 56417
2020-03-12 08:46 DenisChenu Note Added: 56418
2020-03-12 08:46 DenisChenu Fixed in Version => 4.1.10
2020-03-12 10:24 ollehar Note Added: 56423
2020-03-12 10:24 ollehar Note Added: 56424
2020-03-12 10:24 ollehar Priority none => normal
2020-03-12 10:25 ollehar Note Added: 56425
2020-03-12 14:13 DenisChenu Note Added: 56429
2020-03-12 14:14 ollehar Note Added: 56430
2020-03-12 14:21 DenisChenu Note Added: 56431
2020-03-12 14:21 DenisChenu Note Added: 56432
2021-03-19 07:31 c_schmitz Assigned To ollehar => c_schmitz
2021-03-19 07:31 c_schmitz Status feedback => closed
2021-03-19 07:31 c_schmitz Resolution open => fixed
2021-03-19 07:31 c_schmitz Fixed in Version 4.1.10 => 4.4.13
2021-03-19 07:31 c_schmitz Note Added: 63447