View Issue Details

IDProjectCategoryView StatusLast Update
15313Bug reportsStatisticspublic2020-03-09 15:36
Reporterfradeff Assigned Tocdorin  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.17.x 
Fixed in Version3.20.x 
Summary15313: no pdf export of result statistics - infinite loop waiting
Description

Hello
When I try to "export this question to PDF" on /index.php/admin/statistics/sa/index/surveyid/SID, the dynamic image turns but nothing is returned

Steps To Reproduce
  • Results > Statistics > View Statistics > Display All
  • on an answer, click on "export this question to PDF"
TagsNo tags attached.
Complete LimeSurvey version number (& build) 3.17.17+190918
I will donate to the project if issue is resolvedNo
BrowserFirefox 69.0 (64-bit) & Chromium Version 76.0.3809
Database & DB-Versionmysqlnd 5.0.12-dev - 20150407
Server OS (if known)Debian GNU/Linux 9.9 (stretch)
Webserver software & version (if known)Apache 2.0 Handler 20120211
PHP Version7.0.33-0+deb9u3

Activities

fradeff

fradeff

2019-09-23 08:08

reporter  

fradeff

fradeff

2019-09-24 12:40

reporter   ~53699

still bugging with new version 3.18.0
in the console log, I have this message, if it may help:

createpdf_worker.js:22 Uncaught (in promise) TypeError: Cannot read property 'w' of undefined
at compileCanvas (createpdf_worker.js:22)
at createpdf_worker.js:56

Mazi

Mazi

2019-10-21 08:50

partner   ~54121

@cdorin, I can reproduce this with the latest version and Chrome. The feature seems to be broken. Please assign so this can be fixed soon.

fradeff

fradeff

2019-11-06 14:45

reporter   ~54429

just saw the fix on https://github.com/LimeSurvey/LimeSurvey/commit/0b7ba655618bbea80dcc72294fb6dc8fcadf47e5
tested on a dev instance, seems to work perfectly
thank you so much!

Mazi

Mazi

2019-11-11 16:00

partner   ~54522

Confirmed!

@cdorin, please close this one.

Issue History

Date Modified Username Field Change
2019-09-23 08:08 fradeff New Issue
2019-09-23 08:08 fradeff File Added: Capture+d’e_cran+2019-09-20+a_+11.10.18.jpg
2019-09-23 08:08 fradeff File Added: Capture+d’e_cran+2019-09-20+a_+11.05.31.jpg
2019-09-24 12:40 fradeff Note Added: 53699
2019-10-21 08:50 Mazi Note Added: 54121
2019-11-06 14:45 fradeff Note Added: 54429
2019-11-11 16:00 Mazi Note Added: 54522
2019-11-11 16:04 cdorin Assigned To => cdorin
2019-11-11 16:04 cdorin Status new => resolved
2019-11-11 16:04 cdorin Resolution open => fixed
2019-11-11 16:04 cdorin Fixed in Version => 3.20.x
2020-03-09 15:36 c_schmitz Status resolved => closed