View Issue Details

IDProjectCategoryView StatusLast Update
15268Bug reports[All Projects] Survey takingpublic2019-10-23 15:28
Reporterollehar Assigned ToLouisGac  
PrioritynoneSeverityblock 
Status resolvedResolutionunable to reproduce 
Product Version4.0.0-RC3 
Target Version4.0.0-RC4Fixed in Version 
Summary15268: Randomization group not working in LS4
Description

Title.

Steps To Reproduce
  1. Create survey with at least two questions
  2. Add randomization group to group
  3. Execute/preview couple of times
  4. Always the same question order
Additional Information

Removed when Markus refactored qanda?

TagsNo tags attached.
Complete LimeSurvey version number (& build)latest
I will donate to the project if issue is resolvedNo
Browser-
Database & DB-Version-
Server OS (if known)-
Webserver software & version (if known)-
PHP Version-

Activities

cdorin

cdorin

2019-09-11 17:35

manager   ~53558

thx for checking and testing!

LouisGac

LouisGac

2019-10-23 14:22

manager   ~54189

// Add a finalgroup in qa array , needed for random attribute : TODO: find a way to have it in new quanda_helper in 2.1
https://github.com/LimeSurvey/LimeSurvey/blob/d05d166139b5ef58527d0b4f9be05f6ac1145e88/application/helpers/SurveyRuntimeHelper.php#L188

LouisGac

LouisGac

2019-10-23 15:01

manager   ~54190

Ok so the bug does not exists. RAndomization works perfectly fine.
Only problem: randomization is not imported with LSS File.

ollehar

ollehar

2019-10-23 15:03

administrator   ~54191

Really? I'll test again.

ollehar

ollehar

2019-10-23 15:20

administrator   ~54194

  1. Random group order - works
  2. Random question order - works
  3. Random answer order - does not work (e.g. radio list)
  4. Random subquestion order -works
ollehar

ollehar

2019-10-23 15:21

administrator   ~54195

Want me to write a new issue?

LouisGac

LouisGac

2019-10-23 15:28

manager   ~54196

yep

Issue History

Date Modified Username Field Change
2019-09-11 14:53 ollehar New Issue
2019-09-11 17:35 cdorin Note Added: 53558
2019-10-23 14:22 LouisGac Note Added: 54189
2019-10-23 15:01 LouisGac Note Added: 54190
2019-10-23 15:03 ollehar Note Added: 54191
2019-10-23 15:04 LouisGac Assigned To => LouisGac
2019-10-23 15:04 LouisGac Status new => resolved
2019-10-23 15:04 LouisGac Resolution open => unable to reproduce
2019-10-23 15:20 ollehar Note Added: 54194
2019-10-23 15:21 ollehar Note Added: 54195
2019-10-23 15:28 LouisGac Note Added: 54196