View Issue Details

IDProjectCategoryView StatusLast Update
15208Bug reports[All Projects] Theme editorpublic2019-09-02 10:42
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.17.x 
Target VersionFixed in Version3.17.x 
Summary15208: [MSSQL] SQL error on 2nd page of theme
Description

When going on second page of theme editor : have a 500 error

Steps To Reproduce
  1. Have an SQL server
  2. Add more template than 5
  3. Move to next page
Additional Information

SQL only

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.17.13
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionsqlsrv SQLserver 12
Server OS (if known)windowserver 2016
Webserver software & version (if known)IIS 8 and Apache
PHP Versionphp7.2

Activities

DenisChenu

DenisChenu

2019-08-29 18:11

developer  

Capture d’écran du 2019-08-29 17-36-40.png (102,482 bytes)
DenisChenu

DenisChenu

2019-08-29 18:12

developer  

500: Internal Server Error.html (88,531 bytes)
DenisChenu

DenisChenu

2019-08-29 18:13

developer   ~53345

Sorry : can activate debug mode except on internal server … but since need to be on a … windows 7 … it's to awfull … aaaarrg (and this one don't have any disk space).

DenisChenu

DenisChenu

2019-08-29 18:23

developer   ~53346

https://github.com/LimeSurvey/LimeSurvey/commit/808d4bc7e3d910caa060ea054aa03e35550bcdef

lime_release_bot

lime_release_bot

2019-09-02 10:42

developer   ~53375

Fixed in Release 3.17.14+190902

Related Changesets

LimeSurvey: master 808d4bc7

2019-08-29 18:20:39

Denis Chenu

Details Diff
Fixed issue 15208: MSSQL error on 2nd page of theme
Dev: quoteColumnName("t.template_name")
Dev: t.qid and other don't seems to need it
Dev: always better to use more Yii criteria …
Affected Issues
15208
mod - application/models/TemplateConfiguration.php Diff File

Issue History

Date Modified Username Field Change
2019-08-29 18:11 DenisChenu New Issue
2019-08-29 18:11 DenisChenu Status new => assigned
2019-08-29 18:11 DenisChenu Assigned To => DenisChenu
2019-08-29 18:11 DenisChenu File Added: Capture d’écran du 2019-08-29 17-36-40.png
2019-08-29 18:11 DenisChenu File Added: CDbException.html
2019-08-29 18:12 DenisChenu File Deleted: CDbException.html
2019-08-29 18:12 DenisChenu File Added: 500: Internal Server Error.html
2019-08-29 18:13 DenisChenu Note Added: 53345
2019-08-29 18:18 DenisChenu Summary [MSSQL] SQL erro on 2nd page of theme => [MSSQL] SQL error on 2nd page of theme
2019-08-29 18:23 DenisChenu Status assigned => resolved
2019-08-29 18:23 DenisChenu Resolution open => fixed
2019-08-29 18:23 DenisChenu Fixed in Version => 3.17.x
2019-08-29 18:23 DenisChenu Note Added: 53346
2019-08-30 14:12 c_schmitz Changeset attached => LimeSurvey master 808d4bc7
2019-09-02 10:42 lime_release_bot Note Added: 53375
2019-09-02 10:42 lime_release_bot Status resolved => closed