View Issue Details

IDProjectCategoryView StatusLast Update
15198Bug reports[All Projects] Ergonomypublic2019-09-03 13:12
Reportereddylackmann Assigned Tomarkusfluer  
PriorityhighSeveritymajor 
Status resolvedResolutionfixed 
Product Version3.17.x 
Target VersionFixed in Version3.17.x 
Summary15198: Beginner tour box has no close button anymore
Description

I can't close the Beginner Tour Box on the dashboard

Steps To Reproduce

Go to menu "Tutorials" and click on "Beginner Tour"

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.17.13+190824
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-Versionmysql
Server OS (if known)
Webserver software & version (if known)
PHP Version7.2

Activities

eddylackmann

eddylackmann

2019-08-27 17:07

developer  

Beginner Tour.PNG (53,864 bytes)
Beginner Tour.PNG (53,864 bytes)
LouisGac

LouisGac

2019-08-27 17:22

manager   ~53309

https://github.com/twbs/bootstrap-sass/issues/1193
https://blog.getbootstrap.com/2019/02/13/bootstrap-4-3-1-and-3-4-1/

LouisGac

LouisGac

2019-08-27 17:22

manager   ~53310

It looks like the sanitize option was added in 3.4.1 (commit 69157ce) and defaults to true. This breaks most existing HTML popovers. Setting it to false gets the old behavior (obviously it's up to dev to ensure the HTML they use is safe).

LouisGac

LouisGac

2019-08-27 17:24

manager   ~53311

also need an update to latest version:
https://github.com/sorich87/bootstrap-tour/releases

markusfluer

markusfluer

2019-08-29 15:40

administrator   ~53339

Last edited: 2019-08-29 15:40

View 2 revisions

Fixed through commit 1a3beca793647a6522fa7107daccee57f4e582a7
https://github.com/LimeSurvey/LimeSurvey/commit/1a3beca793647a6522fa7107daccee57f4e582a7

eddylackmann

eddylackmann

2019-08-29 15:47

developer   ~53340

Actually if i click on tutorial again it shows up for 1s and disappear...

Issue History

Date Modified Username Field Change
2019-08-27 17:07 eddylackmann New Issue
2019-08-27 17:07 eddylackmann Status new => assigned
2019-08-27 17:07 eddylackmann Assigned To => markusfluer
2019-08-27 17:07 eddylackmann File Added: Beginner Tour.PNG
2019-08-27 17:07 eddylackmann Priority none => normal
2019-08-27 17:16 eddylackmann Status assigned => closed
2019-08-27 17:16 eddylackmann Resolution open => fixed
2019-08-27 17:21 eddylackmann Priority normal => high
2019-08-27 17:21 eddylackmann Severity minor => major
2019-08-27 17:21 eddylackmann Status closed => confirmed
2019-08-27 17:21 eddylackmann Description Updated View Revisions
2019-08-27 17:22 LouisGac Note Added: 53309
2019-08-27 17:22 LouisGac Note Added: 53310
2019-08-27 17:24 LouisGac Note Added: 53311
2019-08-29 15:40 markusfluer Note Added: 53339
2019-08-29 15:40 markusfluer Note Edited: 53339 View Revisions
2019-08-29 15:47 eddylackmann Note Added: 53340
2019-09-03 13:12 markusfluer Status confirmed => resolved
2019-09-03 13:12 markusfluer Fixed in Version => 3.17.x