View Issue Details

IDProjectCategoryView StatusLast Update
15126Bug reports[All Projects] _ Unknownpublic2019-10-02 18:13
Reporterf_funke Assigned Todominikvitt 
PriorityhighSeverityminor 
Status resolvedResolutionunable to reproduce 
Product Version4.0.0-RC2 
Target VersionFixed in Version4.0.0-RC4 
Summary15126: error when updating survey settings
Description

When saving survey settings in the menu on the left hand side, sometimes (perhaps one out of 15 times) saving leads to
./index.php?r=admin/database/index/updatesurveylocalesettings
(see screenshot). The changes have been saved, but browser navigation to go backwards is needed to return to the settings page.

Tagssprint
Complete LimeSurvey version number (& build)4.0.0-RC2 (devdemo.limesurvey.org)
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionn/a
Server OS (if known)
Webserver software & version (if known)
PHP Versionn/a

Activities

f_funke

f_funke

2019-08-05 09:18

developer  

LS4-RC2_error_on_updating_settings_190805.png (597,763 bytes)
DenisChenu

DenisChenu

2019-08-05 11:41

developer   ~53091

I have a ampty page yesterday, on same link :)

markusfluer

markusfluer

2019-08-05 16:07

administrator   ~53107

I could not reproduce this, so I suppose it is because of too slowly loading scripts that are not properly executed.

DenisChenu

DenisChenu

2019-08-05 17:20

developer   ~53116

I'm on local when i have the issue …
debug=2

f_funke

f_funke

2019-08-06 15:39

developer   ~53135

Slowly loading might be an explanation - even though everything else runs very fast. So do you see a solution?

dominikvitt

dominikvitt

2019-10-02 18:13

developer   ~53861

It works as expected.
Saving of database settings takes less then 400ms on local machine and PHP timeout setting is 30 minutes by default, so it should work without any problems.
Can't tell of any reasonable explanation for this behaviour, except LS code had been unstable at the time you tested.

Issue History

Date Modified Username Field Change
2019-08-05 09:18 f_funke New Issue
2019-08-05 09:18 f_funke File Added: LS4-RC2_error_on_updating_settings_190805.png
2019-08-05 11:38 cdorin Assigned To => markusfluer
2019-08-05 11:38 cdorin Status new => assigned
2019-08-05 11:41 DenisChenu Note Added: 53091
2019-08-05 16:07 markusfluer Note Added: 53107
2019-08-05 16:07 markusfluer Status assigned => feedback
2019-08-05 17:20 DenisChenu Note Added: 53116
2019-08-06 15:39 f_funke Note Added: 53135
2019-08-06 15:39 f_funke Status feedback => assigned
2019-09-09 10:41 c_schmitz Assigned To markusfluer =>
2019-09-09 10:41 c_schmitz Priority none => high
2019-09-09 10:41 c_schmitz Status assigned => new
2019-09-09 10:42 c_schmitz Tag Attached: sprint
2019-10-02 18:13 dominikvitt Assigned To => dominikvitt
2019-10-02 18:13 dominikvitt Status new => resolved
2019-10-02 18:13 dominikvitt Resolution open => unable to reproduce
2019-10-02 18:13 dominikvitt Fixed in Version => 4.0.0-RC4
2019-10-02 18:13 dominikvitt Note Added: 53861