View Issue Details

IDProjectCategoryView StatusLast Update
15073Bug reportsImport/Exportpublic2020-03-09 16:32
Reporterandre_ars Assigned Toc_schmitz  
PrioritynoneSeveritycrash 
Status closedResolutionfixed 
Product Version4.0.0-RC1 
Fixed in Version4.1.9 
Summary15073: Cannot export spss Data or Excel
Description

After upgrade from 3.17.7, the SPSS export data function return a "file no found" error.
The sintaxe works ok.

Steps To Reproduce

Responses and statistics -> Export spss -> export data

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.0-RC1+190722
I will donate to the project if issue is resolvedNo
BrowserFirefox
Database & DB-VersionMariaDB 10.2
Server OS (if known)Centos
Webserver software & version (if known)apache
PHP Version7.2

Relationships

has duplicate 15833 closedc_schmitz Cannot export .dat-file needed for SPSS after updating to version 4 

Activities

andre_ars

andre_ars

2019-07-24 13:17

reporter   ~52982

sorry, excel is working.

cdorin

cdorin

2019-08-20 16:36

manager   ~53201

Update:
Yes, the bug still exists in LS 4 RC3. I will assign it now.

andre_ars

andre_ars

2019-12-09 15:48

reporter   ~54977

RC11 still doesnt permit me to export SPSS data

cdorin

cdorin

2019-12-09 15:51

manager   ~54978

@andre_ars , could you please send us a screenshot with the error? Could you please provide more details? Have you tried to reproduce the error on https://devdemo.limesurvey.org?

c_schmitz

c_schmitz

2020-03-02 16:51

administrator   ~56281

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=29629

lime_release_bot

lime_release_bot

2020-03-09 16:32

administrator   ~56384

Fixed in Release 4.1.9+200310

Related Changesets

LimeSurvey: master d1ebce2b

2020-03-02 16:51:26

c_schmitz

Details Diff
Fixed issue 15073: Cannot export data to SPSS if no participant table exists Affected Issues
15073
mod - application/helpers/export_helper.php Diff File

Issue History

Date Modified Username Field Change
2019-07-24 13:16 andre_ars New Issue
2019-07-24 13:17 andre_ars Note Added: 52982
2019-08-20 16:36 cdorin Note Added: 53201
2019-08-20 16:36 cdorin Assigned To => markusfluer
2019-08-20 16:36 cdorin Status new => assigned
2019-12-09 15:48 andre_ars Note Added: 54977
2019-12-09 15:49 cdorin Assigned To markusfluer => cdorin
2019-12-09 15:51 cdorin Note Added: 54978
2020-03-02 16:39 c_schmitz Status assigned => closed
2020-03-02 16:39 c_schmitz Resolution open => unable to reproduce
2020-03-02 16:39 c_schmitz Fixed in Version => 4.1.0
2020-03-02 16:49 c_schmitz Status closed => feedback
2020-03-02 16:49 c_schmitz Resolution unable to reproduce => reopened
2020-03-02 16:49 c_schmitz Relationship added has duplicate 15833
2020-03-02 16:51 c_schmitz Changeset attached => LimeSurvey master d1ebce2b
2020-03-02 16:51 c_schmitz Note Added: 56281
2020-03-02 16:51 c_schmitz Assigned To cdorin => c_schmitz
2020-03-02 16:51 c_schmitz Resolution reopened => fixed
2020-03-02 16:54 c_schmitz Status feedback => resolved
2020-03-02 16:54 c_schmitz Fixed in Version 4.1.0 => 4.1.9
2020-03-09 16:32 lime_release_bot Note Added: 56384
2020-03-09 16:32 lime_release_bot Status resolved => closed