View Issue Details

IDProjectCategoryView StatusLast Update
15060Bug reports[All Projects] Survey editingpublic2019-08-26 17:50
Reporterelissa Assigned ToDenisChenu  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.17.x 
Target VersionFixed in Version3.17.x 
Summary15060: Other option with number only erases decimal comma - with NO warning
Description

Question type - radio. Other option with the setting: Numbers only for 'Other'. When entering numbers with a dot as the decimal separator everything is OK. The decimal number is stored in the database. But when you enter comma as a decimal separator (which is common in my country) the comma is deleted. It could be a desired behaviour provided that there is any warning. The problem is that the comma is accepted WITHOUT any warning during completing the survey but finally data are stored without decimal separators. And a respondent enters "12,5", goes smoothly to the next screen and I have "125" in the database. If comma is not allowed then one should not be able to enter it in the field.

Steps To Reproduce

Create a radio question.
Set Option Other to On.
Set Numbers only for 'Other' to On.
Activate the survey.
Enter number with comma as decimal separator.

TagsNo tags attached.
Complete LimeSurvey version number (& build) 3.17.7 - 190627
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version mysqlnd 5.0.12-dev
Server OS (if known)Linux
Webserver software & version (if known)Apache/2.2.22 (Debian)
PHP Version 7.1.10

Relationships

related to 13881 assignedDenisChenu EM : Not number question replace . by , (javascript) 

Activities

ollehar

ollehar

2019-07-23 14:48

administrator   ~52961

Bug in EM?

DenisChenu

DenisChenu

2019-07-23 14:55

developer   ~52962

Unsure : but $_POST value in ExpressionManager only care of numerical and multi numerical if i remind.

DenisChenu

DenisChenu

2019-07-23 14:56

developer   ~52963

@elissa : can you send a sample lss file with radix as , please ?

elissa

elissa

2019-07-23 19:02

reporter   ~52967

The sample lss file.



LS_RadioOtherTest.lss (16,679 bytes)
ollehar

ollehar

2019-07-23 19:09

administrator   ~52968

Good case for a unit test.

DenisChenu

DenisChenu

2019-07-24 08:32

developer   ~52971

@elissa : for information : the fix must disable entering 1,1 : only allow 1.1

In 2.6lts,

  1. no JS : enter 1.1 : OK, enter 1,1 move next : show «An error in the value» and come back to same page
  2. JS : enter 1.1 : OK, enter 1,1 : become 11
elissa

elissa

2019-07-24 08:59

reporter   ~52972

It's OK to disable entering 1,1. The problem was to have the mess with data with no possibility of dermining what is what.

elissa

elissa

2019-07-24 09:09

reporter   ~52973

Spelling: should be "determining what is what".

DenisChenu

DenisChenu

2019-07-24 10:04

developer   ~52974

I must fix PHP part for starting. Didn't understand why it don't work like 2.6lts …

DenisChenu

DenisChenu

2019-07-24 17:23

developer   ~52989

Fixed in : https://github.com/LimeSurvey/LimeSurvey/commit/5ba81219eeb49f11f48c6f93c2381543c122be9a

  1. Fix automatically numeric value to NO With radix as . : enter 1,1 receive «One or more questions have not been answered in a valid manner. You cannot proceed until these answers are valid.» because LEMVal didn't use current radix … and Fix automatically numeric value … (another issue to report)
  2. Fix automatically numeric value to NO With radix as . : enter 1,1 become 1.1 automatically
lime_release_bot

lime_release_bot

2019-08-26 17:50

administrator   ~53272

Fixed in Release 4.0.0-RC3+190807

Issue History

Date Modified Username Field Change
2019-07-19 16:51 elissa New Issue
2019-07-23 14:48 ollehar Assigned To => DenisChenu
2019-07-23 14:48 ollehar Status new => assigned
2019-07-23 14:48 ollehar Note Added: 52961
2019-07-23 14:55 DenisChenu Note Added: 52962
2019-07-23 14:56 DenisChenu Note Added: 52963
2019-07-23 19:02 elissa File Added: LS_RadioOtherTest.lss
2019-07-23 19:02 elissa Note Added: 52967
2019-07-23 19:09 ollehar Note Added: 52968
2019-07-24 00:37 DenisChenu Relationship added related to 13881
2019-07-24 08:32 DenisChenu Note Added: 52971
2019-07-24 08:59 elissa Note Added: 52972
2019-07-24 09:09 elissa Note Added: 52973
2019-07-24 10:04 DenisChenu Note Added: 52974
2019-07-24 17:23 DenisChenu Note Added: 52989
2019-07-24 17:23 DenisChenu Status assigned => resolved
2019-07-24 17:23 DenisChenu Resolution open => fixed
2019-07-24 17:23 DenisChenu Fixed in Version => 3.17.x
2019-08-26 17:50 lime_release_bot Note Added: 53272
2019-08-26 17:50 lime_release_bot Status resolved => closed
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing