View Issue Details

IDProjectCategoryView StatusLast Update
15053Bug reports[All Projects] Import/Exportpublic2019-10-17 18:04
Reporterrealitix Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary15053: Import with SID non numeric crash
Description

Hello,

When you manually update the .lss file and set a SID with a non numeric value, the import crash.
It should detect it and recreate a new SID.

I join a .lss file you can use.
The bug is on master.

I send a pull request soon.

TagsNo tags attached.
Complete LimeSurvey version number (& build)master
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version0
Server OS (if known)
Webserver software & version (if known)
PHP Version0

Activities

realitix

realitix

2019-07-17 11:17

reporter  

limesurvey_survey_976668.lss (13,266 bytes)
realitix

realitix

2019-07-17 11:20

reporter   ~52905

Pull request: https://github.com/LimeSurvey/LimeSurvey/pull/1306

DenisChenu

DenisChenu

2019-07-17 11:34

developer   ~52907

I can't reproduce : model rules disable it

DenisChenu

DenisChenu

2019-07-17 11:34

developer  

DenisChenu

DenisChenu

2019-07-17 11:37

developer   ~52908

Checked too with a survey with group and question : replacing sid bad BADSET : no issue



limesurvey_survey_badsid2.lss (15,109 bytes)
DenisChenu

DenisChenu

2019-07-17 11:38

developer   ~52909

Please : update to 3.17.7 and check again.

realitix

realitix

2019-07-17 14:15

reporter   ~52912

Strange, I tried on master.
Can you try on master ?

DenisChenu

DenisChenu

2019-07-17 14:57

developer   ~52913

Yes, on master (i'm always on master in localhost …)

LouisGac

LouisGac

2019-07-29 11:50

manager   ~53033

could you please share your server config?

DenisChenu

DenisChenu

2019-10-17 18:04

developer   ~54090

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=29203

Related Changesets

LimeSurvey: master f17d4af3

2019-10-17 18:04:15

realitix


Committer: DenisChenu Details Diff
Fixed issue 15053: Error with non-numeric SID on pgsql

Dev : with PgSQL because when Limesurvey check the uniquerule, it executes a db request (only crash with pgsql).
Dev : If we put the "numeric" rule before the "unique" one, Limesurvey will block
a malformated sid.
Affected Issues
15053
mod - application/models/Survey.php Diff File

Issue History

Date Modified Username Field Change
2019-07-17 11:17 realitix New Issue
2019-07-17 11:17 realitix File Added: limesurvey_survey_976668.lss
2019-07-17 11:20 realitix Note Added: 52905
2019-07-17 11:34 DenisChenu Note Added: 52907
2019-07-17 11:34 DenisChenu File Added: Capture d’écran du 2019-07-17 11-34-24.png
2019-07-17 11:37 DenisChenu File Added: limesurvey_survey_badsid2.lss
2019-07-17 11:37 DenisChenu Note Added: 52908
2019-07-17 11:38 DenisChenu Assigned To => DenisChenu
2019-07-17 11:38 DenisChenu Status new => feedback
2019-07-17 11:38 DenisChenu Note Added: 52909
2019-07-17 14:15 realitix Note Added: 52912
2019-07-17 14:15 realitix Status feedback => assigned
2019-07-17 14:57 DenisChenu Note Added: 52913
2019-07-29 11:50 LouisGac Note Added: 53033
2019-08-08 12:24 DenisChenu Status assigned => closed
2019-08-08 12:24 DenisChenu Resolution open => unable to reproduce
2019-10-17 18:04 DenisChenu Changeset attached => LimeSurvey master f17d4af3
2019-10-17 18:04 DenisChenu Note Added: 54090
2019-10-17 18:04 DenisChenu Resolution unable to reproduce => fixed