View Issue Details

IDProjectCategoryView StatusLast Update
15044Bug reports[All Projects] Import/Exportpublic2019-08-05 02:24
ReporterDenisChenuAssigned ToDenisChenu 
PrioritynoneSeveritymajor 
Status resolvedResolutionfixed 
Product Version4.0.0-RC2 
Target VersionFixed in Version4.0.0-RC3 
Summary15044: Can't import a exported lss or copy an existing survey
Description
  1. Trying to import a lss created with 4.0 break with Duplicate entry '22-en' for key 'lime_idx1_group_ls'
  2. Create a survey with one sample question, add a group + another question : copy it
Steps To Reproduce

1 inport
Create a new survey
Create a group
Create a question i this group
Create a second group
Create a question in this group
Export LSS
Import LSS

 CDbCommand failed to execute the SQL statement: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry '22-en' for key 'lime_idx1_group_ls'. The SQL statement executed was: INSERT INTO `lime_group_l10ns` (`gid`, `group_name`, `description`, `language`) VALUES (:yp0, :yp1, :yp2, :yp3) 

2 copy
Seems need 2 groups and 2 question

 CDbCommand failed to execute the SQL statement: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry '31-en' for key 'lime_idx1_group_ls'. The SQL statement executed was: INSERT INTO `lime_group_l10ns` (`gid`, `group_name`, `description`, `language`) VALUES (:yp0, :yp1, :yp2, :yp3) 
Additional Information

Import multiple old lss is OK.

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0 d34a697454
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionmariadb
Server OS (if known)fedora/linux
Webserver software & version (if known)nginx
PHP Versionphp7.2

Activities

DenisChenu

DenisChenu

2019-07-14 13:24

developer  

CDbException.html (24,767 bytes)
DenisChenu

DenisChenu

2019-07-15 15:34

developer   ~52884

Same with Copy,
On question seems OK
2 group + 2 questions : broke (i activate survey and launch ? Maybe ?)

cdorin

cdorin

2019-07-15 18:23

manager   ~52891

Hmm, could you please attach the problematic survey?

DenisChenu

DenisChenu

2019-07-15 23:41

developer   ~52893

@cdorin : no , you can import a lss, BUT : you can import an just exported lss.

See the copie issue too :

  1. Create a survey with 2 group , one question in each group
  2. Launch survey (test) unsure it's needed
  3. Come back to admin : copy survey just created.
DenisChenu

DenisChenu

2019-08-04 16:43

developer   ~53084

OK, the issue is about import any survey with 2 groups in the new lss version

DenisChenu

DenisChenu

2019-08-05 02:24

developer   ~53086

https://github.com/LimeSurvey/LimeSurvey/commit/37b8d80d572a07169278969b91f5d69ac60abe73

Issue History

Date Modified Username Field Change
2019-07-14 13:24 DenisChenu New Issue
2019-07-14 13:24 DenisChenu File Added: CDbException.html
2019-07-14 13:25 DenisChenu Steps to Reproduce Updated View Revisions
2019-07-15 15:33 DenisChenu Severity minor => major
2019-07-15 15:33 DenisChenu Summary Can't import a exported lss => Can't import a exported lss or copy an existing survey
2019-07-15 15:33 DenisChenu Description Updated View Revisions
2019-07-15 15:33 DenisChenu Steps to Reproduce Updated View Revisions
2019-07-15 15:34 DenisChenu Note Added: 52884
2019-07-15 18:23 cdorin Note Added: 52891
2019-07-15 23:41 DenisChenu Note Added: 52893
2019-07-29 12:20 cdorin Assigned To => p_teichmann
2019-07-29 12:20 cdorin Status new => assigned
2019-08-04 16:43 DenisChenu Assigned To p_teichmann => DenisChenu
2019-08-04 16:43 DenisChenu Note Added: 53084
2019-08-05 02:24 DenisChenu Status assigned => resolved
2019-08-05 02:24 DenisChenu Resolution open => fixed
2019-08-05 02:24 DenisChenu Fixed in Version => 4.0.0-RC3
2019-08-05 02:24 DenisChenu Note Added: 53086