View Issue Details

IDProjectCategoryView StatusLast Update
15043Bug reports[All Projects] Survey takingpublic2019-07-16 09:12
ReporterDSNiFi Assigned ToDenisChenu  
PrioritynoneSeverityblock 
Status closedResolutionduplicate 
Product Version3.17.x 
Target VersionFixed in Version3.17.x 
Summary15043: Responses of Array-Checkbox get lost in Chrome and Firefox
Description

When creating a question of type "Array Checkboxes" the responses will not get saved in Chrome and Firefox. In Edge however the answers will be saved.

This happens most probably because in Chrome/Firefox "java" gets added the beginning of the form variables. In edge this will not happen (see pictures). I'm sure that causes that LimeSurvey will not be able to find the checked boxes.

This makes Array-Checkboxes unusable.

Steps To Reproduce

-Create Survey with question of checkbox-array type.

  • answers will always be empty, no matter what the user enters.
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.17.0+190402
I will donate to the project if issue is resolvedNo
BrowserChrome,Firefox,Edge
Database & DB-Version5.5.62
Server OS (if known)Linux (LimeSurvey docker image: https://hub.docker.com/r/crramirez/limesurvey/)
Webserver software & version (if known)
PHP Version5.5.9-1ubuntu4.29

Relationships

child of 14900 closeddominikvitt numerical array with checkboxes loose all data 

Issue History

Date Modified Username Field Change
2019-07-12 15:34 DSNiFi New Issue
2019-07-12 15:34 DSNiFi File Added: chrome_checkboxen.png
2019-07-12 15:34 DSNiFi File Added: ie_checkboxen.png
2019-07-16 09:11 DenisChenu Relationship added child of 14900
2019-07-16 09:12 DenisChenu Assigned To => DenisChenu
2019-07-16 09:12 DenisChenu Status new => closed
2019-07-16 09:12 DenisChenu Resolution open => duplicate
2019-07-16 09:12 DenisChenu Fixed in Version => 3.17.x
2019-07-16 09:12 DenisChenu Note Added: 52895