View Issue Details

IDProjectCategoryView StatusLast Update
14993Bug reports[All Projects] Statisticspublic2019-07-02 14:29
ReporterfradeffAssigned Todominikvitt 
PrioritynoneSeverityminor 
Status resolvedResolutionfixed 
Product Version3.17.x 
Target VersionFixed in Version3.17.x 
Summary14993: Bug on saving / exporting Statistics
Description

The graphs display well on screen, but I have 2 bugs, confirmed by other admins on the same ls instance:

  1. When exporting all graphs, the zip contain .png files with transparent images of the graphs, without any text/numeric datas...
  2. When exporting the PDF (why pdf?) question by question, it always export the same first graph of the 1st question

My solution, printscreens, works but not very practical

Maybe linked with bug 14655

Steps To Reproduce

Create survey, activate, collect some results, go to https://.../index.php/admin/statistics/sa/index/surveyid/SURVEYID

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.17.4+190529
I will donate to the project if issue is resolvedNo
BrowserFirefox 67.0.2 (64 bits)
Database & DB-Versionmysqlnd 5.0.12-dev - 20150407
Server OS (if known)Debian GNU/Linux 9.9 (stretch)
Webserver software & version (if known)Apache 2.0 Handler 20120211
PHP VersionPHP Version 7.0.33-0+deb9u3

Activities

dominikvitt

dominikvitt

2019-07-02 14:23

developer   ~52660

Export images function actually works, so it isn't really a bug.
I just need to explain how images export really works.
When you click on "Export images" button, program collects all images that are already displayed on the screen.
So, if you go the bottom of the screen too quickly to click on the button, no images or only some images would be exported.

I added a short explanatory message just before this button, so it should be clear how it works.:
"Make sure all images on this screen are loaded before clicking on the button."

https://github.com/LimeSurvey/LimeSurvey/commit/c00e4e99411cb0c6d541873b8205f5bcebb6b688

Also, I can't reproduce the second point.

fradeff

fradeff

2019-07-02 14:29

reporter   ~52661

thanks Dominik, you're great (and I'm a fool... had to think to it before! but as a user forwarded my this issue that she considered as a bug it is maybe usefull you made that fix)

Issue History

Date Modified Username Field Change
2019-06-19 09:41 fradeff New Issue
2019-07-02 11:19 dominikvitt Assigned To => dominikvitt
2019-07-02 11:19 dominikvitt Status new => assigned
2019-07-02 14:23 dominikvitt Status assigned => resolved
2019-07-02 14:23 dominikvitt Resolution open => fixed
2019-07-02 14:23 dominikvitt Fixed in Version => 3.17.x
2019-07-02 14:23 dominikvitt Note Added: 52660
2019-07-02 14:29 fradeff Note Added: 52661